summaryrefslogtreecommitdiffstats
path: root/recipes-core
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2020-10-08 10:51:58 -0400
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-10-08 10:51:58 -0400
commitfcb0c3a663d46c7e8f1f093e27a32a30e9ff2811 (patch)
tree39ade95cf9b099a44bf8115c042c2115b6eb9205 /recipes-core
parent6f7475a1e2cee1beecacac131601b3695dc489b5 (diff)
downloadmeta-virtualization-fcb0c3a663d46c7e8f1f093e27a32a30e9ff2811.tar.gz
kata: cleanup runtime recipe
Some of the dependencies are no longer valid for the kata runtime recipe. This also drops hyperstart as a dependency. With this removal, we need a replacement kernel and initrd for kata. That replacement will happen in future commits. Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-core')
-rw-r--r--recipes-core/kata-containers/kata-runtime/0001-makefile-allow-SKIP_GO_VERSION_CHECK-to-be-overriden.patch26
-rw-r--r--recipes-core/kata-containers/kata-runtime_git.bb21
2 files changed, 37 insertions, 10 deletions
diff --git a/recipes-core/kata-containers/kata-runtime/0001-makefile-allow-SKIP_GO_VERSION_CHECK-to-be-overriden.patch b/recipes-core/kata-containers/kata-runtime/0001-makefile-allow-SKIP_GO_VERSION_CHECK-to-be-overriden.patch
new file mode 100644
index 00000000..b92abeb3
--- /dev/null
+++ b/recipes-core/kata-containers/kata-runtime/0001-makefile-allow-SKIP_GO_VERSION_CHECK-to-be-overriden.patch
@@ -0,0 +1,26 @@
1From 224fedda76bb1b741d09a129a5b43a85cb9ce182 Mon Sep 17 00:00:00 2001
2From: Bruce Ashfield <bruce.ashfield@gmail.com>
3Date: Wed, 7 Oct 2020 23:29:52 -0400
4Subject: [PATCH] makefile: allow SKIP_GO_VERSION_CHECK to be overriden
5
6Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
7---
8 Makefile | 2 +-
9 1 file changed, 1 insertion(+), 1 deletion(-)
10
11diff --git a/Makefile b/Makefile
12index 669c1bd1..4c40278a 100644
13--- a/src/github.com/kata-containers/runtime/Makefile
14+++ b/src/github.com/kata-containers/runtime/Makefile
15@@ -12,7 +12,7 @@ for file in /etc/os-release /usr/lib/os-release; do \
16 fi \
17 done)
18
19-SKIP_GO_VERSION_CHECK=
20+#SKIP_GO_VERSION_CHECK=
21 include golang.mk
22
23 #Get ARCH.
24--
252.19.1
26
diff --git a/recipes-core/kata-containers/kata-runtime_git.bb b/recipes-core/kata-containers/kata-runtime_git.bb
index 4f250f19..403d552e 100644
--- a/recipes-core/kata-containers/kata-runtime_git.bb
+++ b/recipes-core/kata-containers/kata-runtime_git.bb
@@ -4,16 +4,20 @@ LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://src/github.com/kata-containers/runtime/LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" 4LIC_FILES_CHKSUM = "file://src/github.com/kata-containers/runtime/LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
5 5
6GO_IMPORT = "github.com/kata-containers/runtime" 6GO_IMPORT = "github.com/kata-containers/runtime"
7SRCREV = "f4cf2137be58c3778d87a8ee8e258e68d1ede888" 7SRCREV = "04c77eb20e9bd603cab5c711bcbe7c69db58b040"
8SRC_URI = "git://${GO_IMPORT}.git \ 8SRC_URI = "git://${GO_IMPORT}.git \
9 file://0001-makefile-allow-SKIP_GO_VERSION_CHECK-to-be-overriden.patch \
9 " 10 "
10RDEPENDS_${PN}-dev_append = "bash" 11RDEPENDS_${PN}-dev_append = "bash"
12
13CONTAINER_KERNEL ?= ""
14CONTAINER_INITRD ?= ""
11RDEPENDS_${PN} = " \ 15RDEPENDS_${PN} = " \
12 qemu \ 16 qemu \
13 hyperstart \ 17 ${CONTAINER_KERNEL} \
18 ${CONTAINER_INITRD} \
14 " 19 "
15 20DEPENDS += "yq-native"
16# grpc
17 21
18S = "${WORKDIR}/git" 22S = "${WORKDIR}/git"
19 23
@@ -28,6 +32,8 @@ do_compile() {
28 export CGO_LDFLAGS="${LDFLAGS} --sysroot=${STAGING_DIR_TARGET}" 32 export CGO_LDFLAGS="${LDFLAGS} --sysroot=${STAGING_DIR_TARGET}"
29 33
30 cd ${S}/src/${GO_IMPORT} 34 cd ${S}/src/${GO_IMPORT}
35
36 export SKIP_GO_VERSION_CHECK="1"
31 oe_runmake runtime 37 oe_runmake runtime
32} 38}
33 39
@@ -36,7 +42,7 @@ do_install() {
36 cp ${WORKDIR}/git/src/${GO_IMPORT}/kata-runtime ${D}/${bindir} 42 cp ${WORKDIR}/git/src/${GO_IMPORT}/kata-runtime ${D}/${bindir}
37 43
38 mkdir -p ${D}/${datadir}/defaults/kata-containers/ 44 mkdir -p ${D}/${datadir}/defaults/kata-containers/
39 cp ${WORKDIR}/git/src/${GO_IMPORT}/cli/config/configuration.toml ${D}/${datadir}/defaults/kata-containers/ 45 cp ${WORKDIR}/git/src/${GO_IMPORT}/cli/config/configuration-qemu.toml ${D}/${datadir}/defaults/kata-containers/configuration.toml
40 46
41 sed -e 's|/usr/bin/qemu-lite-system-x86_64|/usr/bin/qemu-system-x86_64|' -i ${D}/${datadir}/defaults/kata-containers/configuration.toml 47 sed -e 's|/usr/bin/qemu-lite-system-x86_64|/usr/bin/qemu-system-x86_64|' -i ${D}/${datadir}/defaults/kata-containers/configuration.toml
42 sed -e 's|/usr/share/kata-containers/vmlinuz.container|/var/lib/hyper/kernel|' -i ${D}/${datadir}/defaults/kata-containers/configuration.toml 48 sed -e 's|/usr/share/kata-containers/vmlinuz.container|/var/lib/hyper/kernel|' -i ${D}/${datadir}/defaults/kata-containers/configuration.toml
@@ -47,11 +53,6 @@ do_install() {
47 53
48 # /usr/share/defaults/kata-containers/configuration.toml: file /usr/libexec/kata-containers/kata-shim does not exist 54 # /usr/share/defaults/kata-containers/configuration.toml: file /usr/libexec/kata-containers/kata-shim does not exist
49 # fork/exec /usr/libexec/kata-containers/kata-proxy: no such file or directory 55 # fork/exec /usr/libexec/kata-containers/kata-proxy: no such file or directory
50
51 #64 mknod /dev/kvm c 10 232
52 #68 kata-runtime --log=/dev/stdout run --bundle /opt/container/cube-server foo
53
54
55} 56}
56 57
57FILES_${PN} += "${datadir}/defaults/kata-containers/*" 58FILES_${PN} += "${datadir}/defaults/kata-containers/*"