summaryrefslogtreecommitdiffstats
path: root/recipes-core
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2020-09-30 12:30:40 -0400
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-11-05 14:39:32 -0500
commite9a8756758e44a9fbf0dad7e1b7b197a24355584 (patch)
treed7b898f05da6fdcb367bf8bd063866b47493560b /recipes-core
parent74e0b8d2acc6b9bbc0345a500a700932d70772f4 (diff)
downloadmeta-virtualization-e9a8756758e44a9fbf0dad7e1b7b197a24355584.tar.gz
containers: add a dummy provider for /bin/sh and /bin/env
In some scenarios (and package managers), packages post install scripts may have references to /bin/sh. The package manager doesn't know if the scripts will run on the build host or target, so we get a calculated redepnds on /bin/sh base-files and base-passwd fall into this category of having post installs, but no need for /bin/sh on the target. If you know what you are installing, and want the smallest container possible, this package will satisfy the dependency when assembling the rootfs. To enable it, put the following in a configuration file (local.conf or otherwise): PACKAGE_EXTRA_ARCHS_append = " container-dummy-provides" Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-core')
-rw-r--r--recipes-core/meta/container-dummy-provides.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/recipes-core/meta/container-dummy-provides.bb b/recipes-core/meta/container-dummy-provides.bb
new file mode 100644
index 00000000..2ab42be3
--- /dev/null
+++ b/recipes-core/meta/container-dummy-provides.bb
@@ -0,0 +1,6 @@
1DUMMYARCH = "container-dummy-provides"
2DUMMYPROVIDES = "\
3 /bin/sh \
4 /usr/bin/env \
5"
6require recipes-core/meta/dummy-sdk-package.inc