summaryrefslogtreecommitdiffstats
path: root/recipes-core
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2021-07-28 14:22:43 -0400
committerBruce Ashfield <bruce.ashfield@gmail.com>2021-08-02 17:17:53 -0400
commitd876cfc5bfafa516dee55d04b50b319a22165640 (patch)
treeea03c34f999bd85e440c85fc8e722df8666e2e68 /recipes-core
parent5fdf66c1e2ec0c6b08573bf0a6aa9f84d2fc4ae6 (diff)
downloadmeta-virtualization-d876cfc5bfafa516dee55d04b50b319a22165640.tar.gz
global: overrides syntax conversion
OEcore/bitbake are moving to use the clearer ":" as an overrides separator. This is pass one of updating the meta-virt recipes to use that syntax. This has only been minimally build/runtime tested, more changes will be required for missed overrides, or incorrect conversions Note: A recent bitbake is required: commit 75fad23fc06c008a03414a1fc288a8614c6af9ca Author: Richard Purdie <richard.purdie@linuxfoundation.org> Date: Sun Jul 18 12:59:15 2021 +0100 bitbake: data_smart/parse: Allow ':' characters in variable/function names It is becomming increasingly clear we need to find a way to show what is/is not an override in our syntax. We need to do this in a way which is clear to users, readable and in a way we can transition to. The most effective way I've found to this is to use the ":" charater to directly replace "_" where an override is being specified. This includes "append", "prepend" and "remove" which are effectively special override directives. This patch simply adds the character to the parser so bitbake accepts the value but maps it back to "_" internally so there is no behaviour change. This change is simple enough it could potentially be backported to older version of bitbake meaning layers using the new syntax/markup could work with older releases. Even if other no other changes are accepted at this time and we don't backport, it does set us on a path where at some point in future we could require a more explict syntax. I've tested this patch by converting oe-core/meta-yocto to the new syntax for overrides (9000+ changes) and then seeing that builds continue to work with this patch. (Bitbake rev: 0dbbb4547cb2570d2ce607e9a53459df3c0ac284) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-core')
-rw-r--r--recipes-core/bind/bind_virtualization.inc2
-rw-r--r--recipes-core/busybox/busybox-initrd_1.33.1.bb4
-rw-r--r--recipes-core/busybox/busybox_virtualization.inc2
-rw-r--r--recipes-core/busybox/busybox_vmsep.inc2
-rw-r--r--recipes-core/initscripts/initscripts_virtualization.inc2
-rw-r--r--recipes-core/kata-containers/kata-agent_git.bb4
-rw-r--r--recipes-core/kata-containers/kata-proxy_git.bb2
-rw-r--r--recipes-core/kata-containers/kata-runtime_git.bb6
-rw-r--r--recipes-core/kata-containers/kata-shim_git.bb2
-rw-r--r--recipes-core/libxcrypt/libxcrypt_%.bbappend4
-rw-r--r--recipes-core/packagegroups/packagegroup-container.bb12
-rw-r--r--recipes-core/packagegroups/packagegroup-kubernetes.bb10
-rw-r--r--recipes-core/runv/runv_git.bb6
-rw-r--r--recipes-core/runx/runx_git.bb10
-rw-r--r--recipes-core/sysvinit/sysvinit-inittab_virtualization.inc6
-rw-r--r--recipes-core/sysvinit/sysvinit-inittab_xen.inc2
16 files changed, 38 insertions, 38 deletions
diff --git a/recipes-core/bind/bind_virtualization.inc b/recipes-core/bind/bind_virtualization.inc
index b8f0b3ff..dc63b2aa 100644
--- a/recipes-core/bind/bind_virtualization.inc
+++ b/recipes-core/bind/bind_virtualization.inc
@@ -1,4 +1,4 @@
1# Tell named not to bother listening on the IP address that lxc handles itself. 1# Tell named not to bother listening on the IP address that lxc handles itself.
2do_install_append() { 2do_install:append() {
3 sed -i -e 's,^\( *options *{\)$,\1\n\t// lxc would take care of this address itself\n\tlisten-on { ! 10.0.3.1; any;};\n,' ${D}${sysconfdir}/bind/named.conf.options 3 sed -i -e 's,^\( *options *{\)$,\1\n\t// lxc would take care of this address itself\n\tlisten-on { ! 10.0.3.1; any;};\n,' ${D}${sysconfdir}/bind/named.conf.options
4} 4}
diff --git a/recipes-core/busybox/busybox-initrd_1.33.1.bb b/recipes-core/busybox/busybox-initrd_1.33.1.bb
index 5ce5fa52..6108e9af 100644
--- a/recipes-core/busybox/busybox-initrd_1.33.1.bb
+++ b/recipes-core/busybox/busybox-initrd_1.33.1.bb
@@ -1,4 +1,4 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/busybox-initrd:${COREBASE}/meta/recipes-core/busybox/busybox:${COREBASE}/meta/recipes-core/busybox/files:" 1FILESEXTRAPATHS:prepend := "${THISDIR}/busybox-initrd:${COREBASE}/meta/recipes-core/busybox/busybox:${COREBASE}/meta/recipes-core/busybox/files:"
2 2
3require recipes-core/busybox/busybox_${PV}.bb 3require recipes-core/busybox/busybox_${PV}.bb
4 4
@@ -18,4 +18,4 @@ SECURITY_STRINGFORMAT = ""
18SYSROOT_DIRS += "/bin" 18SYSROOT_DIRS += "/bin"
19BUSYBOX_SPLIT_SUID = "0" 19BUSYBOX_SPLIT_SUID = "0"
20 20
21FILES_${PN} += "${sysconfdir}/init.d/*" 21FILES:${PN} += "${sysconfdir}/init.d/*"
diff --git a/recipes-core/busybox/busybox_virtualization.inc b/recipes-core/busybox/busybox_virtualization.inc
index 15f19308..652f389d 100644
--- a/recipes-core/busybox/busybox_virtualization.inc
+++ b/recipes-core/busybox/busybox_virtualization.inc
@@ -1,4 +1,4 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/busybox:" 1FILESEXTRAPATHS:prepend := "${THISDIR}/busybox:"
2 2
3SRC_URI += " \ 3SRC_URI += " \
4 file://lspci.cfg \ 4 file://lspci.cfg \
diff --git a/recipes-core/busybox/busybox_vmsep.inc b/recipes-core/busybox/busybox_vmsep.inc
index d4b1e6cc..566cd6d5 100644
--- a/recipes-core/busybox/busybox_vmsep.inc
+++ b/recipes-core/busybox/busybox_vmsep.inc
@@ -1,4 +1,4 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/busybox:" 1FILESEXTRAPATHS:prepend := "${THISDIR}/busybox:"
2SRC_URI += " \ 2SRC_URI += " \
3 file://static.cfg \ 3 file://static.cfg \
4 " 4 "
diff --git a/recipes-core/initscripts/initscripts_virtualization.inc b/recipes-core/initscripts/initscripts_virtualization.inc
index 0600ab2a..db9c5535 100644
--- a/recipes-core/initscripts/initscripts_virtualization.inc
+++ b/recipes-core/initscripts/initscripts_virtualization.inc
@@ -1,4 +1,4 @@
1do_install_append() { 1do_install:append() {
2 2
3 echo >> ${D}${sysconfdir}/init.d/functions 3 echo >> ${D}${sysconfdir}/init.d/functions
4 echo success \(\) \{ >> ${D}${sysconfdir}/init.d/functions 4 echo success \(\) \{ >> ${D}${sysconfdir}/init.d/functions
diff --git a/recipes-core/kata-containers/kata-agent_git.bb b/recipes-core/kata-containers/kata-agent_git.bb
index 3632ee52..e154321e 100644
--- a/recipes-core/kata-containers/kata-agent_git.bb
+++ b/recipes-core/kata-containers/kata-agent_git.bb
@@ -8,7 +8,7 @@ SRCREV = "e03f7d7453fabffb17e1540f28666c26178d3cbf"
8SRC_URI = "git://${GO_IMPORT}.git \ 8SRC_URI = "git://${GO_IMPORT}.git \
9 " 9 "
10 10
11RDEPENDS_${PN}-dev_append = "bash" 11RDEPENDS:${PN}-dev:append = "bash"
12 12
13S = "${WORKDIR}/git" 13S = "${WORKDIR}/git"
14 14
@@ -36,4 +36,4 @@ do_install() {
36 36
37deltask compile_ptest_base 37deltask compile_ptest_base
38 38
39FILES_${PN} += "${systemd_unitdir}/*" \ No newline at end of file 39FILES:${PN} += "${systemd_unitdir}/*" \ No newline at end of file
diff --git a/recipes-core/kata-containers/kata-proxy_git.bb b/recipes-core/kata-containers/kata-proxy_git.bb
index 8de0bfcf..7e31355e 100644
--- a/recipes-core/kata-containers/kata-proxy_git.bb
+++ b/recipes-core/kata-containers/kata-proxy_git.bb
@@ -8,7 +8,7 @@ SRCREV = "1148847739f9a9f47b92e34e4f309dc109d4dba9"
8SRC_URI = "git://${GO_IMPORT}.git \ 8SRC_URI = "git://${GO_IMPORT}.git \
9 " 9 "
10 10
11RDEPENDS_${PN}-dev_append = "bash" 11RDEPENDS:${PN}-dev:append = "bash"
12 12
13S = "${WORKDIR}/git" 13S = "${WORKDIR}/git"
14 14
diff --git a/recipes-core/kata-containers/kata-runtime_git.bb b/recipes-core/kata-containers/kata-runtime_git.bb
index 403d552e..79ab87e4 100644
--- a/recipes-core/kata-containers/kata-runtime_git.bb
+++ b/recipes-core/kata-containers/kata-runtime_git.bb
@@ -8,11 +8,11 @@ SRCREV = "04c77eb20e9bd603cab5c711bcbe7c69db58b040"
8SRC_URI = "git://${GO_IMPORT}.git \ 8SRC_URI = "git://${GO_IMPORT}.git \
9 file://0001-makefile-allow-SKIP_GO_VERSION_CHECK-to-be-overriden.patch \ 9 file://0001-makefile-allow-SKIP_GO_VERSION_CHECK-to-be-overriden.patch \
10 " 10 "
11RDEPENDS_${PN}-dev_append = "bash" 11RDEPENDS:${PN}-dev:append = "bash"
12 12
13CONTAINER_KERNEL ?= "" 13CONTAINER_KERNEL ?= ""
14CONTAINER_INITRD ?= "" 14CONTAINER_INITRD ?= ""
15RDEPENDS_${PN} = " \ 15RDEPENDS:${PN} = " \
16 qemu \ 16 qemu \
17 ${CONTAINER_KERNEL} \ 17 ${CONTAINER_KERNEL} \
18 ${CONTAINER_INITRD} \ 18 ${CONTAINER_INITRD} \
@@ -55,6 +55,6 @@ do_install() {
55 # fork/exec /usr/libexec/kata-containers/kata-proxy: no such file or directory 55 # fork/exec /usr/libexec/kata-containers/kata-proxy: no such file or directory
56} 56}
57 57
58FILES_${PN} += "${datadir}/defaults/kata-containers/*" 58FILES:${PN} += "${datadir}/defaults/kata-containers/*"
59 59
60deltask compile_ptest_base 60deltask compile_ptest_base
diff --git a/recipes-core/kata-containers/kata-shim_git.bb b/recipes-core/kata-containers/kata-shim_git.bb
index fb55a8e7..a0e965ec 100644
--- a/recipes-core/kata-containers/kata-shim_git.bb
+++ b/recipes-core/kata-containers/kata-shim_git.bb
@@ -8,7 +8,7 @@ SRCREV = "bcc35aeca3ef6fa0976005c9e93525906aefed2f"
8SRC_URI = "git://${GO_IMPORT}.git \ 8SRC_URI = "git://${GO_IMPORT}.git \
9 " 9 "
10 10
11RDEPENDS_${PN}-dev_append = "bash" 11RDEPENDS:${PN}-dev:append = "bash"
12 12
13S = "${WORKDIR}/git" 13S = "${WORKDIR}/git"
14 14
diff --git a/recipes-core/libxcrypt/libxcrypt_%.bbappend b/recipes-core/libxcrypt/libxcrypt_%.bbappend
index 0b4fbb3d..55e453d9 100644
--- a/recipes-core/libxcrypt/libxcrypt_%.bbappend
+++ b/recipes-core/libxcrypt/libxcrypt_%.bbappend
@@ -1,4 +1,4 @@
1# if vmsep is in distro features, we need a static libxycryp, so we can build 1# if vmsep is in distro features, we need a static libxycryp, so we can build
2# a static busybox. The end result of this is: 2# a static busybox. The end result of this is:
3# EXTRA_OECONF_remove = "--disable-static" 3# EXTRA_OECONF:remove = "--disable-static"
4EXTRA_OECONF_remove = "${@bb.utils.contains('DISTRO_FEATURES', 'vmsep', '--disable-static', '', d)}" 4EXTRA_OECONF:remove = "${@bb.utils.contains('DISTRO_FEATURES', 'vmsep', '--disable-static', '', d)}"
diff --git a/recipes-core/packagegroups/packagegroup-container.bb b/recipes-core/packagegroups/packagegroup-container.bb
index 89b9c01c..82d4a2e7 100644
--- a/recipes-core/packagegroups/packagegroup-container.bb
+++ b/recipes-core/packagegroups/packagegroup-container.bb
@@ -16,32 +16,32 @@ PACKAGES = "\
16 16
17# everything and the kitchen sink, used for building/installing 17# everything and the kitchen sink, used for building/installing
18# many things at once. 18# many things at once.
19RDEPENDS_${PN} = " \ 19RDEPENDS:${PN} = " \
20 packagegroup-lxc \ 20 packagegroup-lxc \
21 packagegroup-docker \ 21 packagegroup-docker \
22 packagegroup-oci \ 22 packagegroup-oci \
23" 23"
24 24
25RDEPENDS_packagegroup-lxc = " \ 25RDEPENDS:packagegroup-lxc = " \
26 lxc \ 26 lxc \
27" 27"
28 28
29RDEPENDS_packagegroup-docker = " \ 29RDEPENDS:packagegroup-docker = " \
30 docker \ 30 docker \
31" 31"
32 32
33RDEPENDS_packagegroup-podman = " \ 33RDEPENDS:packagegroup-podman = " \
34 podman \ 34 podman \
35" 35"
36 36
37RDEPENDS_packagegroup-oci = " \ 37RDEPENDS:packagegroup-oci = " \
38 virtual/runc \ 38 virtual/runc \
39 oci-systemd-hook \ 39 oci-systemd-hook \
40 oci-runtime-tools \ 40 oci-runtime-tools \
41 oci-image-tools \ 41 oci-image-tools \
42" 42"
43 43
44RDEPENDS_packagegroup-containerd = " \ 44RDEPENDS:packagegroup-containerd = " \
45 virtual/containerd \ 45 virtual/containerd \
46" 46"
47 47
diff --git a/recipes-core/packagegroups/packagegroup-kubernetes.bb b/recipes-core/packagegroups/packagegroup-kubernetes.bb
index 237e72e8..8bfe942e 100644
--- a/recipes-core/packagegroups/packagegroup-kubernetes.bb
+++ b/recipes-core/packagegroups/packagegroup-kubernetes.bb
@@ -18,26 +18,26 @@ PACKAGES = "\
18 18
19KUBERNETES_CRI ?= "containerd" 19KUBERNETES_CRI ?= "containerd"
20 20
21RDEPENDS_packagegroup-kubernetes-base = " \ 21RDEPENDS:packagegroup-kubernetes-base = " \
22 packagegroup-${KUBERNETES_CRI} \ 22 packagegroup-${KUBERNETES_CRI} \
23 packagegroup-oci \ 23 packagegroup-oci \
24" 24"
25 25
26RDEPENDS_packagegroup-k8s-host = " \ 26RDEPENDS:packagegroup-k8s-host = " \
27 packagegroup-kubernetes-base \ 27 packagegroup-kubernetes-base \
28" 28"
29 29
30RDEPENDS_packagegroup-k8s-node = " \ 30RDEPENDS:packagegroup-k8s-node = " \
31 packagegroup-kubernetes-base \ 31 packagegroup-kubernetes-base \
32" 32"
33 33
34RDEPENDS_packagegroup-k3s-host = " \ 34RDEPENDS:packagegroup-k3s-host = " \
35 packagegroup-kubernetes-base \ 35 packagegroup-kubernetes-base \
36 k3s-server \ 36 k3s-server \
37 k3s-cni \ 37 k3s-cni \
38" 38"
39 39
40RDEPENDS_packagegroup-k3s-node = " \ 40RDEPENDS:packagegroup-k3s-node = " \
41 packagegroup-kubernetes-base \ 41 packagegroup-kubernetes-base \
42 k3s-agent \ 42 k3s-agent \
43 k3s-cni \ 43 k3s-cni \
diff --git a/recipes-core/runv/runv_git.bb b/recipes-core/runv/runv_git.bb
index ef94f096..af19de81 100644
--- a/recipes-core/runv/runv_git.bb
+++ b/recipes-core/runv/runv_git.bb
@@ -22,7 +22,7 @@ inherit autotools-brokensep
22PACKAGECONFIG[xen] = "--with-xen,--without-xen," 22PACKAGECONFIG[xen] = "--with-xen,--without-xen,"
23AUTOTOOLS_SCRIPT_PATH = "${S}/src/import/" 23AUTOTOOLS_SCRIPT_PATH = "${S}/src/import/"
24 24
25RDEPENDS_${PN} += " qemu hyperstart" 25RDEPENDS:${PN} += " qemu hyperstart"
26 26
27do_compile() { 27do_compile() {
28 export GOARCH="${TARGET_GOARCH}" 28 export GOARCH="${TARGET_GOARCH}"
@@ -76,6 +76,6 @@ do_install() {
76 76
77deltask compile_ptest_base 77deltask compile_ptest_base
78 78
79FILES_${PN} += "/usr/local/bin/*" 79FILES:${PN} += "/usr/local/bin/*"
80 80
81INSANE_SKIP_${PN} += "ldflags already-stripped" 81INSANE_SKIP:${PN} += "ldflags already-stripped"
diff --git a/recipes-core/runx/runx_git.bb b/recipes-core/runx/runx_git.bb
index 89783a0e..7c9232b8 100644
--- a/recipes-core/runx/runx_git.bb
+++ b/recipes-core/runx/runx_git.bb
@@ -41,9 +41,9 @@ DEPENDS += "openssl-native coreutils-native util-linux-native xz-native bc-nativ
41DEPENDS += "elfutils-native" 41DEPENDS += "elfutils-native"
42DEPENDS += "qemu-native bison-native" 42DEPENDS += "qemu-native bison-native"
43 43
44RDEPENDS_${PN} += " jq bash" 44RDEPENDS:${PN} += " jq bash"
45RDEPENDS_${PN} += " xen-tools-xl go-build socat daemonize" 45RDEPENDS:${PN} += " xen-tools-xl go-build socat daemonize"
46RDEPENDS_${PN} += " qemu-system-i386 ca-certificates qemu qemu-keymaps" 46RDEPENDS:${PN} += " qemu-system-i386 ca-certificates qemu qemu-keymaps"
47 47
48RUNX_USE_INTERNAL_BUSYBOX ?= "" 48RUNX_USE_INTERNAL_BUSYBOX ?= ""
49 49
@@ -120,7 +120,7 @@ do_install() {
120 120
121deltask compile_ptest_base 121deltask compile_ptest_base
122 122
123FILES_${PN} += "${bindir}/* ${datadir}/runX/*" 123FILES:${PN} += "${bindir}/* ${datadir}/runX/*"
124 124
125INHIBIT_PACKAGE_STRIP = "1" 125INHIBIT_PACKAGE_STRIP = "1"
126INSANE_SKIP_${PN} += "ldflags already-stripped" 126INSANE_SKIP:${PN} += "ldflags already-stripped"
diff --git a/recipes-core/sysvinit/sysvinit-inittab_virtualization.inc b/recipes-core/sysvinit/sysvinit-inittab_virtualization.inc
index 9e796efd..bf52da0e 100644
--- a/recipes-core/sysvinit/sysvinit-inittab_virtualization.inc
+++ b/recipes-core/sysvinit/sysvinit-inittab_virtualization.inc
@@ -1,9 +1,9 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/files:" 1FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
2 2
3SRC_URI += "file://getty-wrapper" 3SRC_URI += "file://getty-wrapper"
4 4
5do_install_append() { 5do_install:append() {
6 install -d ${D}${base_sbindir} 6 install -d ${D}${base_sbindir}
7 install -m 0755 ${WORKDIR}/getty-wrapper ${D}${base_sbindir}/getty-wrapper 7 install -m 0755 ${WORKDIR}/getty-wrapper ${D}${base_sbindir}/getty-wrapper
8} 8}
9FILES_${PN} += "${base_sbindir}/getty-wrapper" 9FILES:${PN} += "${base_sbindir}/getty-wrapper"
diff --git a/recipes-core/sysvinit/sysvinit-inittab_xen.inc b/recipes-core/sysvinit/sysvinit-inittab_xen.inc
index de0af20b..7f92bd1f 100644
--- a/recipes-core/sysvinit/sysvinit-inittab_xen.inc
+++ b/recipes-core/sysvinit/sysvinit-inittab_xen.inc
@@ -1,4 +1,4 @@
1do_install_append() { 1do_install:append() {
2 echo "" >> ${D}${sysconfdir}/inittab 2 echo "" >> ${D}${sysconfdir}/inittab
3 echo "X0:12345:respawn:${base_sbindir}/getty-wrapper 115200 hvc0" >> ${D}${sysconfdir}/inittab 3 echo "X0:12345:respawn:${base_sbindir}/getty-wrapper 115200 hvc0" >> ${D}${sysconfdir}/inittab
4} 4}