summaryrefslogtreecommitdiffstats
path: root/recipes-core
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2020-09-21 17:29:23 -0700
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-09-22 15:51:13 -0400
commitd0ef2f0bf7551383cdb9f9adc3167530d674b22c (patch)
treeeb6ba1c2ff65d24bf925a1dbb832a16522b05bea /recipes-core
parentbaf30af86f0da867f688246b8af37713986228a7 (diff)
downloadmeta-virtualization-d0ef2f0bf7551383cdb9f9adc3167530d674b22c.tar.gz
busybox: add initrd variant
Add a busybox variant that inherits almost all of its support from the core busybox recipe, but adds configuration values that are appropriate to be used in an initrd. In particular: - we build busybox statically - we enable runlevel and init functionality - mdev is always enabled - applet install support is enabled Signed-off-by: Bruce Ashfield <bruce.ashfield@xilinx.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-core')
-rw-r--r--recipes-core/busybox/busybox-initrd/initrd.cfg14
-rw-r--r--recipes-core/busybox/busybox-initrd/runx.cfg1
-rw-r--r--recipes-core/busybox/busybox-initrd_1.32.0.bb20
3 files changed, 35 insertions, 0 deletions
diff --git a/recipes-core/busybox/busybox-initrd/initrd.cfg b/recipes-core/busybox/busybox-initrd/initrd.cfg
new file mode 100644
index 00000000..9f64c4c6
--- /dev/null
+++ b/recipes-core/busybox/busybox-initrd/initrd.cfg
@@ -0,0 +1,14 @@
1CONFIG_INIT=y
2CNOFIG_FEATURE_UTMP=y
3CONFIG_RUNLEVEL=y
4CONFIG_FEATURE_USE_INITTAB=y
5CONFIG_HALT=y
6CONFIG_POWEROFF=y
7CONFIG_FEATURE_KILL_DELAY=0
8CONFIG_TELINIT_PATH=""
9CONFIG_INIT_TERMINAL_TYPE=""
10
11# CONFIG_FEATURE_SHADOWPASSWDS is not set
12CONFIG_USE_BB_PWD_GRP=y
13
14CONFIG_STATIC=y
diff --git a/recipes-core/busybox/busybox-initrd/runx.cfg b/recipes-core/busybox/busybox-initrd/runx.cfg
new file mode 100644
index 00000000..1f1ac6af
--- /dev/null
+++ b/recipes-core/busybox/busybox-initrd/runx.cfg
@@ -0,0 +1 @@
CONFIG_FEATURE_INSTALLER=y
diff --git a/recipes-core/busybox/busybox-initrd_1.32.0.bb b/recipes-core/busybox/busybox-initrd_1.32.0.bb
new file mode 100644
index 00000000..82edb570
--- /dev/null
+++ b/recipes-core/busybox/busybox-initrd_1.32.0.bb
@@ -0,0 +1,20 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/busybox-initrd:${COREBASE}/meta/recipes-core/busybox/busybox:${COREBASE}/meta/recipes-core/busybox/files:"
2
3require recipes-core/busybox/busybox_${PV}.bb
4
5SRC_URI += "file://init.cfg \
6 file://mdev.cfg \
7 file://runx.cfg \
8 file://initrd.cfg"
9
10S = "${WORKDIR}/busybox-${PV}"
11
12# override security-flags settings, we have some warnings to ignore
13SECURITY_STRINGFORMAT = ""
14
15# we do this to get the target binary available to recipes that
16# depend on busybox
17SYSROOT_DIRS += "/bin"
18BUSYBOX_SPLIT_SUID = "0"
19
20FILES_${PN} += "${sysconfdir}/init.d/*"