summaryrefslogtreecommitdiffstats
path: root/recipes-core
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2022-06-03 09:16:55 -0400
committerBruce Ashfield <bruce.ashfield@gmail.com>2022-06-03 09:31:54 -0400
commit6e2826e6f54c7966134304e82997441fac8fa374 (patch)
tree30978e2b0143044bb43d0622c0953e17b7b59fce /recipes-core
parentcba2694dac0141026cbba5452fe9431a2ce76ded (diff)
downloadmeta-virtualization-6e2826e6f54c7966134304e82997441fac8fa374.tar.gz
kata-containers: add protocol=https to SRC_URIs
Although the components of kata containers aren't functional, we keep it around in case someone is interested in fixing the recipe. It was skipped from the global protocol=https addition for that reason .. but in case someone is running global/world fetches, this can cause a problem. So we add the missing procotol specification. Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-core')
-rw-r--r--recipes-core/kata-containers/kata-agent_git.bb4
-rw-r--r--recipes-core/kata-containers/kata-proxy_git.bb2
-rw-r--r--recipes-core/kata-containers/kata-runtime_git.bb2
-rw-r--r--recipes-core/kata-containers/kata-shim_git.bb2
4 files changed, 5 insertions, 5 deletions
diff --git a/recipes-core/kata-containers/kata-agent_git.bb b/recipes-core/kata-containers/kata-agent_git.bb
index ca552b9f..940b926f 100644
--- a/recipes-core/kata-containers/kata-agent_git.bb
+++ b/recipes-core/kata-containers/kata-agent_git.bb
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://src/github.com/kata-containers/agent/LICENSE;md5=86d3
5 5
6GO_IMPORT = "github.com/kata-containers/agent" 6GO_IMPORT = "github.com/kata-containers/agent"
7SRCREV = "e03f7d7453fabffb17e1540f28666c26178d3cbf" 7SRCREV = "e03f7d7453fabffb17e1540f28666c26178d3cbf"
8SRC_URI = "git://${GO_IMPORT}.git;branch=master \ 8SRC_URI = "git://${GO_IMPORT}.git;branch=master;protocol=https \
9 " 9 "
10 10
11RDEPENDS:${PN}-dev:append = "bash" 11RDEPENDS:${PN}-dev:append = "bash"
@@ -36,4 +36,4 @@ do_install() {
36 36
37deltask compile_ptest_base 37deltask compile_ptest_base
38 38
39FILES:${PN} += "${systemd_unitdir}/*" \ No newline at end of file 39FILES:${PN} += "${systemd_unitdir}/*"
diff --git a/recipes-core/kata-containers/kata-proxy_git.bb b/recipes-core/kata-containers/kata-proxy_git.bb
index cbce8241..c41e0e06 100644
--- a/recipes-core/kata-containers/kata-proxy_git.bb
+++ b/recipes-core/kata-containers/kata-proxy_git.bb
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://src/github.com/kata-containers/proxy/LICENSE;md5=86d3
5 5
6GO_IMPORT = "github.com/kata-containers/proxy" 6GO_IMPORT = "github.com/kata-containers/proxy"
7SRCREV = "1148847739f9a9f47b92e34e4f309dc109d4dba9" 7SRCREV = "1148847739f9a9f47b92e34e4f309dc109d4dba9"
8SRC_URI = "git://${GO_IMPORT}.git;branch=master \ 8SRC_URI = "git://${GO_IMPORT}.git;branch=master;protocol=https \
9 " 9 "
10 10
11RDEPENDS:${PN}-dev:append = "bash" 11RDEPENDS:${PN}-dev:append = "bash"
diff --git a/recipes-core/kata-containers/kata-runtime_git.bb b/recipes-core/kata-containers/kata-runtime_git.bb
index c7f156f0..4573f49f 100644
--- a/recipes-core/kata-containers/kata-runtime_git.bb
+++ b/recipes-core/kata-containers/kata-runtime_git.bb
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://src/github.com/kata-containers/runtime/LICENSE;md5=86
5 5
6GO_IMPORT = "github.com/kata-containers/runtime" 6GO_IMPORT = "github.com/kata-containers/runtime"
7SRCREV = "04c77eb20e9bd603cab5c711bcbe7c69db58b040" 7SRCREV = "04c77eb20e9bd603cab5c711bcbe7c69db58b040"
8SRC_URI = "git://${GO_IMPORT}.git;branch=master \ 8SRC_URI = "git://${GO_IMPORT}.git;branch=master;protocol=https \
9 file://0001-makefile-allow-SKIP_GO_VERSION_CHECK-to-be-overriden.patch \ 9 file://0001-makefile-allow-SKIP_GO_VERSION_CHECK-to-be-overriden.patch \
10 " 10 "
11RDEPENDS:${PN}-dev:append = "bash" 11RDEPENDS:${PN}-dev:append = "bash"
diff --git a/recipes-core/kata-containers/kata-shim_git.bb b/recipes-core/kata-containers/kata-shim_git.bb
index 467df261..2c67554c 100644
--- a/recipes-core/kata-containers/kata-shim_git.bb
+++ b/recipes-core/kata-containers/kata-shim_git.bb
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://src/github.com/kata-containers/shim/LICENSE;md5=86d3f
5 5
6GO_IMPORT = "github.com/kata-containers/shim" 6GO_IMPORT = "github.com/kata-containers/shim"
7SRCREV = "bcc35aeca3ef6fa0976005c9e93525906aefed2f" 7SRCREV = "bcc35aeca3ef6fa0976005c9e93525906aefed2f"
8SRC_URI = "git://${GO_IMPORT}.git;branch=master \ 8SRC_URI = "git://${GO_IMPORT}.git;branch=master;protocol=https \
9 " 9 "
10 10
11RDEPENDS:${PN}-dev:append = "bash" 11RDEPENDS:${PN}-dev:append = "bash"