summaryrefslogtreecommitdiffstats
path: root/recipes-core
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2021-04-02 09:02:44 +0200
committerBruce Ashfield <bruce.ashfield@gmail.com>2021-04-06 20:33:53 -0400
commit4ea3d7682103a19496f257a4425a4ee150c21722 (patch)
treeb61bf85e8c91ffa0ce30009903e9687754ed8814 /recipes-core
parent1dda063e0cd9084697e6c205baf44e6b2397ad1a (diff)
downloadmeta-virtualization-4ea3d7682103a19496f257a4425a4ee150c21722.tar.gz
packagegroup-container: skip without meta-security because of podman
* copy the skip from podman recipe, because this packagegroup depends on podman Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-core')
-rw-r--r--recipes-core/packagegroups/packagegroup-container.bb9
1 files changed, 9 insertions, 0 deletions
diff --git a/recipes-core/packagegroups/packagegroup-container.bb b/recipes-core/packagegroups/packagegroup-container.bb
index d425ac58..b3b0d4c3 100644
--- a/recipes-core/packagegroups/packagegroup-container.bb
+++ b/recipes-core/packagegroups/packagegroup-container.bb
@@ -44,3 +44,12 @@ RDEPENDS_packagegroup-containerd = " \
44 virtual/containerd \ 44 virtual/containerd \
45" 45"
46 46
47python __anonymous() {
48 msg = ""
49 # ERROR: Nothing PROVIDES 'libseccomp' (but meta-virtualization/recipes-containers/podman/ DEPENDS on or otherwise requires it).
50 # ERROR: Required build target 'meta-world-pkgdata' has no buildable providers.
51 # Missing or unbuildable dependency chain was: ['meta-world-pkgdata', 'podman', 'libseccomp']
52 if 'security' not in d.getVar('BBFILE_COLLECTIONS').split():
53 msg += "Make sure meta-security should be present as it provides 'libseccomp'"
54 raise bb.parse.SkipRecipe(msg)
55}