summaryrefslogtreecommitdiffstats
path: root/recipes-core
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2021-04-03 21:51:31 +0200
committerBruce Ashfield <bruce.ashfield@gmail.com>2021-04-06 20:34:26 -0400
commit04f8621d8213630e3072321c68089ac147e21ebe (patch)
tree0478365a34ae96ab61584583653f7689aaf4dab9 /recipes-core
parent4c073402756248acd32b209b7b8a5e1fe328b13b (diff)
downloadmeta-virtualization-04f8621d8213630e3072321c68089ac147e21ebe.tar.gz
cri-o, podman, packagegroup-container: replace anonymous python function calling bb.parse.SkipRecipe with conditional PNBLACKLISTs
* PNBLACKLISTs are IMHO a bit easier to read and easier to override from distro which e.g. provides own recipe for libseccomp Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-core')
-rw-r--r--recipes-core/packagegroups/packagegroup-container.bb10
1 files changed, 1 insertions, 9 deletions
diff --git a/recipes-core/packagegroups/packagegroup-container.bb b/recipes-core/packagegroups/packagegroup-container.bb
index b3b0d4c3..b06a7c74 100644
--- a/recipes-core/packagegroups/packagegroup-container.bb
+++ b/recipes-core/packagegroups/packagegroup-container.bb
@@ -44,12 +44,4 @@ RDEPENDS_packagegroup-containerd = " \
44 virtual/containerd \ 44 virtual/containerd \
45" 45"
46 46
47python __anonymous() { 47PNBLACKLIST[packagegroup-container] ?= "${@bb.utils.contains('BBFILE_COLLECTIONS', 'security', '', 'Depends on podman which depends on libseccomp from meta-security which is not included', d)}"
48 msg = ""
49 # ERROR: Nothing PROVIDES 'libseccomp' (but meta-virtualization/recipes-containers/podman/ DEPENDS on or otherwise requires it).
50 # ERROR: Required build target 'meta-world-pkgdata' has no buildable providers.
51 # Missing or unbuildable dependency chain was: ['meta-world-pkgdata', 'podman', 'libseccomp']
52 if 'security' not in d.getVar('BBFILE_COLLECTIONS').split():
53 msg += "Make sure meta-security should be present as it provides 'libseccomp'"
54 raise bb.parse.SkipRecipe(msg)
55}