summaryrefslogtreecommitdiffstats
path: root/recipes-core/runx/runx_git.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2020-06-18 10:44:59 -0400
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-06-18 10:44:59 -0400
commit73fff505780467b7bd3d58ccbd39a22332849e41 (patch)
treea4ca0bf3c55bf6cc23829edc6c2d45f9a5a51d80 /recipes-core/runx/runx_git.bb
parent9765cee9e9b55168c539c7bc17323d4ad2e7a995 (diff)
downloadmeta-virtualization-73fff505780467b7bd3d58ccbd39a22332849e41.tar.gz
runx: update to v5.4 kernel
Updating to the tip of the runx repository. This brings in some build changes, as well as introducing the v5.4 kernel. Our patches for cross compilation need to be tweaked to the new structure, as well as the install task to pickup the new location of some files. Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-core/runx/runx_git.bb')
-rw-r--r--recipes-core/runx/runx_git.bb16
1 files changed, 8 insertions, 8 deletions
diff --git a/recipes-core/runx/runx_git.bb b/recipes-core/runx/runx_git.bb
index 3b4cd335..991e6e1f 100644
--- a/recipes-core/runx/runx_git.bb
+++ b/recipes-core/runx/runx_git.bb
@@ -2,15 +2,15 @@ HOMEPAGE = "https://github.com/lf-edge/runx"
2SUMMARY = "runx stuff" 2SUMMARY = "runx stuff"
3DESCRIPTION = "Xen Runtime for OCI" 3DESCRIPTION = "Xen Runtime for OCI"
4 4
5SRCREV_runx = "da0c75c58ae5232d19b1791c33545db3225e1ea9" 5SRCREV_runx = "f24efd33fb18469e9cfe4d1bfe8e2c90ec8c4e93"
6SRC_URI = "\ 6SRC_URI = "\
7 git://github.com/lf-edge/runx;nobranch=1;name=runx \ 7 git://github.com/lf-edge/runx;nobranch=1;name=runx \
8 https://www.kernel.org/pub/linux/kernel/v4.x/linux-4.15.tar.xz;destsuffix=git/kernel/build \ 8 https://www.kernel.org/pub/linux/kernel/v5.x/linux-5.4.tar.xz;destsuffix=git/kernel/build \
9 file://0001-make-kernel-cross-compilation-tweaks.patch \ 9 file://0001-make-kernel-cross-compilation-tweaks.patch \
10 file://0001-make-initrd-cross-install-tweaks.patch \ 10 file://0001-make-initrd-cross-install-tweaks.patch \
11 " 11 "
12SRC_URI[md5sum] = "0d701ac1e2a67d47ce7127432df2c32b" 12SRC_URI[md5sum] = "ce9b2d974d27408a61c53a30d3f98fb9"
13SRC_URI[sha256sum] = "5a26478906d5005f4f809402e981518d2b8844949199f60c4b6e1f986ca2a769" 13SRC_URI[sha256sum] = "bf338980b1670bca287f9994b7441c2361907635879169c64ae78364efc5f491"
14 14
15LICENSE = "Apache-2.0" 15LICENSE = "Apache-2.0"
16LIC_FILES_CHKSUM = "file://LICENSE;md5=945fc9aa694796a6337395cc291ddd8c" 16LIC_FILES_CHKSUM = "file://LICENSE;md5=945fc9aa694796a6337395cc291ddd8c"
@@ -31,7 +31,7 @@ DEPENDS = "busybox go-build"
31 31
32# for the kernel build phase 32# for the kernel build phase
33DEPENDS += "openssl-native coreutils-native util-linux-native xz-native bc-native" 33DEPENDS += "openssl-native coreutils-native util-linux-native xz-native bc-native"
34DEPENDS += "qemu-native" 34DEPENDS += "qemu-native bison-native"
35 35
36RDEPENDS_${PN} += " jq bash" 36RDEPENDS_${PN} += " jq bash"
37RDEPENDS_${PN} += " xen-tools-xl go-build socat daemonize" 37RDEPENDS_${PN} += " xen-tools-xl go-build socat daemonize"
@@ -77,7 +77,7 @@ do_compile() {
77 export QEMU_USER=`which qemu-${HOST_ARCH}` 77 export QEMU_USER=`which qemu-${HOST_ARCH}`
78 export BUSYBOX="${WORKDIR}/busybox" 78 export BUSYBOX="${WORKDIR}/busybox"
79 export CROSS_COMPILE="t" 79 export CROSS_COMPILE="t"
80 ${S}/kernel/make-initrd 80 ${S}/initrd/make-initrd
81} 81}
82 82
83do_install() { 83do_install() {
@@ -86,11 +86,11 @@ do_install() {
86 86
87 install -d ${D}${datadir}/runX 87 install -d ${D}${datadir}/runX
88 install -m 755 ${S}/kernel/out/kernel ${D}/${datadir}/runX 88 install -m 755 ${S}/kernel/out/kernel ${D}/${datadir}/runX
89 install -m 755 ${S}/kernel/out/initrd ${D}/${datadir}/runX 89 install -m 755 ${S}/initrd/out/initrd ${D}/${datadir}/runX
90 install -m 755 ${S}/files/start ${D}/${datadir}/runX 90 install -m 755 ${S}/files/start ${D}/${datadir}/runX
91 install -m 755 ${S}/files/create ${D}/${datadir}/runX
91 install -m 755 ${S}/files/state ${D}/${datadir}/runX 92 install -m 755 ${S}/files/state ${D}/${datadir}/runX
92 install -m 755 ${S}/files/delete ${D}/${datadir}/runX 93 install -m 755 ${S}/files/delete ${D}/${datadir}/runX
93 install -m 755 ${S}/files/serial_bridge ${D}/${datadir}/runX
94 install -m 755 ${S}/files/serial_start ${D}/${datadir}/runX 94 install -m 755 ${S}/files/serial_start ${D}/${datadir}/runX
95 95
96 96