summaryrefslogtreecommitdiffstats
path: root/recipes-core/kata-containers/kata-agent_git.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2018-10-04 09:34:16 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2018-11-05 10:22:54 -0500
commitd9c64d8aa0d7c5ca8d55e1443684c243b01186f0 (patch)
treee8dd7866dfd9e089abd5e7e8efea02a198f131cc /recipes-core/kata-containers/kata-agent_git.bb
parent100fb480e7fa7646682891307a9091e07e7981cd (diff)
downloadmeta-virtualization-d9c64d8aa0d7c5ca8d55e1443684c243b01186f0.tar.gz
kata: WIP
Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-core/kata-containers/kata-agent_git.bb')
-rw-r--r--recipes-core/kata-containers/kata-agent_git.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/recipes-core/kata-containers/kata-agent_git.bb b/recipes-core/kata-containers/kata-agent_git.bb
new file mode 100644
index 00000000..3632ee52
--- /dev/null
+++ b/recipes-core/kata-containers/kata-agent_git.bb
@@ -0,0 +1,39 @@
1DESCRIPTION = "Agent run inside a virtual machine, which spawns containers and processes"
2HOMEPAGE = "https://github.com/kata-containers/agent"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://src/github.com/kata-containers/agent/LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
5
6GO_IMPORT = "github.com/kata-containers/agent"
7SRCREV = "e03f7d7453fabffb17e1540f28666c26178d3cbf"
8SRC_URI = "git://${GO_IMPORT}.git \
9 "
10
11RDEPENDS_${PN}-dev_append = "bash"
12
13S = "${WORKDIR}/git"
14
15inherit go
16
17do_compile() {
18 # Pass the needed cflags/ldflags so that cgo
19 # can find the needed headers files and libraries
20 export GOARCH=${TARGET_GOARCH}
21 export CGO_ENABLED="1"
22 export CGO_CFLAGS="${CFLAGS} --sysroot=${STAGING_DIR_TARGET}"
23 export CGO_LDFLAGS="${LDFLAGS} --sysroot=${STAGING_DIR_TARGET}"
24
25 cd ${S}/src/${GO_IMPORT}
26 oe_runmake kata-agent
27}
28
29do_install() {
30 mkdir -p ${D}/${bindir}/
31 cp ${WORKDIR}/git/src/${GO_IMPORT}/kata-agent ${D}/${bindir}
32
33 mkdir -p ${D}/${systemd_unitdir}/system
34 cp ${WORKDIR}/git/src/${GO_IMPORT}/kata-agent.service ${D}/${systemd_unitdir}/system
35}
36
37deltask compile_ptest_base
38
39FILES_${PN} += "${systemd_unitdir}/*" \ No newline at end of file