summaryrefslogtreecommitdiffstats
path: root/recipes-containers
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2020-06-30 23:52:30 -0400
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-07-01 12:43:16 -0400
commitf567afae0a191bd8bc532e5779b75d5ae5a95c6d (patch)
treee487a20472e279fe5fd7535638c31c37dacc4822 /recipes-containers
parentcc5e41ffb029ed61711e14368e66083e22a6ba38 (diff)
downloadmeta-virtualization-f567afae0a191bd8bc532e5779b75d5ae5a95c6d.tar.gz
oci-runtime-tools: fix 32bit ARM build
With oe-core commit c23f9e80492e4b [tcmode-default: use go-binary-native by default], we must explictly call the proper cross go binary, versus just the go-native variant. These builds were working by luck, since the go compiler was capable of building the target binaries previously (in its build-from-source creation). We fixup the calls and we no longer see fpu build issues: fatal error: gnu/stubs-soft.h: No such file or directory 7 | # include <gnu/stubs-soft.h> | ^~~~~~~~~~~~~~~~~~ Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-containers')
-rw-r--r--recipes-containers/oci-runtime-tools/files/0001-build-use-for-cross-compiler.patch31
-rw-r--r--recipes-containers/oci-runtime-tools/oci-runtime-tools_git.bb1
2 files changed, 32 insertions, 0 deletions
diff --git a/recipes-containers/oci-runtime-tools/files/0001-build-use-for-cross-compiler.patch b/recipes-containers/oci-runtime-tools/files/0001-build-use-for-cross-compiler.patch
new file mode 100644
index 00000000..fedfad37
--- /dev/null
+++ b/recipes-containers/oci-runtime-tools/files/0001-build-use-for-cross-compiler.patch
@@ -0,0 +1,31 @@
1From b4ad9b2a57d6c736870657c06959ccc44b578f12 Mon Sep 17 00:00:00 2001
2From: Bruce Ashfield <bruce.ashfield@gmail.com>
3Date: Tue, 30 Jun 2020 23:47:08 -0400
4Subject: [PATCH] build: use for cross compiler
5
6Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
7---
8 a/src/import/Makefile | 4 ++--
9 1 file changed, 2 insertions(+), 2 deletions(-)
10
11diff --git a/src/import/Makefile a/src/import/Makefile
12index 77626d2..c3a0760 100644
13--- a/src/import/Makefile
14+++ a/src/import/Makefile
15@@ -8,11 +8,11 @@ COMMIT=$(shell git rev-parse HEAD 2> /dev/null || true)
16 all: tool runtimetest
17
18 tool:
19- go build -tags "$(BUILDTAGS)" -ldflags "-X main.gitCommit=${COMMIT}" -o oci-runtime-tool ./cmd/oci-runtime-tool
20+ ${GO} build -tags "$(BUILDTAGS)" -ldflags "-X main.gitCommit=${COMMIT}" -o oci-runtime-tool ./cmd/oci-runtime-tool
21
22 .PHONY: runtimetest
23 runtimetest:
24- CGO_ENABLED=0 go build -installsuffix cgo -tags "$(BUILDTAGS)" -o runtimetest ./cmd/runtimetest
25+ CGO_ENABLED=0 ${GO} build -installsuffix cgo -tags "$(BUILDTAGS)" -o runtimetest ./cmd/runtimetest
26
27 .PHONY: man
28 man:
29--
302.19.1
31
diff --git a/recipes-containers/oci-runtime-tools/oci-runtime-tools_git.bb b/recipes-containers/oci-runtime-tools/oci-runtime-tools_git.bb
index adbfc1ef..a0ccb85c 100644
--- a/recipes-containers/oci-runtime-tools/oci-runtime-tools_git.bb
+++ b/recipes-containers/oci-runtime-tools/oci-runtime-tools_git.bb
@@ -5,6 +5,7 @@ LIC_FILES_CHKSUM = "file://src/import/LICENSE;md5=b355a61a394a504dacde901c958f66
5 5
6SRC_URI = "git://github.com/opencontainers/runtime-tools.git \ 6SRC_URI = "git://github.com/opencontainers/runtime-tools.git \
7 file://0001-Revert-implement-add-set-function-for-hooks-items.patch \ 7 file://0001-Revert-implement-add-set-function-for-hooks-items.patch \
8 file://0001-build-use-for-cross-compiler.patch \
8 " 9 "
9 10
10SRCREV = "6e7da8148f4de2c9e9c9d3b345576898d4f412cb" 11SRCREV = "6e7da8148f4de2c9e9c9d3b345576898d4f412cb"