summaryrefslogtreecommitdiffstats
path: root/recipes-containers
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2021-05-18 22:39:40 -0400
committerBruce Ashfield <bruce.ashfield@gmail.com>2021-05-18 22:42:27 -0400
commitef7f5e7c5825413c8ae35639208ed76fd7c219aa (patch)
treec72f37bc0e68668edc30f5890439a07b65bbdc0f /recipes-containers
parent07ed07b9f1f1d54e5808b740e3d9a9e69748e64e (diff)
downloadmeta-virtualization-ef7f5e7c5825413c8ae35639208ed76fd7c219aa.tar.gz
sloci-image: allow target and nativesdk variants
We now have use cases for sloci that can run on the target itself, or have it used in a nativesdk scenario. To avoid the awkwardly named "nativesdk-sloci-image-native" or .inc files, we rename the recipe sloci-image_git and use BBCLASSEXTEND for native/nativesdk support This is similar to the change sent by: Hongxu Jia <hongxu.jia@windriver.com>, but is updated to the current sloci-image recipe contents. Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-containers')
-rw-r--r--recipes-containers/sloci-image/sloci-image_git.bb (renamed from recipes-containers/sloci-image/sloci-image-native_git.bb)4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes-containers/sloci-image/sloci-image-native_git.bb b/recipes-containers/sloci-image/sloci-image_git.bb
index a68c6d9a..fc3c329e 100644
--- a/recipes-containers/sloci-image/sloci-image-native_git.bb
+++ b/recipes-containers/sloci-image/sloci-image_git.bb
@@ -11,8 +11,6 @@ DEPENDS = ""
11SRCREV = "4015e49763e5a738026a5bbfcf32b38b5a4fa650" 11SRCREV = "4015e49763e5a738026a5bbfcf32b38b5a4fa650"
12PV = "v0.1.0+git${SRCPV}" 12PV = "v0.1.0+git${SRCPV}"
13 13
14inherit native
15
16S = "${WORKDIR}/git" 14S = "${WORKDIR}/git"
17 15
18do_compile() { 16do_compile() {
@@ -25,3 +23,5 @@ do_install() {
25} 23}
26 24
27CLEANBROKEN = "1" 25CLEANBROKEN = "1"
26
27BBCLASSEXTEND = "native nativesdk"