summaryrefslogtreecommitdiffstats
path: root/recipes-containers
diff options
context:
space:
mode:
authorJonatan Pålsson <jonatan.palsson@pelagicore.com>2017-03-27 08:43:30 +0200
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-03-28 09:09:41 -0400
commitea05b2693aa6eae10a5f59aa7a47e52b4c4b4acd (patch)
treefda547f88032003e39bded373d95e86e529777d9 /recipes-containers
parentbccfd5ddb908b82511869701a41be056c0414a1b (diff)
downloadmeta-virtualization-ea05b2693aa6eae10a5f59aa7a47e52b4c4b4acd.tar.gz
lxc: Add lua to PACKAGECONFIG
Lua support is automatically enabled when configuring LXC if lua is available in the sysroot. The packaging step will fail since the lua related files are not in FILES. This patch explicitly enables/disables lua support using PACKAGECONFIG, and also adds lua-related files to FILES. Signed-off-by: Jonatan Pålsson <jonatan.palsson@pelagicore.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-containers')
-rw-r--r--recipes-containers/lxc/lxc_2.0.0.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/recipes-containers/lxc/lxc_2.0.0.bb b/recipes-containers/lxc/lxc_2.0.0.bb
index 250ac4d9..c98d1a7f 100644
--- a/recipes-containers/lxc/lxc_2.0.0.bb
+++ b/recipes-containers/lxc/lxc_2.0.0.bb
@@ -65,6 +65,7 @@ PACKAGECONFIG[templates] = ",,, ${PN}-templates"
65PACKAGECONFIG[selinux] = "--enable-selinux,--disable-selinux,libselinux,libselinux" 65PACKAGECONFIG[selinux] = "--enable-selinux,--disable-selinux,libselinux,libselinux"
66PACKAGECONFIG[seccomp] ="--enable-seccomp,--disable-seccomp,libseccomp,libseccomp" 66PACKAGECONFIG[seccomp] ="--enable-seccomp,--disable-seccomp,libseccomp,libseccomp"
67PACKAGECONFIG[python] = "--enable-python,--disable-python,python3,python3-core" 67PACKAGECONFIG[python] = "--enable-python,--disable-python,python3,python3-core"
68PACKAGECONFIG[lua] = "--enable-lua,--disable-lua,lua,lua"
68 69
69# required by python3 to run setup.py 70# required by python3 to run setup.py
70export BUILD_SYS 71export BUILD_SYS
@@ -86,6 +87,9 @@ FILES_${PN}-doc = "${mandir} ${infodir}"
86# For LXC the docdir only contains example configuration files and should be included in the lxc package 87# For LXC the docdir only contains example configuration files and should be included in the lxc package
87FILES_${PN} += "${docdir}" 88FILES_${PN} += "${docdir}"
88FILES_${PN} += "${libdir}/python3*" 89FILES_${PN} += "${libdir}/python3*"
90FILES_${PN} += "${datadir}/lua/*"
91FILES_${PN} += "${libdir}/lua/lxc/*"
92FILES_${PN}-dbg += "${libdir}/lua/lxc/.debug"
89FILES_${PN}-dbg += "${libexecdir}/lxc/.debug ${libexecdir}/lxc/hooks/.debug" 93FILES_${PN}-dbg += "${libexecdir}/lxc/.debug ${libexecdir}/lxc/hooks/.debug"
90PACKAGES =+ "${PN}-templates ${PN}-setup ${PN}-networking" 94PACKAGES =+ "${PN}-templates ${PN}-setup ${PN}-networking"
91FILES_${PN}-templates += "${datadir}/lxc/templates" 95FILES_${PN}-templates += "${datadir}/lxc/templates"