summaryrefslogtreecommitdiffstats
path: root/recipes-containers
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2024-05-28 13:17:03 +0000
committerBruce Ashfield <bruce.ashfield@gmail.com>2024-05-29 13:16:56 +0000
commitd79afeac8c06b768364313e84b160cdebb0ec783 (patch)
tree63ede00532f12d593fe9ca295def350fff08d9c2 /recipes-containers
parent2aa6da625d493f92000a8f786496d19823a01a28 (diff)
downloadmeta-virtualization-d79afeac8c06b768364313e84b160cdebb0ec783.tar.gz
lxc: convert remaining WORKDIR references to UNPACKDIR
While the WORKDIR references seem to work, they may not continue to work. We switch to using UNPACKDIR which is where the SRC_URI referenced elements / files will be placed by the fetcher. Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-containers')
-rw-r--r--recipes-containers/lxc/lxc_git.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes-containers/lxc/lxc_git.bb b/recipes-containers/lxc/lxc_git.bb
index ee0e442f..550f910e 100644
--- a/recipes-containers/lxc/lxc_git.bb
+++ b/recipes-containers/lxc/lxc_git.bb
@@ -161,12 +161,12 @@ do_install:append() {
161 # /etc/default/lxc sources lxc-net, this allows lxc bridge when lxc-networking 161 # /etc/default/lxc sources lxc-net, this allows lxc bridge when lxc-networking
162 # is not installed this results in no lxcbr0, but when lxc-networking is installed 162 # is not installed this results in no lxcbr0, but when lxc-networking is installed
163 # lxcbr0 will be fully configured. 163 # lxcbr0 will be fully configured.
164 install -m 644 ${WORKDIR}/lxc-net ${D}${sysconfdir}/default/ 164 install -m 644 ${UNPACKDIR}/lxc-net ${D}${sysconfdir}/default/
165 165
166 # Force the main dnsmasq instance to bind only to specified interfaces and 166 # Force the main dnsmasq instance to bind only to specified interfaces and
167 # to not bind to virbr0. Libvirt will run its own instance on this interface. 167 # to not bind to virbr0. Libvirt will run its own instance on this interface.
168 install -d ${D}/${sysconfdir}/dnsmasq.d 168 install -d ${D}/${sysconfdir}/dnsmasq.d
169 install -m 644 ${WORKDIR}/dnsmasq.conf ${D}/${sysconfdir}/dnsmasq.d/lxc 169 install -m 644 ${UNPACKDIR}/dnsmasq.conf ${D}/${sysconfdir}/dnsmasq.d/lxc
170} 170}
171 171
172EXTRA_OEMAKE += "TEST_DIR=${D}${PTEST_PATH}/src/tests" 172EXTRA_OEMAKE += "TEST_DIR=${D}${PTEST_PATH}/src/tests"