summaryrefslogtreecommitdiffstats
path: root/recipes-containers
diff options
context:
space:
mode:
authorhongxu <hongxu.jia@windriver.com>2021-07-05 17:30:08 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2021-07-07 15:42:51 -0400
commitc1bd680e12e56f2eea235d22548e0cf85185ab53 (patch)
tree1940df04b6b36ba5e94ff226c204afced4c77234 /recipes-containers
parent6459b6544b9a4d38f145de7c935a5919e758b691 (diff)
downloadmeta-virtualization-c1bd680e12e56f2eea235d22548e0cf85185ab53.tar.gz
skopeo: fix native skopeo failed if no libdevmapper.so.1.02 on host
If host does not install libdevmapper.so.1.02, run native skopeo failed: ... $ tmp-glibc/sysroots/x86_64/usr/sbin/skopeo -h |tmp-glibc/sysroots/x86_64/usr/sbin/skopeo.real: error while loading shared libraries: libdevmapper.so.1.02: cannot open shared object file: No such file or directory ... Create wrapper to set LD_LIBRARY_PATH which using native libdevmapper.so.1.02 Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-containers')
-rw-r--r--recipes-containers/skopeo/skopeo_git.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/recipes-containers/skopeo/skopeo_git.bb b/recipes-containers/skopeo/skopeo_git.bb
index 6c95bf3e..19ac938b 100644
--- a/recipes-containers/skopeo/skopeo_git.bb
+++ b/recipes-containers/skopeo/skopeo_git.bb
@@ -84,6 +84,9 @@ do_install() {
84do_install_append_class-native() { 84do_install_append_class-native() {
85 create_cmdline_wrapper ${D}/${sbindir}/skopeo \ 85 create_cmdline_wrapper ${D}/${sbindir}/skopeo \
86 --policy ${sysconfdir}/containers/policy.json 86 --policy ${sysconfdir}/containers/policy.json
87
88 create_wrapper ${D}/${sbindir}/skopeo.real \
89 LD_LIBRARY_PATH=${STAGING_LIBDIR_NATIVE}
87} 90}
88 91
89do_install_append_class-nativesdk() { 92do_install_append_class-nativesdk() {