summaryrefslogtreecommitdiffstats
path: root/recipes-containers
diff options
context:
space:
mode:
authorWenzong Fan <wenzong.fan@windriver.com>2014-12-03 02:41:10 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-12-03 10:19:56 -0500
commitc0423005b36d80bd35bd329b5460b4ac78365fd2 (patch)
tree09196ca170e30d9cb6e7a15b1c669ecd67f7a32d /recipes-containers
parent48c1f0666b2f523845c10ae352d58a77e3cc474f (diff)
downloadmeta-virtualization-c0423005b36d80bd35bd329b5460b4ac78365fd2.tar.gz
lxc: add PACKAGECONFIG for selinux
Add PACKAGECONFIG for 'selinux', otherwise there would be warnings like below: WARN: lxc: lxc rdepends on libselinux, but it isn't a build dependency? Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-containers')
-rw-r--r--recipes-containers/lxc/lxc_1.0.6.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/recipes-containers/lxc/lxc_1.0.6.bb b/recipes-containers/lxc/lxc_1.0.6.bb
index 08055732..e6ec68db 100644
--- a/recipes-containers/lxc/lxc_1.0.6.bb
+++ b/recipes-containers/lxc/lxc_1.0.6.bb
@@ -40,11 +40,14 @@ S = "${WORKDIR}/${BPN}-${PV}"
40PTEST_CONF = "${@base_contains('DISTRO_FEATURES', 'ptest', '--enable-tests', '', d)}" 40PTEST_CONF = "${@base_contains('DISTRO_FEATURES', 'ptest', '--enable-tests', '', d)}"
41EXTRA_OECONF += "--with-distro=${DISTRO} ${PTEST_CONF}" 41EXTRA_OECONF += "--with-distro=${DISTRO} ${PTEST_CONF}"
42 42
43PACKAGECONFIG ??= "templates" 43PACKAGECONFIG ??= "templates \
44 ${@base_contains('DISTRO_FEATURES', 'selinux', 'selinux', '', d)} \
45"
44PACKAGECONFIG[doc] = "--enable-doc --enable-api-docs,--disable-doc --disable-api-docs,," 46PACKAGECONFIG[doc] = "--enable-doc --enable-api-docs,--disable-doc --disable-api-docs,,"
45PACKAGECONFIG[rpath] = "--enable-rpath,--disable-rpath,," 47PACKAGECONFIG[rpath] = "--enable-rpath,--disable-rpath,,"
46PACKAGECONFIG[apparmour] = "--enable-apparmor,--disable-apparmor,apparmor,apparmor" 48PACKAGECONFIG[apparmour] = "--enable-apparmor,--disable-apparmor,apparmor,apparmor"
47PACKAGECONFIG[templates] = ",,, ${PN}-templates" 49PACKAGECONFIG[templates] = ",,, ${PN}-templates"
50PACKAGECONFIG[selinux] = "--enable-selinux,--disable-selinux,libselinux,libselinux"
48 51
49inherit autotools pkgconfig ptest 52inherit autotools pkgconfig ptest
50 53