summaryrefslogtreecommitdiffstats
path: root/recipes-containers
diff options
context:
space:
mode:
authorJianchuan Wang <jianchuan.wang@windriver.com>2016-09-08 01:36:00 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2016-09-12 10:03:05 -0400
commitb9b7ece0cd52966467035fb71ad9ba472bf24b88 (patch)
tree1c7f62718927b9c2873edf99d4d848c7c2198ea0 /recipes-containers
parentc415f9786025622ff253ac21f24eef4755118e82 (diff)
downloadmeta-virtualization-b9b7ece0cd52966467035fb71ad9ba472bf24b88.tar.gz
criu: uprev to 2.5
Signed-off-by: Jianchuan Wang <jianchuan.wang@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-containers')
-rw-r--r--recipes-containers/criu/criu_git.bb22
-rw-r--r--recipes-containers/criu/files/0001-criu-Change-libraries-install-directory.patch63
-rw-r--r--recipes-containers/criu/files/0001-criu-Fix-toolchain-hardcode.patch108
-rw-r--r--recipes-containers/criu/files/0002-criu-Skip-documentation-install.patch29
4 files changed, 140 insertions, 82 deletions
diff --git a/recipes-containers/criu/criu_git.bb b/recipes-containers/criu/criu_git.bb
index c8be78fb..dc0bdbe6 100644
--- a/recipes-containers/criu/criu_git.bb
+++ b/recipes-containers/criu/criu_git.bb
@@ -11,11 +11,11 @@ LICENSE = "GPLv2"
11 11
12EXCLUDE_FROM_WORLD = "1" 12EXCLUDE_FROM_WORLD = "1"
13 13
14LIC_FILES_CHKSUM = "file://COPYING;md5=5cc804625b8b491b6b4312f0c9cb5efa" 14LIC_FILES_CHKSUM = "file://COPYING;md5=412de458544c1cb6a2b512cd399286e2"
15 15
16SRCREV = "4c5b23e52c1dc4e3fbbc7472b92e7b1ce9d22f02" 16SRCREV = "c031417255f6a5c4409d15ff0b36af5f6e90c559"
17PR = "r0" 17PR = "r0"
18PV = "1.6+git${SRCPV}" 18PV = "2.5+git${SRCPV}"
19 19
20SRC_URI = "git://github.com/xemul/criu.git;protocol=git \ 20SRC_URI = "git://github.com/xemul/criu.git;protocol=git \
21 file://0001-criu-Fix-toolchain-hardcode.patch \ 21 file://0001-criu-Fix-toolchain-hardcode.patch \
@@ -26,7 +26,7 @@ SRC_URI = "git://github.com/xemul/criu.git;protocol=git \
26 26
27COMPATIBLE_HOST = "(x86_64|arm|aarch64).*-linux" 27COMPATIBLE_HOST = "(x86_64|arm|aarch64).*-linux"
28 28
29DEPENDS += "protobuf-c-native protobuf-c libbsd" 29DEPENDS += "libnl libcap protobuf-c-native protobuf-c"
30 30
31S = "${WORKDIR}/git" 31S = "${WORKDIR}/git"
32 32
@@ -35,14 +35,16 @@ S = "${WORKDIR}/git"
35# if the ARCH is ARMv7 or ARMv6. 35# if the ARCH is ARMv7 or ARMv6.
36# ARM BSPs need set CRIU_BUILD_ARCH variable for building CRIU. 36# ARM BSPs need set CRIU_BUILD_ARCH variable for building CRIU.
37# 37#
38EXTRA_OEMAKE_arm += "ARCH=${CRIU_BUILD_ARCH} WERROR=0" 38EXTRA_OEMAKE_arm += "ARCH=arm UNAME-M=${CRIU_BUILD_ARCH} WERROR=0"
39EXTRA_OEMAKE_x86-64 += "ARCH=${TARGET_ARCH} WERROR=0" 39EXTRA_OEMAKE_x86-64 += "ARCH=x86 WERROR=0"
40EXTRA_OEMAKE_aarch64 += "ARCH=${TARGET_ARCH} WERROR=0" 40EXTRA_OEMAKE_aarch64 += "ARCH=arm64 WERROR=0"
41 41
42EXTRA_OEMAKE_append += "SBINDIR=${sbindir} LIBDIR=${libdir} INCLUDEDIR=${includedir} PIEGEN=no" 42EXTRA_OEMAKE_append += "SBINDIR=${sbindir} LIBDIR=${libdir} INCLUDEDIR=${includedir} PIEGEN=no"
43EXTRA_OEMAKE_append += "LOGROTATEDIR=${sysconfdir} SYSTEMDUNITDIR=${systemd_unitdir}" 43EXTRA_OEMAKE_append += "LOGROTATEDIR=${sysconfdir} SYSTEMDUNITDIR=${systemd_unitdir}"
44 44
45CFLAGS += "-D__USE_GNU -D_GNU_SOURCE" 45CFLAGS += "-D__USE_GNU -D_GNU_SOURCE "
46
47CFLAGS += " -I${STAGING_INCDIR} -I${STAGING_INCDIR}/libnl3"
46 48
47# overide LDFLAGS to allow criu to build without: "x86_64-poky-linux-ld: unrecognized option '-Wl,-O1'" 49# overide LDFLAGS to allow criu to build without: "x86_64-poky-linux-ld: unrecognized option '-Wl,-O1'"
48export LDFLAGS="" 50export LDFLAGS=""
@@ -56,8 +58,8 @@ PACKAGECONFIG ??= ""
56PACKAGECONFIG[selinux] = ",,libselinux" 58PACKAGECONFIG[selinux] = ",,libselinux"
57 59
58do_compile_prepend() { 60do_compile_prepend() {
59 rm -rf ${S}/protobuf/google/protobuf/descriptor.proto 61 rm -rf ${S}/images/google/protobuf/descriptor.proto
60 ln -s ${PKG_CONFIG_SYSROOT_DIR}/usr/include/google/protobuf/descriptor.proto ${S}/protobuf/google/protobuf/descriptor.proto 62 ln -s ${PKG_CONFIG_SYSROOT_DIR}/usr/include/google/protobuf/descriptor.proto ${S}/images/google/protobuf/descriptor.proto
61} 63}
62 64
63do_compile () { 65do_compile () {
diff --git a/recipes-containers/criu/files/0001-criu-Change-libraries-install-directory.patch b/recipes-containers/criu/files/0001-criu-Change-libraries-install-directory.patch
index 28d638b3..a7214050 100644
--- a/recipes-containers/criu/files/0001-criu-Change-libraries-install-directory.patch
+++ b/recipes-containers/criu/files/0001-criu-Change-libraries-install-directory.patch
@@ -1,48 +1,39 @@
1From cb9933dc34af0b4d52c4584332600114ac65c402 Mon Sep 17 00:00:00 2001 1From 7ebde06e00b591a88397dad74a1aa47fd562eb50 Mon Sep 17 00:00:00 2001
2From: Jianchuan Wang <jianchuan.wang@windriver.com> 2From: Jianchuan Wang <jianchuan.wang@windriver.com>
3Date: Tue, 4 Aug 2015 17:45:51 +0800 3Date: Tue, 16 Aug 2016 09:48:08 +0800
4Subject: [PATCH] criu: Change libraries install directory 4Subject: [PATCH 1/2] criu: Change libraries install directory
5 5
6Install the libraries into /usr/lib(/usr/lib64) 6Install the libraries into /usr/lib(or /usr/lib64)
7 7
8Signed-off-by: Jianchuan Wang <jianchuan.wang@windriver.com> 8Signed-off-by: Jianchuan Wang <jianchuan.wang@windriver.com>
9--- 9---
10 Makefile | 2 +- 10 Makefile.install | 13 -------------
11 Makefile.inc | 9 --------- 11 1 file changed, 13 deletions(-)
12 2 files changed, 1 insertion(+), 10 deletions(-)
13 12
14diff --git a/Makefile b/Makefile 13diff --git a/Makefile.install b/Makefile.install
15index 7f5c890..6dbc436 100644 14index dbc22e1..a30dc96 100644
16--- a/Makefile 15--- a/Makefile.install
17+++ b/Makefile 16+++ b/Makefile.install
18@@ -351,7 +351,7 @@ install-man: 17@@ -11,19 +11,6 @@ LIBDIR ?= $(PREFIX)/lib
18 INCLUDEDIR ?= $(PREFIX)/include/criu
19 LIBEXECDIR ?= $(PREFIX)/libexec
19 20
20 install-crit: crit 21-#
21 $(E) " INSTALL crit" 22-# For recent Debian/Ubuntu with multiarch support.
22- $(Q) python scripts/crit-setup.py install --root=$(DESTDIR) --prefix=$(PREFIX) 23-DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH 2>/dev/null)
23+ $(Q) python scripts/crit-setup.py install --root=$(DESTDIR) --prefix=$(PREFIX) --install-lib=$(LIBDIR)
24
25 .PHONY: install install-man install-crit install-criu
26
27diff --git a/Makefile.inc b/Makefile.inc
28index 5496f41..ba70aea 100644
29--- a/Makefile.inc
30+++ b/Makefile.inc
31@@ -17,14 +17,5 @@ MANDIR := $(PREFIX)/share/man
32 SYSTEMDUNITDIR := $(PREFIX)/lib/systemd/system/
33 LOGROTATEDIR := $(PREFIX)/etc/logrotate.d/
34 LIBDIR := $(PREFIX)/lib
35-# For recent Debian/Ubuntu with multiarch support
36-DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture \
37- -qDEB_HOST_MULTIARCH 2>/dev/null)
38-ifneq "$(DEB_HOST_MULTIARCH)" "" 24-ifneq "$(DEB_HOST_MULTIARCH)" ""
39-LIBDIR := $(PREFIX)/lib/$(DEB_HOST_MULTIARCH) 25- LIBDIR ?= $(PREFIX)/lib/$(DEB_HOST_MULTIARCH)
40-# For most other systems 26-else
41-else ifeq "$(shell uname -m)" "x86_64" 27- #
42-LIBDIR := $(PREFIX)/lib64 28- # For most other systems
29- ifeq "$(shell uname -m)" "x86_64"
30- LIBDIR ?= $(PREFIX)/lib64
31- endif
43-endif 32-endif
33-
34 export BINDIR SBINDIR MANDIR SYSTEMDUNITDIR LOGROTATEDIR
35 export INCLUDEDIR LIBDIR DESTDIR PREFIX LIBEXECDIR
44 36
45 INCLUDEDIR := $(PREFIX)/include/criu
46-- 37--
471.9.1 382.7.4
48 39
diff --git a/recipes-containers/criu/files/0001-criu-Fix-toolchain-hardcode.patch b/recipes-containers/criu/files/0001-criu-Fix-toolchain-hardcode.patch
index 2fabe0ad..d30f2ac2 100644
--- a/recipes-containers/criu/files/0001-criu-Fix-toolchain-hardcode.patch
+++ b/recipes-containers/criu/files/0001-criu-Fix-toolchain-hardcode.patch
@@ -1,46 +1,112 @@
1From 3d4f112fdb434712eba09239a468842323f1af4c Mon Sep 17 00:00:00 2001 1From 057d30f15e81dcc4162d6fbee06f126564596397 Mon Sep 17 00:00:00 2001
2From: Yang Shi <yang.shi@windriver.com> 2From: Jianchuan Wang <jianchuan.wang@windriver.com>
3Date: Tue, 26 Aug 2014 14:42:42 -0700 3Date: Wed, 7 Sep 2016 23:55:15 -0400
4Subject: [PATCH 1/2] criu: Fix toolchain hardcode 4Subject: [PATCH] criu: Fix toolchain hardcode
5 5
6Replace ":=" to "?=" so that the toolchain used by bitbake build system will 6Replace ":=" to "?=" so that the toolchain used by bitbake build system will
7be taken. 7be taken.
8 8
9Signed-off-by: Yang Shi <yang.shi@windriver.com> 9Signed-off-by: Yang Shi <yang.shi@windriver.com>
10Signed-off-by: Nam Ninh <nam.ninh@windriver.com> 10Signed-off-by: Jianchuan Wang <jianchuan.wang@windriver.com>
11--- 11---
12 Makefile | 18 +++++++++--------- 12 Makefile | 2 +-
13 1 file changed, 9 insertions(+), 9 deletions(-) 13 criu/pie/Makefile | 2 +-
14 scripts/nmk/scripts/include.mk | 2 +-
15 scripts/nmk/scripts/tools.mk | 40 ++++++++++++++++++++--------------------
16 4 files changed, 23 insertions(+), 23 deletions(-)
14 17
15diff --git a/Makefile b/Makefile 18diff --git a/Makefile b/Makefile
16index f1c8784..43252ec 100644 19index 52cbd6a..f66279b 100644
17--- a/Makefile 20--- a/Makefile
18+++ b/Makefile 21+++ b/Makefile
19@@ -23,15 +23,15 @@ export VERSION_SO_MAJOR VERSION_SO_MINOR 22@@ -60,7 +60,7 @@ LDARCH ?= $(SRCARCH)
20 # Common definitions 23
24 export SRCARCH LDARCH VDSO
25
26-UNAME-M := $(shell uname -m)
27+UNAME-M ?= $(shell uname -m)
28 export UNAME-M
29
30 ifeq ($(ARCH),arm)
31diff --git a/criu/pie/Makefile b/criu/pie/Makefile
32index 125b02f..9975871 100644
33--- a/criu/pie/Makefile
34+++ b/criu/pie/Makefile
35@@ -17,7 +17,7 @@ restorer-obj-e += ./$(ARCH_DIR)/syscalls.built-in.o
21 # 36 #
37 CFLAGS := $(filter-out -pg $(CFLAGS-GCOV),$(CFLAGS))
38 CFLAGS += -iquote $(SRC_DIR)/criu/pie/piegen
39-CFLAGS += -iquote $(SRC_DIR)/criu/arch/$(ARCH)/include
40+CFLAGS += -iquote $(SRC_DIR)/criu/arch/$(SRCARCH)/include
41 CFLAGS += -iquote $(SRC_DIR)/criu/include
42 CFLAGS += -iquote $(SRC_DIR)
22 43
23-FIND := find 44diff --git a/scripts/nmk/scripts/include.mk b/scripts/nmk/scripts/include.mk
24-CSCOPE := cscope 45index 4c496f7..a7250cd 100644
46--- a/scripts/nmk/scripts/include.mk
47+++ b/scripts/nmk/scripts/include.mk
48@@ -20,7 +20,7 @@ SUBARCH := $(shell uname -m | sed \
49 -e s/aarch64.*/arm64/)
50
51 ARCH ?= $(SUBARCH)
52-SRCARCH := $(ARCH)
53+SRCARCH ?= $(ARCH)
54
55 export SUBARCH ARCH SRCARCH
56
57diff --git a/scripts/nmk/scripts/tools.mk b/scripts/nmk/scripts/tools.mk
58index 0538dde..e4af068 100644
59--- a/scripts/nmk/scripts/tools.mk
60+++ b/scripts/nmk/scripts/tools.mk
61@@ -2,28 +2,28 @@ ifndef ____nmk_defined__tools
62
63 #
64 # System tools shorthands
25-RM := rm -f 65-RM := rm -f
26-LD := $(CROSS_COMPILE)ld 66-LD := $(CROSS_COMPILE)ld
27-CC := $(CROSS_COMPILE)gcc 67-CC := $(CROSS_COMPILE)gcc
68-CPP := $(CC) -E
69-AS := $(CROSS_COMPILE)as
70-AR := $(CROSS_COMPILE)ar
71-STRIP := $(CROSS_COMPILE)strip
72-OBJCOPY := $(CROSS_COMPILE)objcopy
73-OBJDUMP := $(CROSS_COMPILE)objdump
28-NM := $(CROSS_COMPILE)nm 74-NM := $(CROSS_COMPILE)nm
29-SH := bash
30-MAKE := make 75-MAKE := make
31-OBJCOPY := $(CROSS_COMPILE)objcopy 76-MKDIR := mkdir -p
32+FIND ?= find 77-AWK := awk
33+CSCOPE ?= cscope 78-PERL := perl
79-PYTHON := python
80-FIND := find
81-SH := $(shell if [ -x "$$BASH" ]; then echo $$BASH; \
34+RM ?= rm -f 82+RM ?= rm -f
35+LD ?= $(CROSS_COMPILE)ld 83+LD ?= $(CROSS_COMPILE)ld
36+CC ?= $(CROSS_COMPILE)gcc 84+CC ?= $(CROSS_COMPILE)gcc
85+CPP ?= $(CC) -E
86+AS ?= $(CROSS_COMPILE)as
87+AR ?= $(CROSS_COMPILE)ar
88+STRIP ?= $(CROSS_COMPILE)strip
89+OBJCOPY ?= $(CROSS_COMPILE)objcopy
90+OBJDUMP ?= $(CROSS_COMPILE)objdump
37+NM ?= $(CROSS_COMPILE)nm 91+NM ?= $(CROSS_COMPILE)nm
38+SH ?= bash
39+MAKE ?= make 92+MAKE ?= make
40+OBJCOPY ?= $(CROSS_COMPILE)objcopy 93+MKDIR ?= mkdir -p
41 94+AWK ?= awk
42 CFLAGS += $(USERCFLAGS) 95+PERL ?= perl
96+PYTHON ?= python
97+FIND ?= find
98+SH ?= $(shell if [ -x "$$BASH" ]; then echo $$BASH; \
99 else if [ -x /bin/bash ]; then echo /bin/bash; \
100 else echo sh; fi ; fi)
101-CSCOPE := cscope
102-ETAGS := etags
103-CTAGS := ctags
104+CSCOPE ?= cscope
105+ETAGS ?= etags
106+CTAGS ?= ctags
43 107
108 export RM LD CC CPP AS AR STRIP OBJCOPY OBJDUMP
109 export NM SH MAKE MKDIR AWK PERL PYTHON SH CSCOPE
44-- 110--
452.0.2 1112.8.1
46 112
diff --git a/recipes-containers/criu/files/0002-criu-Skip-documentation-install.patch b/recipes-containers/criu/files/0002-criu-Skip-documentation-install.patch
index eaf81603..ba414d96 100644
--- a/recipes-containers/criu/files/0002-criu-Skip-documentation-install.patch
+++ b/recipes-containers/criu/files/0002-criu-Skip-documentation-install.patch
@@ -1,29 +1,28 @@
1From e9c2a94b9eb37ad24672b10caa398bd18282b962 Mon Sep 17 00:00:00 2001 1From 07d9b3d0c372e45127dd51781d9564e8bee90dbe Mon Sep 17 00:00:00 2001
2From: Yang Shi <yang.shi@windriver.com> 2From: Jianchuan Wang <jianchuan.wang@windriver.com>
3Date: Tue, 26 Aug 2014 14:44:51 -0700 3Date: Tue, 16 Aug 2016 09:42:24 +0800
4Subject: [PATCH 2/2] criu: Skip documentation install 4Subject: [PATCH 2/2] criu: Skip documentation install
5 5
6asciidoc is needed to generate CRIU documentation, so skip it in install. 6asciidoc is needed to generate CRIU documentation, so skip it in install.
7 7
8Signed-off-by: Yang Shi <yang.shi@windriver.com> 8Signed-off-by: Jianchuan Wang <jianchuan.wang@windriver.com>
9Signed-off-by: Nam Ninh <nam.ninh@windriver.com>
10--- 9---
11 Makefile | 2 +- 10 Makefile.install | 2 +-
12 1 file changed, 1 insertion(+), 1 deletion(-) 11 1 file changed, 1 insertion(+), 1 deletion(-)
13 12
14diff --git a/Makefile b/Makefile 13diff --git a/Makefile.install b/Makefile.install
15index 43252ec..e25edcc 100644 14index a30dc96..33143fb 100644
16--- a/Makefile 15--- a/Makefile.install
17+++ b/Makefile 16+++ b/Makefile.install
18@@ -265,7 +265,7 @@ install: $(PROGRAM) install-man 17@@ -22,7 +22,7 @@ install-tree:
19 $(Q) install -m 644 scripts/logrotate.d/criu-service $(DESTDIR)$(LOGROTATEDIR) 18 .PHONY: install-tree
20 19
21 install-man: 20 install-man:
22- $(Q) $(MAKE) -C Documentation install 21- $(Q) $(MAKE) -C Documentation install
23+# $(Q) $(MAKE) -C Documentation install 22+# $(Q) $(MAKE) -C Documentation install
23 .PHONY: install-man
24 24
25 .PHONY: install install-man 25 install-lib: lib
26
27-- 26--
282.0.2 272.7.4
29 28