summaryrefslogtreecommitdiffstats
path: root/recipes-containers
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2021-04-15 10:40:01 -0400
committerBruce Ashfield <bruce.ashfield@gmail.com>2021-04-15 10:40:01 -0400
commitb63523eeacd4aa446c316a9db1618ef7814d83b0 (patch)
tree8365f4e7898ee66178a6b1f14d550b6b265c3da9 /recipes-containers
parent37a794296ef0f089769d2eba0d63a2cfb3b5e337 (diff)
downloadmeta-virtualization-b63523eeacd4aa446c316a9db1618ef7814d83b0.tar.gz
docker-compose: update to 1.29.1
The following changes are part of this version bump: 1.29.1 (2021-04-13) ------------------- Bugs Fix for invalid handler warning on Windows builds Fix config hash to trigger container recreation on IPC mode updates Fix conversion map for placement.max_replicas_per_node Remove extra scan suggestion on build 1.29.0 (2021-04-06) ------------------- Features Add profile filter to docker-compose config Add a depends_on condition to wait for successful service completion Miscellaneous Add image scan message on build Update warning message for --no-ansi to mention --ansi never as alternative Bump docker-py to 5.0.0 Bump PyYAML to 5.4.1 Bump python-dotenv to 0.17.0 1.28.6 (2021-03-23) ------------------- Bugs Make --env-file relative to the current working directory and error out for invalid paths. Environment file paths set with --env-file are relative to the current working directory while the default .env file is located in the project directory which by default is the base directory of the Compose file. Fix missing service property storage_opt by updating the compose schema Fix build extra_hosts list format Remove extra error message on exec Miscellaneous Add compose.yml and compose.yaml to default filename list 1.28.5 (2021-02-25) ------------------- Bugs Fix OpenSSL version mismatch error when shelling out to the ssh client (via bump to docker-py 4.4.4 which contains the fix) Add missing build flags to the native builder: platform, isolation and extra_hosts Remove info message on native build Avoid fetching logs when service logging driver is set to 'none' 1.28.4 (2021-02-18) -------------------- Bugs Fix SSH port parsing by bumping docker-py to 4.4.3 Miscellaneous Bump Python to 3.7.10 1.28.3 (2021-02-17) ------------------- Bugs Fix SSH hostname parsing when it contains leading s/h, and remove the quiet option that was hiding the error (via docker-py bump to 4.4.2) Fix key error for '--no-log-prefix' option Fix incorrect CLI environment variable name for service profiles: COMPOSE_PROFILES instead of COMPOSE_PROFILE Fix fish completion Miscellaneous Bump cryptography to 3.3.2 Remove log driver filter Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-containers')
-rw-r--r--recipes-containers/docker-compose/files/0001-setup.py-remove-maximum-version-requirements.patch29
-rw-r--r--recipes-containers/docker-compose/python3-docker-compose_1.29.1.bb (renamed from recipes-containers/docker-compose/python3-docker-compose_1.28.2.bb)4
2 files changed, 16 insertions, 17 deletions
diff --git a/recipes-containers/docker-compose/files/0001-setup.py-remove-maximum-version-requirements.patch b/recipes-containers/docker-compose/files/0001-setup.py-remove-maximum-version-requirements.patch
index 2576bb1d..7205d3b5 100644
--- a/recipes-containers/docker-compose/files/0001-setup.py-remove-maximum-version-requirements.patch
+++ b/recipes-containers/docker-compose/files/0001-setup.py-remove-maximum-version-requirements.patch
@@ -14,42 +14,41 @@ Signed-off-by: Ming Liu <liu.ming50@gmail.com>
14 setup.py | 24 ++++++++++++------------ 14 setup.py | 24 ++++++++++++------------
15 1 file changed, 12 insertions(+), 12 deletions(-) 15 1 file changed, 12 insertions(+), 12 deletions(-)
16 16
17Index: docker-compose-1.28.2/setup.py 17Index: docker-compose-1.29.1/setup.py
18=================================================================== 18===================================================================
19--- docker-compose-1.28.2.orig/setup.py 19--- docker-compose-1.29.1.orig/setup.py
20+++ docker-compose-1.28.2/setup.py 20+++ docker-compose-1.29.1/setup.py
21@@ -25,17 +25,17 @@ 21@@ -25,16 +25,21 @@
22 22
23 23
24 install_requires = [ 24 install_requires = [
25- 'cached-property >= 1.2.0, < 2',
26- 'docopt >= 0.6.1, < 1', 25- 'docopt >= 0.6.1, < 1',
27- 'PyYAML >= 3.10, < 6', 26- 'PyYAML >= 3.10, < 6',
28- 'requests >= 2.20.0, < 3', 27- 'requests >= 2.20.0, < 3',
29- 'texttable >= 0.9.0, < 2', 28- 'texttable >= 0.9.0, < 2',
30- 'websocket-client >= 0.32.0, < 1',
31- 'distro >= 1.5.0, < 2',
32- 'docker[ssh] >= 4.4.0, < 5',
33- 'dockerpty >= 0.4.1, < 1',
34- 'jsonschema >= 2.5.1, < 4',
35- 'python-dotenv >= 0.13.0, < 1',
36+ 'cached-property >= 1.2.0',
37+ 'docopt >= 0.6.1', 29+ 'docopt >= 0.6.1',
38+ 'PyYAML >= 3.10', 30+ 'PyYAML >= 3.10',
39+ 'requests >= 2.20.0', 31+ 'requests >= 2.20.0',
40+ 'texttable >= 0.9.0', 32+ 'texttable >= 0.9.0',
33 'websocket-client >= 0.32.0, < 1',
34 'distro >= 1.5.0, < 2',
35- 'docker[ssh] >= 5',
36+ 'docker[ssh] >= 4.4.0, < 5',
37 'dockerpty >= 0.4.1, < 1',
38 'jsonschema >= 2.5.1, < 4',
39- 'python-dotenv >= 0.13.0, < 1',
41+ 'websocket-client >= 0.32.0', 40+ 'websocket-client >= 0.32.0',
42+ 'distro >= 1.5.0', 41+ 'distro >= 1.5.0',
43+ 'docker[ssh] >= 4.4.0', 42+ 'docker[ssh] >= 5',
44+ 'dockerpty >= 0.4.1', 43+ 'dockerpty >= 0.4.1',
45+ 'jsonschema >= 2.5.1', 44+ 'jsonschema >= 2.5.1',
46+ 'python-dotenv >= 0.13.0', 45+ 'python-dotenv >= 0.13.0',
47 ] 46 ]
48 47
49 48
50@@ -51,7 +51,7 @@ 49@@ -51,7 +56,7 @@
51 extras_require = {
52 ':python_version < "3.5"': ['backports.ssl_match_hostname >= 3.5, < 4'], 50 ':python_version < "3.5"': ['backports.ssl_match_hostname >= 3.5, < 4'],
51 ':python_version < "3.8"': ['cached-property >= 1.2.0, < 2'],
53 ':sys_platform == "win32"': ['colorama >= 0.4, < 1'], 52 ':sys_platform == "win32"': ['colorama >= 0.4, < 1'],
54- 'socks': ['PySocks >= 1.5.6, != 1.5.7, < 2'], 53- 'socks': ['PySocks >= 1.5.6, != 1.5.7, < 2'],
55+ 'socks': ['PySocks >= 1.5.6, != 1.5.7'], 54+ 'socks': ['PySocks >= 1.5.6, != 1.5.7'],
diff --git a/recipes-containers/docker-compose/python3-docker-compose_1.28.2.bb b/recipes-containers/docker-compose/python3-docker-compose_1.29.1.bb
index 1c1aa9bc..d74f742e 100644
--- a/recipes-containers/docker-compose/python3-docker-compose_1.28.2.bb
+++ b/recipes-containers/docker-compose/python3-docker-compose_1.29.1.bb
@@ -5,8 +5,8 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=435b266b3899aa8a959f17d41c56def8"
5 5
6inherit pypi setuptools3 6inherit pypi setuptools3
7 7
8SRC_URI[md5sum] = "48486752654e04eef6c8a79f0d279b30" 8SRC_URI[md5sum] = "49c202544c7e2eadbbe45da8e838ae02"
9SRC_URI[sha256sum] = "2f148b590414915d029dad7551f4cdf0b03a774dc9baa674480217236d260cc1" 9SRC_URI[sha256sum] = "d2064934f5084db8a0c4805e226447bf1fd0c928419be95afb6bd1866838c1f1"
10 10
11 11
12SRC_URI += "file://0001-setup.py-remove-maximum-version-requirements.patch \ 12SRC_URI += "file://0001-setup.py-remove-maximum-version-requirements.patch \