summaryrefslogtreecommitdiffstats
path: root/recipes-containers
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2017-04-11 13:43:34 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-04-11 23:09:01 -0400
commita20d51d5c60f1ae3ce8784d5db044af28006d115 (patch)
tree2451a411bd4000660255460f5e3c18e31bb06785 /recipes-containers
parent752fde1f87884ce0bf31ac36afb47b36a7bca794 (diff)
downloadmeta-virtualization-a20d51d5c60f1ae3ce8784d5db044af28006d115.tar.gz
housekeeping: swap out go-osarchmap in favor of goarch
Continue work to use go infra in oe-core instead of the support for go previously found in meta-virt. This is a 1:1 drop in replacement and removes one more go piece from meta-virt in favor of the common support found in oe-core. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-containers')
-rw-r--r--recipes-containers/docker-distribution/docker-distribution_git.bb2
-rw-r--r--recipes-containers/docker/docker_git.bb2
-rw-r--r--recipes-containers/oci-image-tools/oci-image-tools_git.bb2
-rw-r--r--recipes-containers/oci-runtime-tools/oci-runtime-tools_git.bb2
-rw-r--r--recipes-containers/riddler/riddler_git.bb2
-rw-r--r--recipes-containers/runc/runc.inc2
6 files changed, 6 insertions, 6 deletions
diff --git a/recipes-containers/docker-distribution/docker-distribution_git.bb b/recipes-containers/docker-distribution/docker-distribution_git.bb
index 07920b9f..08b6d70b 100644
--- a/recipes-containers/docker-distribution/docker-distribution_git.bb
+++ b/recipes-containers/docker-distribution/docker-distribution_git.bb
@@ -13,7 +13,7 @@ PACKAGES =+ "docker-registry"
13PV = "v2.6.0-rc+git${SRCPV}" 13PV = "v2.6.0-rc+git${SRCPV}"
14S = "${WORKDIR}/git/src/github.com/docker/distribution" 14S = "${WORKDIR}/git/src/github.com/docker/distribution"
15 15
16inherit go-osarchmap 16inherit goarch
17inherit go 17inherit go
18 18
19# This disables seccomp and apparmor, which are on by default in the 19# This disables seccomp and apparmor, which are on by default in the
diff --git a/recipes-containers/docker/docker_git.bb b/recipes-containers/docker/docker_git.bb
index 6b73cf3d..74170cbf 100644
--- a/recipes-containers/docker/docker_git.bb
+++ b/recipes-containers/docker/docker_git.bb
@@ -72,7 +72,7 @@ DOCKER_PKG="github.com/docker/docker"
72 72
73inherit systemd update-rc.d 73inherit systemd update-rc.d
74inherit go 74inherit go
75inherit go-osarchmap 75inherit goarch
76 76
77do_configure[noexec] = "1" 77do_configure[noexec] = "1"
78 78
diff --git a/recipes-containers/oci-image-tools/oci-image-tools_git.bb b/recipes-containers/oci-image-tools/oci-image-tools_git.bb
index 125362bb..29a89266 100644
--- a/recipes-containers/oci-image-tools/oci-image-tools_git.bb
+++ b/recipes-containers/oci-image-tools/oci-image-tools_git.bb
@@ -18,7 +18,7 @@ PV = "0.1.0+git${SRCPV}"
18 18
19S = "${WORKDIR}/git" 19S = "${WORKDIR}/git"
20 20
21inherit go-osarchmap 21inherit goarch
22inherit go 22inherit go
23 23
24# This disables seccomp and apparmor, which are on by default in the 24# This disables seccomp and apparmor, which are on by default in the
diff --git a/recipes-containers/oci-runtime-tools/oci-runtime-tools_git.bb b/recipes-containers/oci-runtime-tools/oci-runtime-tools_git.bb
index 176860ec..4f77dced 100644
--- a/recipes-containers/oci-runtime-tools/oci-runtime-tools_git.bb
+++ b/recipes-containers/oci-runtime-tools/oci-runtime-tools_git.bb
@@ -10,7 +10,7 @@ PV = "0.0.1+git${SRCPV}"
10 10
11S = "${WORKDIR}/git" 11S = "${WORKDIR}/git"
12 12
13inherit go-osarchmap 13inherit goarch
14inherit go 14inherit go
15 15
16do_compile() { 16do_compile() {
diff --git a/recipes-containers/riddler/riddler_git.bb b/recipes-containers/riddler/riddler_git.bb
index 51599803..ae6c5ec9 100644
--- a/recipes-containers/riddler/riddler_git.bb
+++ b/recipes-containers/riddler/riddler_git.bb
@@ -9,7 +9,7 @@ PV = "0.1.0+git${SRCPV}"
9 9
10S = "${WORKDIR}/git" 10S = "${WORKDIR}/git"
11 11
12inherit go-osarchmap 12inherit goarch
13inherit go 13inherit go
14 14
15# This disables seccomp and apparmor, which are on by default in the 15# This disables seccomp and apparmor, which are on by default in the
diff --git a/recipes-containers/runc/runc.inc b/recipes-containers/runc/runc.inc
index 41baf739..4808547b 100644
--- a/recipes-containers/runc/runc.inc
+++ b/recipes-containers/runc/runc.inc
@@ -18,7 +18,7 @@ LIBCONTAINER_PACKAGE="github.com/opencontainers/runc/libcontainer"
18do_configure[noexec] = "1" 18do_configure[noexec] = "1"
19EXTRA_OEMAKE="BUILDTAGS=''" 19EXTRA_OEMAKE="BUILDTAGS=''"
20 20
21inherit go-osarchmap 21inherit goarch
22 22
23do_compile() { 23do_compile() {
24 export GOARCH="${TARGET_GOARCH}" 24 export GOARCH="${TARGET_GOARCH}"