summaryrefslogtreecommitdiffstats
path: root/recipes-containers
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2021-09-14 13:12:02 -0400
committerBruce Ashfield <bruce.ashfield@gmail.com>2021-09-16 18:01:55 -0400
commit98c8cbc1308181bed244e86f77b738444c7b6fd7 (patch)
tree97dd17f102cbfa1d71aba6a35983def193b556fc /recipes-containers
parentcafbf244e6f54fd37731ee8a37b942314895ec41 (diff)
downloadmeta-virtualization-98c8cbc1308181bed244e86f77b738444c7b6fd7.tar.gz
spf13-pflag: update to 1.0.4
Bumping pflag to version v1.0.5-4-gd5e0c06, which comprises the following commits: d5e0c06 allow for blank ip addresses (#316) 85dd5c8 Add IPNetSlice and unit tests (#170) 6971c29 remove dead code for checking error nil (#282) 81378bb Add exported functions to preserve `pkg/flag` compatibility (#220) 14457a6 Remove require pflag v1.0.3 e8f2996 Fix typo in go.mod 8e39cc4 gofmt 68f4136 Add SliceValue Comments b22fc70 Expand SliceValue support to all slice and array types. c6c0f0f Add first SliceValue implementations 9722382 Added String-To-Int64 option parsing (#211) 4890c25 Fix package doc b3e76d4 Fix descriptions for StringSlice functions 24fa697 fix misspell (#197) 916c5bf Fix typo in count.go (#196) aea12ed add int32 & int64 slice support (#194) 454a7fb add float32 & float64 slice support (#192) 082b515 Travis: test on 1.9 as well (#191) 252d3ee travis: update to 1.10 and 1.11 in travis tests (#190) 0873577 Fix golint import path (#189) b5e1a80 Sentence restructure and grammar fix (#188) 298182f Fix panic when parsing unknown flag followed by empty argument (#173) d929dcb Handle single string=>string flags without quotes (#179) 947b89b Add map valued (string->string, string->int) flags. (#133) 9a97c10 bytes: add support for base64 encoded flags (#177) 3ebe029 Allow bubbling up of -test.* flags (#169) 583c0c0 Typo correction in flag.go (#164) 329ebf1 Allow Users To Show Deprecated Flags (#163) 1ce0cc6 make x.Parsed() return true after AddGoFlagSet(x) and pflag.Parse() (#162) 1cd4a0c add ability to ignore unknown flags (#160) ad68c28 Add multiline wrapping support (#155) 45e82a3 Implement BytesHex type of argument (#115) ee5fd03 doc: clarify difference between string slice vs. array (#158) 6a877eb DurationSlice: implementation and tests (#122) 4c012f6 Add uintSlice and boolSlice to name prettifier (#150) 97afa5e Prevent printing when using ContinueOnError (#144) 1f33b80 add int16 flag (#143) a9789e8 Remove redundant break 2c300e7 Fixing Count flag usage string (#141) be7121d Fix SetNormalizeFunc (#137) 5c2d607 Generate flag error output for errors returned from the parseFunc (#138) 7aff26d New: renamed intSlice to ints in usage 230e229 Fixed: updated unittest adc6ccc New: added a default name to avoid stringSlice in the usage message. e57e3ee Delete example, what isn't even shown in docs 80fe0fb Testing for Shorthand Lookup 75859d1 Add example to FlagSet.ShorthandLookup 86425cb Add example to ShorthandLookup 10b28b3 Add note about panic in ShorthandLookup a84f757 Allow lookup by shorthand (#106) c990990 Add Go 1.8.1 to .travis.yml af3f947 Update .travis.yml f1d95a3 Unify error message for panic and f.out 314c91c Use comparison a string with "" instead of comparison of len 1cd6182 Prevent parsing if there are no arguments 9c8891d Add more verbosity to panic of shorthand redefinition 1d9fab4 Use f.out in output flag deprecation 4995a3e Make more detailed error in Set 9421342 Add comments for better understanding of parsing short flags 159e1d7 Document Count function e466d44 Delete setFlag 686edd7 Fix alreadythere variable name af10531 Note about SortFlags in README e453343 flag_test: fix go vet (#123) 0328f15 Cache sorted flags 9a906f1 Prevent changing order of flags after SetNormalizeFunc() (#121) d16db1e Modified to display a string default value as double quoted and escaped (#118) d90f37a Add SortFlags option (#113) b205ad1 Change `ogier` to `spf13` in docs and README 9ff6c69 Add FlagSet.FlagUsagesWrapped(cols) which wraps to the given column (#105) 3f939ad Removed unused field "exitOnError". Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-containers')
-rw-r--r--recipes-containers/go-spf13-pflag/spf13-pflag_git.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes-containers/go-spf13-pflag/spf13-pflag_git.bb b/recipes-containers/go-spf13-pflag/spf13-pflag_git.bb
index df0db0c9..cbccbdb9 100644
--- a/recipes-containers/go-spf13-pflag/spf13-pflag_git.bb
+++ b/recipes-containers/go-spf13-pflag/spf13-pflag_git.bb
@@ -9,8 +9,8 @@ SRCNAME = "pflag"
9PKG_NAME = "github.com/spf13/${SRCNAME}" 9PKG_NAME = "github.com/spf13/${SRCNAME}"
10SRC_URI = "git://${PKG_NAME}.git;destsuffix=git/src/${PKG_NAME}" 10SRC_URI = "git://${PKG_NAME}.git;destsuffix=git/src/${PKG_NAME}"
11 11
12SRCREV = "9ff6c6923cfffbcd502984b8e0c80539a94968b7" 12SRCREV = "d5e0c0615acee7028e1e2740a11102313be88de1"
13PV = "v1.0.0-rc4+git${SRCPV}" 13PV = "v1.0.5+git${SRCPV}"
14 14
15S = "${WORKDIR}/git" 15S = "${WORKDIR}/git"
16 16