summaryrefslogtreecommitdiffstats
path: root/recipes-containers
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2021-05-25 12:57:55 -0400
committerBruce Ashfield <bruce.ashfield@gmail.com>2021-06-04 08:43:02 -0400
commit87460f34d756d5833fa58efacecb9148b03290e9 (patch)
tree3f65eedefc8ea57079b3031e9c82bacfef006a9a /recipes-containers
parente16ec7aebc732442bc786fb92da923d1ba0c745b (diff)
downloadmeta-virtualization-87460f34d756d5833fa58efacecb9148b03290e9.tar.gz
containerd-opencontainers: update to 1.5.2
Updating to the released 1.5.x containerd. We also add a patch to fix the following: Since our oe-core go infrastructure insists on both -pie and static builds (for the most part), and that is not recommended by many packages, we end up with errors like: cannot find package runtime/cgo (using -importcfg) ... recipe-sysroot-native/usr/lib/aarch64-poky-linux/go/pkg/tool/linux_amd64/link: cannot open file : open : no such file or directory Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-containers')
-rw-r--r--recipes-containers/containerd/containerd-opencontainers/0001-Makefile-allow-GO_BUILD_FLAGS-to-be-externally-speci.patch38
-rw-r--r--recipes-containers/containerd/containerd-opencontainers_git.bb13
2 files changed, 47 insertions, 4 deletions
diff --git a/recipes-containers/containerd/containerd-opencontainers/0001-Makefile-allow-GO_BUILD_FLAGS-to-be-externally-speci.patch b/recipes-containers/containerd/containerd-opencontainers/0001-Makefile-allow-GO_BUILD_FLAGS-to-be-externally-speci.patch
new file mode 100644
index 00000000..7f4d7518
--- /dev/null
+++ b/recipes-containers/containerd/containerd-opencontainers/0001-Makefile-allow-GO_BUILD_FLAGS-to-be-externally-speci.patch
@@ -0,0 +1,38 @@
1From 474b93f8f643651144304a6971ef476add7f06f8 Mon Sep 17 00:00:00 2001
2From: Bruce Ashfield <bruce.ashfield@gmail.com>
3Date: Tue, 25 May 2021 12:49:41 -0400
4Subject: [PATCH] Makefile: allow GO_BUILD_FLAGS to be externally specified
5
6Since our oe-core go infrastructure insists on both -pie and static
7builds (for the most part), and that is not recommended by many
8packages, we end up with errors like:
9
10 cannot find package runtime/cgo (using -importcfg)
11 ...
12 recipe-sysroot-native/usr/lib/aarch64-poky-linux/go/pkg/tool/linux_amd64/link:
13 cannot open file : open : no such file or directory
14
15Upstream-Status: Inappropriate: specific to OE go configuration and build
16
17Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
18---
19 Makefile | 3 ++-
20 1 file changed, 2 insertions(+), 1 deletion(-)
21
22diff --git git.orig/src/import/Makefile git.orig/src/import/Makefile
23index c61418e60..54a10eb42 100644
24--- git.orig/src/import/Makefile
25+++ git.orig/src/import/Makefile
26@@ -112,7 +112,8 @@ endif
27 GOPATHS=$(shell echo ${GOPATH} | tr ":" "\n" | tr ";" "\n")
28
29 TESTFLAGS_RACE=
30-GO_BUILD_FLAGS=
31+# allow flags to be exported and picked up.
32+# GO_BUILD_FLAGS=
33 # See Golang issue re: '-trimpath': https://github.com/golang/go/issues/13809
34 GO_GCFLAGS=$(shell \
35 set -- ${GOPATHS}; \
36--
372.19.1
38
diff --git a/recipes-containers/containerd/containerd-opencontainers_git.bb b/recipes-containers/containerd/containerd-opencontainers_git.bb
index 2674a17e..8ac1ffaf 100644
--- a/recipes-containers/containerd/containerd-opencontainers_git.bb
+++ b/recipes-containers/containerd/containerd-opencontainers_git.bb
@@ -5,17 +5,17 @@ DESCRIPTION = "containerd is a daemon to control runC, built for performance and
5 support as well as checkpoint and restore for cloning and live migration of containers." 5 support as well as checkpoint and restore for cloning and live migration of containers."
6 6
7 7
8SRCREV = "32005190c04eb635cdd0de7c9245dd043168ec9e" 8SRCREV = "36cc874494a56a253cd181a1a685b44b58a2e34a"
9SRC_URI = "git://github.com/containerd/containerd;branch=master \ 9SRC_URI = "git://github.com/containerd/containerd;branch=release/1.5 \
10 file://0001-build-use-oe-provided-GO-and-flags.patch \
11 file://0001-Add-build-option-GODEBUG-1.patch \ 10 file://0001-Add-build-option-GODEBUG-1.patch \
11 file://0001-Makefile-allow-GO_BUILD_FLAGS-to-be-externally-speci.patch \
12 " 12 "
13 13
14# Apache-2.0 for containerd 14# Apache-2.0 for containerd
15LICENSE = "Apache-2.0" 15LICENSE = "Apache-2.0"
16LIC_FILES_CHKSUM = "file://src/import/LICENSE;md5=1269f40c0d099c21a871163984590d89" 16LIC_FILES_CHKSUM = "file://src/import/LICENSE;md5=1269f40c0d099c21a871163984590d89"
17 17
18CONTAINERD_VERSION = "v1.5.0-rc" 18CONTAINERD_VERSION = "v1.5.2"
19 19
20EXTRA_OEMAKE += "GODEBUG=1" 20EXTRA_OEMAKE += "GODEBUG=1"
21 21
@@ -78,6 +78,11 @@ do_compile() {
78 export CFLAGS="${CFLAGS}" 78 export CFLAGS="${CFLAGS}"
79 export LDFLAGS="${LDFLAGS}" 79 export LDFLAGS="${LDFLAGS}"
80 export SHIM_CGO_ENABLED="${CGO_ENABLED}" 80 export SHIM_CGO_ENABLED="${CGO_ENABLED}"
81 # fixes:
82 # cannot find package runtime/cgo (using -importcfg)
83 # ... recipe-sysroot-native/usr/lib/aarch64-poky-linux/go/pkg/tool/linux_amd64/link:
84 # cannot open file : open : no such file or directory
85 export GO_BUILD_FLAGS="-a -pkgdir dontusecurrentpkgs"
81 export GO111MODULE=off 86 export GO111MODULE=off
82 87
83 cd ${S}/src/import 88 cd ${S}/src/import