summaryrefslogtreecommitdiffstats
path: root/recipes-containers
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2023-09-06 03:09:26 +0000
committerBruce Ashfield <bruce.ashfield@gmail.com>2023-09-15 17:30:40 +0000
commit7ed351dbdc079aaa92b1c03007c91892126b7811 (patch)
tree51741cb01a5549ae46497f4d12fc44c88678f321 /recipes-containers
parent103695c7b9578f3380b5b4ab851548c3d9aaef4a (diff)
downloadmeta-virtualization-7ed351dbdc079aaa92b1c03007c91892126b7811.tar.gz
docker: drop docker-ce recipe
docker-ce is now the same as moby. We've had a warning for quite some time now, so it is time to remove the recipe. We don't RPROVIDE docker-ce in the docker-moby recipe as part of this removal, as all docker packages have been RPROVIDING "docker" regardless of the variant. images and packagelists should be using that provider, not docker-moby and docker-ce Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-containers')
-rw-r--r--recipes-containers/docker/docker-ce_git.bb8
1 files changed, 0 insertions, 8 deletions
diff --git a/recipes-containers/docker/docker-ce_git.bb b/recipes-containers/docker/docker-ce_git.bb
deleted file mode 100644
index a3ea9ab5..00000000
--- a/recipes-containers/docker/docker-ce_git.bb
+++ /dev/null
@@ -1,8 +0,0 @@
1# docker-ce and docker-moby are now nearly identical. We simply include the
2# moby recipe and warn if this is being built.
3include docker-moby_git.bb
4
5do_compile:prepend() {
6 bbwarn "${PN} is now the same as docker-moby. This recipe will be removed in future releases."
7 bbwarn "Consumers of docker should migrate to moby as soon as possible"
8}