summaryrefslogtreecommitdiffstats
path: root/recipes-containers
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2017-02-20 02:00:20 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-02-20 02:06:22 -0500
commit7d6284a079748f919e3e0b8116649cfa5ff8ee8f (patch)
tree7a6f3a22b38f6ecac9631410e19a21904bed6efd /recipes-containers
parent776422fa046e0779b48ddfaaed4fb35651256258 (diff)
downloadmeta-virtualization-7d6284a079748f919e3e0b8116649cfa5ff8ee8f.tar.gz
runc/containerd: create virtual/runc and virtual/containerd
Since there are two implementations of runc and containerd that may not always be in sync, the docker variant, and the opencontainers variable, we create a virtual/* namespace for these components. Anything requiring runc or containerd should set a preferred provider to get the desired/tested variant. We set the default provider to the docker variants, since they are the primary use case for these components. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-containers')
-rw-r--r--recipes-containers/containerd/containerd-docker_git.bb10
-rw-r--r--recipes-containers/containerd/containerd-opencontainers_git.bb9
-rw-r--r--recipes-containers/containerd/containerd.inc (renamed from recipes-containers/containerd/containerd_git.bb)6
-rw-r--r--recipes-containers/docker/docker_git.bb3
-rw-r--r--recipes-containers/runc/runc-docker_git.bb11
-rw-r--r--recipes-containers/runc/runc-opencontainers_git.bb8
-rw-r--r--recipes-containers/runc/runc.inc (renamed from recipes-containers/runc/runc_git.bb)8
7 files changed, 40 insertions, 15 deletions
diff --git a/recipes-containers/containerd/containerd-docker_git.bb b/recipes-containers/containerd/containerd-docker_git.bb
new file mode 100644
index 00000000..f6dcaeca
--- /dev/null
+++ b/recipes-containers/containerd/containerd-docker_git.bb
@@ -0,0 +1,10 @@
1include containerd.inc
2
3SRCREV = "03e5862ec0d8d3b3f750e19fca3ee367e13c090e"
4SRC_URI = "\
5 git://github.com/docker/containerd.git;branch=docker-1.13.x \
6 "
7CONTAINERD_VERSION = "0.2.3"
8
9PROVIDES += "virtual/containerd"
10RPROVIDES_${PN} = "virtual/containerd"
diff --git a/recipes-containers/containerd/containerd-opencontainers_git.bb b/recipes-containers/containerd/containerd-opencontainers_git.bb
new file mode 100644
index 00000000..37f85472
--- /dev/null
+++ b/recipes-containers/containerd/containerd-opencontainers_git.bb
@@ -0,0 +1,9 @@
1include containerd.inc
2
3SRCREV = "0ac3cd1be170d180b2baed755e8f0da547ceb267"
4SRC_URI = "git://github.com/docker/containerd.git;nobranch=1 \
5 "
6CONTAINERD_VERSION = "0.2.2"
7
8PROVIDES += "virtual/containerd"
9RPROVIDES_${PN} = "virtual/containerd"
diff --git a/recipes-containers/containerd/containerd_git.bb b/recipes-containers/containerd/containerd.inc
index 67011a35..a128fbde 100644
--- a/recipes-containers/containerd/containerd_git.bb
+++ b/recipes-containers/containerd/containerd.inc
@@ -4,18 +4,12 @@ DESCRIPTION = "containerd is a daemon to control runC, built for performance and
4 containerd leverages runC's advanced features such as seccomp and user namespace \ 4 containerd leverages runC's advanced features such as seccomp and user namespace \
5 support as well as checkpoint and restore for cloning and live migration of containers." 5 support as well as checkpoint and restore for cloning and live migration of containers."
6 6
7SRCREV = "03e5862ec0d8d3b3f750e19fca3ee367e13c090e"
8SRC_URI = "\
9 git://github.com/docker/containerd.git;branch=docker-1.13.x \
10 "
11
12# Apache-2.0 for containerd 7# Apache-2.0 for containerd
13LICENSE = "Apache-2.0" 8LICENSE = "Apache-2.0"
14LIC_FILES_CHKSUM = "file://LICENSE.code;md5=aadc30f9c14d876ded7bedc0afd2d3d7" 9LIC_FILES_CHKSUM = "file://LICENSE.code;md5=aadc30f9c14d876ded7bedc0afd2d3d7"
15 10
16S = "${WORKDIR}/git" 11S = "${WORKDIR}/git"
17 12
18CONTAINERD_VERSION = "0.2.3"
19PV = "${CONTAINERD_VERSION}+git${SRCREV}" 13PV = "${CONTAINERD_VERSION}+git${SRCREV}"
20 14
21DEPENDS = "go-cross-${TARGET_ARCH} \ 15DEPENDS = "go-cross-${TARGET_ARCH} \
diff --git a/recipes-containers/docker/docker_git.bb b/recipes-containers/docker/docker_git.bb
index 46ad26e9..c8ab45a0 100644
--- a/recipes-containers/docker/docker_git.bb
+++ b/recipes-containers/docker/docker_git.bb
@@ -63,7 +63,8 @@ DEPENDS_append_class-target = "lvm2"
63RDEPENDS_${PN} = "curl aufs-util git util-linux iptables \ 63RDEPENDS_${PN} = "curl aufs-util git util-linux iptables \
64 ${@bb.utils.contains('DISTRO_FEATURES','systemd','','cgroup-lite',d)} \ 64 ${@bb.utils.contains('DISTRO_FEATURES','systemd','','cgroup-lite',d)} \
65 " 65 "
66RDEPENDS_${PN} += "containerd runc" 66RDEPENDS_${PN} += "virtual/containerd virtual/runc"
67
67RRECOMMENDS_${PN} = "kernel-module-dm-thin-pool kernel-module-nf-nat" 68RRECOMMENDS_${PN} = "kernel-module-dm-thin-pool kernel-module-nf-nat"
68RSUGGESTS_${PN} = "lxc docker-registry rt-tests" 69RSUGGESTS_${PN} = "lxc docker-registry rt-tests"
69DOCKER_PKG="github.com/docker/docker" 70DOCKER_PKG="github.com/docker/docker"
diff --git a/recipes-containers/runc/runc-docker_git.bb b/recipes-containers/runc/runc-docker_git.bb
new file mode 100644
index 00000000..96d48cae
--- /dev/null
+++ b/recipes-containers/runc/runc-docker_git.bb
@@ -0,0 +1,11 @@
1include runc.inc
2
3# Note: this rev is before the required protocol field, update when all components
4# have been updated to match.
5SRCREV = "2f7393a47307a16f8cee44a37b262e8b81021e3e"
6SRC_URI = "git://github.com/docker/runc.git;nobranch=1 \
7 "
8
9RUNC_VERSION = "1.0.0-rc2"
10PROVIDES += "virtual/runc"
11RPROVIDES_${PN} = "virtual/runc"
diff --git a/recipes-containers/runc/runc-opencontainers_git.bb b/recipes-containers/runc/runc-opencontainers_git.bb
new file mode 100644
index 00000000..a302d4b5
--- /dev/null
+++ b/recipes-containers/runc/runc-opencontainers_git.bb
@@ -0,0 +1,8 @@
1include runc.inc
2
3SRCREV = "1cdaa709f151b61cee2bdaa09d8e5d2b58a8ba72"
4SRC_URI = "git://github.com/opencontainers/runc;branch=master \
5 "
6RUNC_VERSION = "1.0.0-rc1"
7PROVIDES += "virtual/runc"
8RPROVIDES_${PN} = "virtual/runc"
diff --git a/recipes-containers/runc/runc_git.bb b/recipes-containers/runc/runc.inc
index c5cf40be..7626dad7 100644
--- a/recipes-containers/runc/runc_git.bb
+++ b/recipes-containers/runc/runc.inc
@@ -2,20 +2,12 @@ HOMEPAGE = "https://github.com/opencontainers/runc"
2SUMMARY = "runc container cli tools" 2SUMMARY = "runc container cli tools"
3DESCRIPTION = "runc is a CLI tool for spawning and running containers according to the OCI specification." 3DESCRIPTION = "runc is a CLI tool for spawning and running containers according to the OCI specification."
4 4
5# Note: this rev is before the required protocol field, update when all components
6# have been updated to match.
7SRCREV = "2f7393a47307a16f8cee44a37b262e8b81021e3e"
8SRC_URI = "\
9 git://github.com/docker/runc.git;nobranch=1 \
10 "
11
12# Apache-2.0 for containerd 5# Apache-2.0 for containerd
13LICENSE = "Apache-2.0" 6LICENSE = "Apache-2.0"
14LIC_FILES_CHKSUM = "file://LICENSE;md5=435b266b3899aa8a959f17d41c56def8" 7LIC_FILES_CHKSUM = "file://LICENSE;md5=435b266b3899aa8a959f17d41c56def8"
15 8
16S = "${WORKDIR}/git" 9S = "${WORKDIR}/git"
17 10
18RUNC_VERSION = "1.0.0-rc2"
19PV = "${RUNC_VERSION}+git${SRCREV}" 11PV = "${RUNC_VERSION}+git${SRCREV}"
20 12
21DEPENDS = "go-cross-${TARGET_ARCH} \ 13DEPENDS = "go-cross-${TARGET_ARCH} \