summaryrefslogtreecommitdiffstats
path: root/recipes-containers
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2022-06-12 01:00:05 -0700
committerBruce Ashfield <bruce.ashfield@gmail.com>2022-06-20 12:09:46 -0400
commit7808674c4cd92d719507ecec345c105f4740467d (patch)
tree1bf01b712e4dbf18d48621806b07b776b6e212c4 /recipes-containers
parentce03a8868f90aca0d31dff3f17f49ef13ce923b9 (diff)
downloadmeta-virtualization-7808674c4cd92d719507ecec345c105f4740467d.tar.gz
umoci: adjust CGO_CFLAGS and CGO_LDFLAGS settings
The CGO_CFLAGS and CGO_LDFLAGS should use target flags instead of the nativesdk ones. Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-containers')
-rw-r--r--recipes-containers/umoci/umoci_git.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes-containers/umoci/umoci_git.bb b/recipes-containers/umoci/umoci_git.bb
index a2c08279..3e7b9128 100644
--- a/recipes-containers/umoci/umoci_git.bb
+++ b/recipes-containers/umoci/umoci_git.bb
@@ -61,8 +61,8 @@ do_compile() {
61 export CGO_ENABLED="1" 61 export CGO_ENABLED="1"
62 export CFLAGS="" 62 export CFLAGS=""
63 export LDFLAGS="" 63 export LDFLAGS=""
64 export CGO_CFLAGS="${BUILDSDK_CFLAGS} --sysroot=${STAGING_DIR_TARGET}" 64 export CGO_CFLAGS="${TARGET_CFLAGS}"
65 export CGO_LDFLAGS="${BUILDSDK_LDFLAGS} --sysroot=${STAGING_DIR_TARGET}" 65 export CGO_LDFLAGS="${TARGET_LDFLAGS}"
66 66
67 export GO111MODULE=off 67 export GO111MODULE=off
68 68