summaryrefslogtreecommitdiffstats
path: root/recipes-containers
diff options
context:
space:
mode:
authorFabio Berton <fabio.berton@ossystems.com.br>2016-06-14 14:59:12 -0300
committerBruce Ashfield <bruce.ashfield@windriver.com>2016-06-17 08:34:46 -0400
commit7605443085454a4c523c04b981db85ee96a1f9d5 (patch)
treed1db4cca58dbc88d70046abdd5a27423e90b7df4 /recipes-containers
parent06dccfa933d7ef60d2f6739f78e1197c7f8df5cd (diff)
downloadmeta-virtualization-7605443085454a4c523c04b981db85ee96a1f9d5.tar.gz
docker-registry: Make version dependence compatible with opkg
Some recipes in RDEPENDS are installing specific version of package, for example: gunicorn (= 19.1.1) If usigin ipk for PACKAGE_CLASSES, opkg prints error: Collected errors: * satisfy_dependencies_for: Cannot satisfy the following dependencies for docker: * gunicorn (= 19.1.1) * * opkg_install: Cannot install package docker. This error is caused because opkg appends package revision to version. In this case: gunicorn_19.1.1-r0.1 If we use comparator >= this error doesn't appear. Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-containers')
-rw-r--r--recipes-containers/docker-registry/docker-registry_git.bb26
1 files changed, 13 insertions, 13 deletions
diff --git a/recipes-containers/docker-registry/docker-registry_git.bb b/recipes-containers/docker-registry/docker-registry_git.bb
index 996dfddc..e94e9858 100644
--- a/recipes-containers/docker-registry/docker-registry_git.bb
+++ b/recipes-containers/docker-registry/docker-registry_git.bb
@@ -24,27 +24,27 @@ PV = "0.9.1+git${SRCREV}"
24 24
25RDEPENDS_${PN} += "\ 25RDEPENDS_${PN} += "\
26 docker \ 26 docker \
27 gunicorn (= 19.1.1) \ 27 gunicorn (>= 19.1.1) \
28 python-pip \ 28 python-pip \
29 python-distribute \ 29 python-distribute \
30 python-m2crypto (= 0.22.3) \ 30 python-m2crypto (>= 0.22.3) \
31 python-pyyaml (= 3.11) \ 31 python-pyyaml (>= 3.11) \
32 python-flask (= 0.10.1) \ 32 python-flask (>= 0.10.1) \
33 python-gevent (= 1.0.1) \ 33 python-gevent (>= 1.0.1) \
34 python-requests \ 34 python-requests \
35 python-sqlalchemy (>= 0.9.4) \ 35 python-sqlalchemy (>= 0.9.4) \
36 python-blinker (= 1.3) \ 36 python-blinker (>= 1.3) \
37 python-backports-lzma (= 0.0.3) \ 37 python-backports-lzma (>= 0.0.3) \
38 python-flask-cors (= 1.10.3) \ 38 python-flask-cors (>= 1.10.3) \
39 python-bugsnag (= 2.0.2) \ 39 python-bugsnag (>= 2.0.2) \
40 python-docker-registry-core (= 2.0.3) \ 40 python-docker-registry-core (>= 2.0.3) \
41 python-newrelic (= 2.22.0.19) \ 41 python-newrelic (>= 2.22.0.19) \
42 python-itsdangerous (>= 0.21) \ 42 python-itsdangerous (>= 0.21) \
43 python-jinja2 (>= 2.4) \ 43 python-jinja2 (>= 2.4) \
44 python-werkzeug (>= 0.7) \ 44 python-werkzeug (>= 0.7) \
45 python-simplejson (>= 3.6.2) \ 45 python-simplejson (>= 3.6.2) \
46 python-redis (= 2.10.3) \ 46 python-redis (>= 2.10.3) \
47 python-boto (= 2.34.0) \ 47 python-boto (>= 2.34.0) \
48 python-webob \ 48 python-webob \
49 " 49 "
50# OFFICIAL REQ: 50# OFFICIAL REQ: