summaryrefslogtreecommitdiffstats
path: root/recipes-containers
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2020-03-03 23:11:35 +0100
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-03-03 20:03:22 -0500
commit7164f0391d4e2073cdb2fa8f2666c71083a02586 (patch)
tree1ec276ff0d7524bfcb9f8798b60e46a24d183abf /recipes-containers
parent7251b240d1bd177e70d309c318b1ebe35cbe0e69 (diff)
downloadmeta-virtualization-7164f0391d4e2073cdb2fa8f2666c71083a02586.tar.gz
docker-moby: fix build
* apply similar patch to what was applied to docker-ce in: http://git.yoctoproject.org/cgit/cgit.cgi/meta-virtualization/commit/recipes-containers/docker?id=e7787cb01be91d3798594687a475d5b085f29ede it's very similar, but needs to be separate .patch file, because the path to make/.binary is different in docker-ce and docker-moby. since the recent upgrade: http://git.yoctoproject.org/cgit/cgit.cgi/meta-virtualization/commit/?id=f770151b3ff0938bea4972abdd1ee7f6cbc3a074 docker-moby needs the same change or fails like this: | ERROR: Execution of 'work/raspberrypi4-oe-linux-gnueabi/docker-moby/19.03.6+git71373c6105e3cbc9702935b96d8ee01214c405e7-r0/temp/run.do_compile.31754' failed with exit code 2: | | Package devmapper was not found in the pkg-config search path. | Perhaps you should add the directory containing `devmapper.pc' | to the PKG_CONFIG_PATH environment variable | No package 'devmapper' found | Removing bundles/ | | ---> Making bundle: dynbinary (in bundles/dynbinary) | Building: bundles/dynbinary-daemon/dockerd-19.03.6 | GOOS="linux" GOARCH="arm" GOARM="7" | # runtime/cgo | exec: "arm-linux-gnueabihf-gcc": executable file not found in $PATH | WARNING: work/raspberrypi4-oe-linux-gnueabi/docker-moby/19.03.6+git71373c6105e3cbc9702935b96d8ee01214c405e7-r0/temp/run.do_compile.31754:1 exit 2 from 'VERSION="19.03.6" DOCKER_GITCOMMIT="${SRCREV_docker}" ./hack/make.sh dynbinary' | ERROR: Task (meta-virtualization/recipes-containers/docker/docker-moby.bb:do_compile) failed with exit code '1' Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-containers')
-rw-r--r--recipes-containers/docker/docker-moby.bb1
-rw-r--r--recipes-containers/docker/docker-moby/0001-imporve-hardcoded-CC-on-cross-compile-docker-ce.patch61
2 files changed, 62 insertions, 0 deletions
diff --git a/recipes-containers/docker/docker-moby.bb b/recipes-containers/docker/docker-moby.bb
index a8c5946e..39bc2637 100644
--- a/recipes-containers/docker/docker-moby.bb
+++ b/recipes-containers/docker/docker-moby.bb
@@ -44,6 +44,7 @@ SRC_URI = "\
44 git://github.com/docker/cli;branch=19.03;name=cli;destsuffix=git/cli \ 44 git://github.com/docker/cli;branch=19.03;name=cli;destsuffix=git/cli \
45 file://docker.init \ 45 file://docker.init \
46 file://0001-libnetwork-use-GO-instead-of-go.patch \ 46 file://0001-libnetwork-use-GO-instead-of-go.patch \
47 file://0001-imporve-hardcoded-CC-on-cross-compile-docker-ce.patch \
47 " 48 "
48 49
49require docker.inc 50require docker.inc
diff --git a/recipes-containers/docker/docker-moby/0001-imporve-hardcoded-CC-on-cross-compile-docker-ce.patch b/recipes-containers/docker/docker-moby/0001-imporve-hardcoded-CC-on-cross-compile-docker-ce.patch
new file mode 100644
index 00000000..766425a8
--- /dev/null
+++ b/recipes-containers/docker/docker-moby/0001-imporve-hardcoded-CC-on-cross-compile-docker-ce.patch
@@ -0,0 +1,61 @@
1From 1263fdb50a540e9db742694b7cee08284ad986d0 Mon Sep 17 00:00:00 2001
2From: Hongxu Jia <hongxu.jia@windriver.com>
3Date: Wed, 17 Jul 2019 17:34:04 +0800
4Subject: [PATCH] imporve hardcoded CC on cross compile
5
6Since commit applied in moby [61a3285 Support cross-compile for arm]
7it hardcoded var-CC to support cross-compile for arm
8
9Correct it with "${parameter:-word}" format, it is helpful for user
10define toolchains
11
12(Use Default Values. If parameter is unset or null, the expansion of
13word is substituted. Otherwise, the value of parameter is substituted.)
14
15Upstream-Status: Submitted [https://github.com/moby/moby/pull/39546]
16
17Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
18---
19 components/engine/hack/make/.binary | 10 +++++-----
20 1 file changed, 5 insertions(+), 5 deletions(-)
21
22diff --git a/src/import/hack/make/.binary b/src/import/hack/make/.binary
23index 53de6749e5..66f4ca05f3 100644
24--- a/src/import/hack/make/.binary
25+++ b/src/import/hack/make/.binary
26@@ -44,27 +44,27 @@ if [ "$(go env GOOS)/$(go env GOARCH)" != "$(go env GOHOSTOS)/$(go env GOHOSTARC
27 # must be cross-compiling!
28 case "$(go env GOOS)/$(go env GOARCH)" in
29 windows/amd64)
30- export CC=x86_64-w64-mingw32-gcc
31+ export CC="${CC:-x86_64-w64-mingw32-gcc}"
32 export CGO_ENABLED=1
33 ;;
34 linux/arm)
35 case "${GOARM}" in
36 5|"")
37- export CC=arm-linux-gnueabi-gcc
38+ export CC="${CC:-arm-linux-gnueabi-gcc}"
39 export CGO_ENABLED=1
40 ;;
41 7)
42- export CC=arm-linux-gnueabihf-gcc
43+ export CC="${CC:-arm-linux-gnueabihf-gcc}"
44 export CGO_ENABLED=1
45 ;;
46 esac
47 ;;
48 linux/arm64)
49- export CC=aarch64-linux-gnu-gcc
50+ export CC="${CC:-aarch64-linux-gnu-gcc}"
51 export CGO_ENABLED=1
52 ;;
53 linux/amd64)
54- export CC=x86_64-linux-gnu-gcc
55+ export CC="${CC:-x86_64-linux-gnu-gcc}"
56 export CGO_ENABLED=1
57 ;;
58 esac
59--
602.23.0
61