summaryrefslogtreecommitdiffstats
path: root/recipes-containers
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2022-03-29 19:49:23 -0400
committerBruce Ashfield <bruce.ashfield@gmail.com>2022-03-30 09:42:46 -0400
commit700220557cf657ebbfef09626f588d3eea25f552 (patch)
tree857865620e9f1bc38a08d32d2819c056db12ea46 /recipes-containers
parentf17c020e205e499565e2fe40f6d63c19a420d229 (diff)
downloadmeta-virtualization-700220557cf657ebbfef09626f588d3eea25f552.tar.gz
containers: introduce podman-tui
Add the curses/terminal control application for podman. Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-containers')
-rw-r--r--recipes-containers/podman-tui/podman-tui_git.bb67
1 files changed, 67 insertions, 0 deletions
diff --git a/recipes-containers/podman-tui/podman-tui_git.bb b/recipes-containers/podman-tui/podman-tui_git.bb
new file mode 100644
index 00000000..bd9b7e27
--- /dev/null
+++ b/recipes-containers/podman-tui/podman-tui_git.bb
@@ -0,0 +1,67 @@
1HOMEPAGE = "https://github.com/containers/podman-tui"
2SUMMARY = "podman-tui is a Terminal User Interface to interact with podman"
3DESCRIPTION = "podman-tui is a Terminal User Interface to interact with the podman v4. \
4podman bindings has been used to communicate with podman environment through rest api API (unix socket). \
5 "
6
7inherit features_check
8REQUIRED_DISTRO_FEATURES ?= "seccomp ipv6"
9
10DEPENDS = " \
11 libseccomp \
12 libdevmapper \
13 lvm2 \
14 btrfs-tools \
15 gpgme \
16 libassuan \
17 libgpg-error \
18"
19
20SRCREV = "ff962bb92d7f5fea9f819c4ef8a484bdceb3747b"
21SRC_URI = " \
22 git://github.com/containers/podman-tui;protocol=https;branch=main \
23"
24
25LICENSE = "Apache-2.0"
26LIC_FILES_CHKSUM = "file://src/import/LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
27
28GO_IMPORT = "import"
29
30S = "${WORKDIR}/git"
31
32PV = "v0.3.0+git${SRCPV}"
33
34PODMAN_PKG = "github.com/containers/podman-tui"
35
36inherit go goarch
37inherit pkgconfig
38
39do_configure[noexec] = "1"
40
41BUILD_TAGS ?= "exclude_graphdriver_btrfs exclude_graphdriver_devicemapper"
42
43do_compile() {
44 cd ${S}/src
45
46 rm -rf .gopath
47 mkdir -p .gopath/src/"$(dirname "${PODMAN_PKG}")"
48 ln -sf ../../../../import/ .gopath/src/"${PODMAN_PKG}"
49
50 cd ${S}/src/.gopath/src/"${PODMAN_PKG}"
51
52 # Pass the needed cflags/ldflags so that cgo
53 # can find the needed headers files and libraries
54 export GOFLAGS="-mod=vendor"
55
56 # oe_runmake BUILDTAGS="${BUILDTAGS}"
57 ${GO} build -tags "$(BUILDTAGS)" ${GO_LDFLAGS} -o bin/podman-tui
58}
59
60do_install() {
61 cd ${S}/src/.gopath/src/"${PODMAN_PKG}"
62
63 install -d ${D}/${bindir}
64 install bin/podman-tui ${D}/${bindir}/
65}
66
67RDEPENDS:${PN} += "podman"