summaryrefslogtreecommitdiffstats
path: root/recipes-containers
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2017-02-17 13:26:04 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-02-17 13:26:09 -0500
commit6d05401c38eb7ccc35e2f46848e40af57b57fd8e (patch)
tree8e98990c0f00db9abfe9c01368633fc908c2409f /recipes-containers
parent9f8e6b8550c215b99e689c8717098d4d7327594f (diff)
downloadmeta-virtualization-6d05401c38eb7ccc35e2f46848e40af57b57fd8e.tar.gz
docker: use .service file from contrib
Oru existing docker.service file is using an out of date command. We can use the contrib .service file instead .. and hopefully it will stay up to date. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-containers')
-rw-r--r--recipes-containers/docker/docker_git.bb3
1 files changed, 1 insertions, 2 deletions
diff --git a/recipes-containers/docker/docker_git.bb b/recipes-containers/docker/docker_git.bb
index 009fe9fe..46ad26e9 100644
--- a/recipes-containers/docker/docker_git.bb
+++ b/recipes-containers/docker/docker_git.bb
@@ -21,7 +21,6 @@ DESCRIPTION = "Linux container runtime \
21SRCREV = "49bf474f9ed7ce7143a59d1964ff7b7fd9b52178" 21SRCREV = "49bf474f9ed7ce7143a59d1964ff7b7fd9b52178"
22SRC_URI = "\ 22SRC_URI = "\
23 git://github.com/docker/docker.git;nobranch=1 \ 23 git://github.com/docker/docker.git;nobranch=1 \
24 file://docker.service \
25 file://docker.init \ 24 file://docker.init \
26 file://hi.Dockerfile \ 25 file://hi.Dockerfile \
27 file://context-use-golang.org-x-net-pkg-until-we-move-to-go.patch \ 26 file://context-use-golang.org-x-net-pkg-until-we-move-to-go.patch \
@@ -140,7 +139,7 @@ do_install() {
140 install -d ${D}${systemd_unitdir}/system 139 install -d ${D}${systemd_unitdir}/system
141 install -m 644 ${S}/contrib/init/systemd/docker.* ${D}/${systemd_unitdir}/system 140 install -m 644 ${S}/contrib/init/systemd/docker.* ${D}/${systemd_unitdir}/system
142 # replaces one copied from above with one that uses the local registry for a mirror 141 # replaces one copied from above with one that uses the local registry for a mirror
143 install -m 644 ${WORKDIR}/docker.service ${D}/${systemd_unitdir}/system 142 install -m 644 ${S}/contrib/init/systemd/docker.service ${D}/${systemd_unitdir}/system
144 else 143 else
145 install -d ${D}${sysconfdir}/init.d 144 install -d ${D}${sysconfdir}/init.d
146 install -m 0755 ${WORKDIR}/docker.init ${D}${sysconfdir}/init.d/docker.init 145 install -m 0755 ${WORKDIR}/docker.init ${D}${sysconfdir}/init.d/docker.init