summaryrefslogtreecommitdiffstats
path: root/recipes-containers
diff options
context:
space:
mode:
authorJose Quaresma <quaresma.jose@gmail.com>2022-09-20 11:46:09 +0000
committerBruce Ashfield <bruce.ashfield@gmail.com>2022-09-20 08:42:10 -0400
commit2d0f7255a75d24ec3e3b686d70e97d20dc39c259 (patch)
treeb436ab95e684f6f826cce151ec5e75890edd9876 /recipes-containers
parent758da82203289e1d0f607b7e4c5e48e35e66d4ed (diff)
downloadmeta-virtualization-2d0f7255a75d24ec3e3b686d70e97d20dc39c259.tar.gz
docker/proxy: don't use -linkshared unconditionally
The linkshared is not supported in some machines like riscv64 and when supported we can use the GO_LINKSHARED instaed. So export GO_LINKSHARED on the recipe to be available for Makefile. This is currently only used in libnetwork for the proxy build, but could be used in additional locations in the future. Signed-off-by: Jose Quaresma <jose.quaresma@foundries.io> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-containers')
-rw-r--r--recipes-containers/docker/docker.inc3
-rw-r--r--recipes-containers/docker/files/0001-libnetwork-use-GO-instead-of-go.patch4
2 files changed, 5 insertions, 2 deletions
diff --git a/recipes-containers/docker/docker.inc b/recipes-containers/docker/docker.inc
index b0bee4f0..9708eaf7 100644
--- a/recipes-containers/docker/docker.inc
+++ b/recipes-containers/docker/docker.inc
@@ -58,6 +58,9 @@ inherit pkgconfig
58 58
59do_configure[noexec] = "1" 59do_configure[noexec] = "1"
60 60
61# Export for possible use in Makefiles, default value comes from go.bbclass
62export GO_LINKSHARED
63
61DOCKER_PKG="github.com/docker/docker" 64DOCKER_PKG="github.com/docker/docker"
62# in order to exclude devicemapper and btrfs - https://github.com/docker/docker/issues/14056 65# in order to exclude devicemapper and btrfs - https://github.com/docker/docker/issues/14056
63BUILD_TAGS ?= "exclude_graphdriver_btrfs exclude_graphdriver_devicemapper" 66BUILD_TAGS ?= "exclude_graphdriver_btrfs exclude_graphdriver_devicemapper"
diff --git a/recipes-containers/docker/files/0001-libnetwork-use-GO-instead-of-go.patch b/recipes-containers/docker/files/0001-libnetwork-use-GO-instead-of-go.patch
index d4f84e30..b9b41de5 100644
--- a/recipes-containers/docker/files/0001-libnetwork-use-GO-instead-of-go.patch
+++ b/recipes-containers/docker/files/0001-libnetwork-use-GO-instead-of-go.patch
@@ -34,8 +34,8 @@ Index: git/libnetwork/Makefile
34 @echo "🐳 $@" 34 @echo "🐳 $@"
35- go build -o "bin/dnet-$$GOOS-$$GOARCH" ./cmd/dnet 35- go build -o "bin/dnet-$$GOOS-$$GOARCH" ./cmd/dnet
36- go build -o "bin/docker-proxy-$$GOOS-$$GOARCH" ./cmd/proxy 36- go build -o "bin/docker-proxy-$$GOOS-$$GOARCH" ./cmd/proxy
37+ @$(GO) build -trimpath -linkshared $(GOBUILDFLAGS) -o "bin/docker-proxy-$$GOOS-$$GOARCH" ./cmd/proxy 37+ @$(GO) build -trimpath $(GO_LINKSHARED) $(GOBUILDFLAGS) -o "bin/docker-proxy-$$GOOS-$$GOARCH" ./cmd/proxy
38+ @$(GO) build -trimpath -linkshared $(GOBUILDFLAGS) -o "bin/dnet-$$GOOS-$$GOARCH" ./cmd/dnet 38+ @$(GO) build -trimpath $(GO_LINKSHARED) $(GOBUILDFLAGS) -o "bin/dnet-$$GOOS-$$GOARCH" ./cmd/dnet
39 39
40 # Rebuild protocol buffers. 40 # Rebuild protocol buffers.
41 # These may need to be rebuilt after vendoring updates, so .proto files are declared .PHONY so they are always rebuilt. 41 # These may need to be rebuilt after vendoring updates, so .proto files are declared .PHONY so they are always rebuilt.