summaryrefslogtreecommitdiffstats
path: root/recipes-containers
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2021-10-18 13:27:28 -0400
committerBruce Ashfield <bruce.ashfield@gmail.com>2021-10-18 13:32:43 -0400
commit21fc48f10ec2031cf0b6610531258c51434e1bb5 (patch)
treef20b982d3ff46f4bcef80cc5ada6501d8a78bd0f /recipes-containers
parentb2299d39000252829f0e99006efcfcf0a3ebb3dc (diff)
downloadmeta-virtualization-21fc48f10ec2031cf0b6610531258c51434e1bb5.tar.gz
crun: fix offline builds
The 'autogen.sh' script of crun was fetching dependencies that we already have in our SRC_URI. We want the OE git fetcher to manage the source, not scripts in the source of a package. We grab the two lines out of autogen.sh that we need, and use them directly in the configure_prepend. We also add yajl to the source code dependencies as the package DEPENDS is not enough as crun is explicitly building source that looks for the yajl code. Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-containers')
-rw-r--r--recipes-containers/crun/crun_git.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/recipes-containers/crun/crun_git.bb b/recipes-containers/crun/crun_git.bb
index dbc5c023..70004dad 100644
--- a/recipes-containers/crun/crun_git.bb
+++ b/recipes-containers/crun/crun_git.bb
@@ -7,12 +7,14 @@ SRCREV_crun = "360f5d02c37d5f7a67d38622010228ae2eeb80f1"
7SRCREV_libocispec = "c9b8b9524814550a489aa6d38b2dec95633ffa15" 7SRCREV_libocispec = "c9b8b9524814550a489aa6d38b2dec95633ffa15"
8SRCREV_ispec = "79b036d80240ae530a8de15e1d21c7ab9292c693" 8SRCREV_ispec = "79b036d80240ae530a8de15e1d21c7ab9292c693"
9SRCREV_rspec = "7413a7f753e1bd9a6a9c6dc7f96f55888cbbd476" 9SRCREV_rspec = "7413a7f753e1bd9a6a9c6dc7f96f55888cbbd476"
10SRCREV_yajl = "f344d21280c3e4094919fd318bc5ce75da91fc06"
10 11
11SRCREV_FORMAT = "crun_rspec" 12SRCREV_FORMAT = "crun_rspec"
12SRC_URI = "git://github.com/containers/crun.git;branch=main;name=crun \ 13SRC_URI = "git://github.com/containers/crun.git;branch=main;name=crun \
13 git://github.com/containers/libocispec.git;branch=main;name=libocispec;destsuffix=git/libocispec \ 14 git://github.com/containers/libocispec.git;branch=main;name=libocispec;destsuffix=git/libocispec \
14 git://github.com/opencontainers/runtime-spec.git;branch=master;name=rspec;destsuffix=git/libocispec/runtime-spec \ 15 git://github.com/opencontainers/runtime-spec.git;branch=master;name=rspec;destsuffix=git/libocispec/runtime-spec \
15 git://github.com/opencontainers/image-spec.git;branch=main;name=ispec;destsuffix=git/libocispec/image-spec \ 16 git://github.com/opencontainers/image-spec.git;branch=main;name=ispec;destsuffix=git/libocispec/image-spec \
17 git://github.com/containers/yajl.git;branch=main;name=yajl;destsuffix=git/libocispec/yajl \
16 " 18 "
17 19
18PV = "0.18+git${SRCREV_crun}" 20PV = "0.18+git${SRCREV_crun}"
@@ -34,7 +36,10 @@ DEPENDS += "systemd"
34DEPENDS += "oci-image-spec oci-runtime-spec" 36DEPENDS += "oci-image-spec oci-runtime-spec"
35 37
36do_configure:prepend () { 38do_configure:prepend () {
37 ./autogen.sh 39 # extracted from autogen.sh in crun source. This avoids
40 # git submodule fetching.
41 mkdir -p m4
42 autoreconf -fi
38} 43}
39 44
40do_install() { 45do_install() {