summaryrefslogtreecommitdiffstats
path: root/recipes-containers
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2023-02-10 14:00:08 -0500
committerBruce Ashfield <bruce.ashfield@gmail.com>2023-02-17 15:21:29 -0500
commit20fde9bbee686e17d8d5c14589cae6cadd8c9128 (patch)
treea8951c04c04780caf8ceade9dcf633ee5273e2b2 /recipes-containers
parent13ad8548dea1c9edf5d3281c7bcc83d11582d5c9 (diff)
downloadmeta-virtualization-20fde9bbee686e17d8d5c14589cae6cadd8c9128.tar.gz
skopeo: update to 1.11.0
We drop a patch that is now part of the release. Bumping skopeo to version v1.11.0-39-g95680f3c, which comprises the following commits: 643a2359 Update c/image after https://github.com/containers/image/pull/1816 2c6e15b5 Run codespell on codebase df708d16 [CI:DOCS] Disable dependabot 2acac8a6 Update module golang.org/x/term to v0.5.0 f9e2c676 Update golang.org/x/exp digest to 46f607a 47c7902e Remove unnecessary blank lines c1a57ca1 Pre-allocate an array 2a7b1327 Simplify a condition e7ab33e6 Rename a variable to avoid an underscore e90c381a Add missing comment punctuation 70c06b4a Fix, or remove, comments using lint syntax 9137ac56 Simplify an increment efc6e837 Reformat import statements a8b9e4e3 Use %w when wrapping errors 99215e40 Remove a duplicate word afa031e8 Use net/netip.Addr instead of net.IP 891ba3d4 s/interface{}/any/g f2b3a9c0 Use golang.org/x/exp f1a6d427 Use strings.Cut 22955d05 go mod tidy -go=1.18 007f01c6 [CI:BUILD] enable debuginfo for el8 copr builds 036bf598 [CI:BUILD] copr: fix el8 build and enable debuginfo f9406bb0 Cirrus: Use human-readable CI VM Images b41b85ab Update module gopkg.in/yaml.v2 to v3 d2fbec35 Add unit tests for tlsVerifyConfig's yaml.Unmarshaler 9e24a195 [CI:DOCS] Fix up language in README cc958d3e Move to v1.11.1-dev 9d036f30 Bump to v1.11.0 83bcd136 [CI:DOCS] Format manual page documents afbdaf8e Update module github.com/containers/common to v0.51.0 c9114248 Update module github.com/containers/image/v5 to v5.24.0 0fad1193 Add (skopeo generate-sigstore-key) 48b9d94c Update c/image after https://github.com/containers/image/pull/1810 80e3fd10 Touch up conscious language issues 9f04dfde Partially fix removal of temporary data in (make test-system) 36c480f6 Don't affect $XDG_RUNTIME_DIR of Podman starting the registry 850bc49d Update module github.com/containers/storage to v1.45.3 a98c1372 Fix storage.conf setup in test-system 19815502 Fix (test-integration), in a container without CI 67a8bef6 Cirrus: Fix c/image CI testing 63da8390 Bump github.com/containers/ocicrypt from 1.1.6 to 1.1.7 1fac61ef Cirrus: Add a common intra-test reset function 292962d3 Fix unnecessary use of podman in CI test e239f32a Cirrus: Update to F37 CI VM Images ee804858 Cirrus: Remove redundant package install attempt 0698e82b fix(deps): update module github.com/containers/storage to v1.45.1 bb1ac893 Add support for Fulcio and Rekor, and --sign-by-sigstore=param-file 03b5bdec Update c/image after https://github.com/containers/image/pull/1787 1133a2a3 fix(deps): update module github.com/containers/storage to v1.45.0 d0cf39d8 Cirrus: Skip OSX CI on release-branches f17eafe8 Correctly use the stdout parameter in some places 58bccf38 fix(deps): update module golang.org/x/term to v0.4.0 Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-containers')
-rw-r--r--recipes-containers/skopeo/files/0002-fix_workaround_field_rename_in_btrfs-progs_6_1.patch38
-rw-r--r--recipes-containers/skopeo/skopeo_git.bb5
2 files changed, 2 insertions, 41 deletions
diff --git a/recipes-containers/skopeo/files/0002-fix_workaround_field_rename_in_btrfs-progs_6_1.patch b/recipes-containers/skopeo/files/0002-fix_workaround_field_rename_in_btrfs-progs_6_1.patch
deleted file mode 100644
index cd3c70f4..00000000
--- a/recipes-containers/skopeo/files/0002-fix_workaround_field_rename_in_btrfs-progs_6_1.patch
+++ /dev/null
@@ -1,38 +0,0 @@
1From 246ba3062e8b551026aef2708eee747014ce5c52 Mon Sep 17 00:00:00 2001
2From: Rui Chen <rui@chenrui.dev>
3Date: Wed, 28 Dec 2022 18:26:39 -0500
4Subject: [PATCH] fix: workaround field rename in btrfs-progs 6.1
5
6same as kdave/btrfs-progs@0345143
7
8Signed-off-by: Rui Chen <rui@chenrui.dev>
9
10Upstream-Status: Backport [https://github.com/containers/storage/commit/246ba3062e8b551026aef2708eee747014ce5c52]
11Signed-off-by: Jose Quaresma <jose.quaresma@foundries.io>
12---
13 drivers/btrfs/btrfs.go | 5 ++++-
14 1 file changed, 4 insertions(+), 1 deletion(-)
15
16diff --git a/drivers/btrfs/btrfs.go b/drivers/btrfs/btrfs.go
17index e8b16b858e..3d9053297b 100644
18--- a/drivers/btrfs/btrfs.go
19+++ b/drivers/btrfs/btrfs.go
20@@ -6,6 +6,9 @@ package btrfs
21 /*
22 #include <stdlib.h>
23 #include <dirent.h>
24+
25+// keep struct field name compatible with btrfs-progs < 6.1.
26+#define max_referenced max_rfer
27 #include <btrfs/ioctl.h>
28 #include <btrfs/ctree.h>
29
30@@ -382,7 +385,7 @@ func subvolLimitQgroup(path string, size uint64) error {
31 defer closeDir(dir)
32
33 var args C.struct_btrfs_ioctl_qgroup_limit_args
34- args.lim.max_referenced = C.__u64(size)
35+ args.lim.max_rfer = C.__u64(size)
36 args.lim.flags = C.BTRFS_QGROUP_LIMIT_MAX_RFER
37 _, _, errno := unix.Syscall(unix.SYS_IOCTL, getDirFd(dir), C.BTRFS_IOC_QGROUP_LIMIT,
38 uintptr(unsafe.Pointer(&args)))
diff --git a/recipes-containers/skopeo/skopeo_git.bb b/recipes-containers/skopeo/skopeo_git.bb
index 1dfce24b..a719671c 100644
--- a/recipes-containers/skopeo/skopeo_git.bb
+++ b/recipes-containers/skopeo/skopeo_git.bb
@@ -24,11 +24,10 @@ SRC_URI = " \
24 file://storage.conf \ 24 file://storage.conf \
25 file://registries.conf \ 25 file://registries.conf \
26 file://0001-makefile-add-GOBUILDFLAGS-to-go-build-call.patch \ 26 file://0001-makefile-add-GOBUILDFLAGS-to-go-build-call.patch \
27 file://0002-fix_workaround_field_rename_in_btrfs-progs_6_1.patch;patchdir=src/import/vendor/github.com/containers/storage \
28" 27"
29 28
30SRCREV = "4517ea0b7be6a6743d854e05cd24f7354a487b60" 29SRCREV = "95680f3c07931ee748afbf240059a62eac6e6bed"
31PV = "v1.10.0+git${SRCPV}" 30PV = "v1.11.0+git${SRCPV}"
32GO_IMPORT = "import" 31GO_IMPORT = "import"
33 32
34S = "${WORKDIR}/git" 33S = "${WORKDIR}/git"