summaryrefslogtreecommitdiffstats
path: root/recipes-containers
diff options
context:
space:
mode:
authorStefan Lengfeld <s.lengfeld@phytec.de>2016-11-03 11:01:22 +0100
committerBruce Ashfield <bruce.ashfield@windriver.com>2016-11-03 15:42:08 -0400
commit011c4d611b3ce4e4922207ea0f58fd475eab83fb (patch)
tree3a9d5f462940317d09f644014177e86b9de40c05 /recipes-containers
parentada27ac45fb6e6872de078d4a55185f31719e44b (diff)
downloadmeta-virtualization-011c4d611b3ce4e4922207ea0f58fd475eab83fb.tar.gz
docker: install script config-check.sh
The script /usr/share/docker/config-check.sh is very useful to test all kernel requirements for docker. A lot of embedded boards will use a custom kernel config that does not have all kernel features enabled by default. Install the script so kernel developer can easily enable the missing features. Signed-off-by: Stefan Lengfeld <s.lengfeld@phytec.de> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-containers')
-rw-r--r--recipes-containers/docker/docker_git.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/recipes-containers/docker/docker_git.bb b/recipes-containers/docker/docker_git.bb
index 4be5e470..2cff6f15 100644
--- a/recipes-containers/docker/docker_git.bb
+++ b/recipes-containers/docker/docker_git.bb
@@ -52,6 +52,8 @@ DEPENDS = "go-cross \
52 go-distribution-digest \ 52 go-distribution-digest \
53 " 53 "
54 54
55PACKAGES =+ "${PN}-contrib"
56
55DEPENDS_append_class-target = "lvm2" 57DEPENDS_append_class-target = "lvm2"
56RDEPENDS_${PN} = "curl aufs-util git util-linux iptables \ 58RDEPENDS_${PN} = "curl aufs-util git util-linux iptables \
57 ${@bb.utils.contains('DISTRO_FEATURES','systemd','','cgroup-lite',d)} \ 59 ${@bb.utils.contains('DISTRO_FEATURES','systemd','','cgroup-lite',d)} \
@@ -126,6 +128,7 @@ do_install() {
126 128
127 mkdir -p ${D}/usr/share/docker/ 129 mkdir -p ${D}/usr/share/docker/
128 cp ${WORKDIR}/hi.Dockerfile ${D}/usr/share/docker/ 130 cp ${WORKDIR}/hi.Dockerfile ${D}/usr/share/docker/
131 install -m 0755 ${S}/contrib/check-config.sh ${D}/usr/share/docker/
129} 132}
130 133
131inherit useradd 134inherit useradd
@@ -134,5 +137,8 @@ GROUPADD_PARAM_${PN} = "-r docker"
134 137
135FILES_${PN} += "/lib/systemd/system/*" 138FILES_${PN} += "/lib/systemd/system/*"
136 139
140FILES_${PN}-contrib += "/usr/share/docker/check-config.sh"
141RDEPENDS_${PN}-contrib += "bash"
142
137# DO NOT STRIP docker 143# DO NOT STRIP docker
138INHIBIT_PACKAGE_STRIP = "1" 144INHIBIT_PACKAGE_STRIP = "1"