summaryrefslogtreecommitdiffstats
path: root/recipes-containers/tini/tini_0.19.0.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2021-02-06 14:00:31 -0500
committerBruce Ashfield <bruce.ashfield@gmail.com>2021-02-06 14:00:31 -0500
commitcf80825a85f23af3df325cca534b5ee3e21e8f47 (patch)
tree6a07c398c5497e9fbdde76736ec88d42695d72c4 /recipes-containers/tini/tini_0.19.0.bb
parentc3fe6ab4276444d0ac0c1de23a935d77fc2f4404 (diff)
downloadmeta-virtualization-cf80825a85f23af3df325cca534b5ee3e21e8f47.tar.gz
tini: update to 0.19.0
Bumping the tini release. We pickup the following changes with this update: b9f42a0 Indicate that -e can be repeated 71911f9 add installation instructos for Arch Linux 9d647c3 credit to nfnty for packaging tini for Arch Linux 4df9bb0 add `chmod +x` step to signed download docs 7fdac39 Adding example of how to verify checksums 07b3139 add Debian installation instructions 0374cb6 add aliases x86_64 for uname -m de40ad0 Update Travis release token 81d9b14 Release 0.19.0 9587d90 run_build: publish sha256 checksums to releases 3f3e765 Add ppc64le alias for the ppc64el build 0e55606 .travis.yml: Remove redundant argument 12197f9 Update tests to Python 3 6cfeff2 add support for mips64el 76d4aa0 tini.c: fix child subreaper error message cefad7b gpg: explicitly pass file name 6ece2eb update readme to fix instructions for gpg Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-containers/tini/tini_0.19.0.bb')
-rw-r--r--recipes-containers/tini/tini_0.19.0.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes-containers/tini/tini_0.19.0.bb b/recipes-containers/tini/tini_0.19.0.bb
new file mode 100644
index 00000000..62e285df
--- /dev/null
+++ b/recipes-containers/tini/tini_0.19.0.bb
@@ -0,0 +1,32 @@
1HOMEPAGE = "http://github.com/krallin/tini"
2SUMMARY = "Minimal init for containers"
3DESCRIPTION = "Tini is the simplest init you could think of. All Tini does is \
4spawn a single child (Tini is meant to be run in a container), and wait for \
5it to exit all the while reaping zombies and performing signal forwarding. "
6
7SRCREV = "b9f42a0e7bb46efea0c9e3d8610c96ab53b467f8"
8SRC_URI = " \
9 git://github.com/krallin/tini.git \
10 file://0001-Do-not-strip-the-output-binary-allow-yocto-to-do-thi.patch \
11 "
12
13LICENSE = "MIT"
14LIC_FILES_CHKSUM = "file://LICENSE;md5=ffc9091894702bc5dcf4cc0085561ef5"
15
16S = "${WORKDIR}/git"
17
18BBCLASSEXTEND = "native"
19
20# tini links with -static, so no PIE for us
21SECURITY_CFLAGS_pn-${PN} = "${SECURITY_NO_PIE_CFLAGS}"
22
23inherit cmake
24
25do_install() {
26 mkdir -p ${D}/${bindir}
27 install -m 0755 ${B}/tini-static ${D}/${bindir}/docker-init
28}
29
30# Tini is the currently the provider for docker-init
31PROVIDES += "docker-init"
32RPROVIDES_${PN} = "docker-init"