summaryrefslogtreecommitdiffstats
path: root/recipes-containers/skopeo/skopeo_git.bb
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2022-06-12 01:00:04 -0700
committerBruce Ashfield <bruce.ashfield@gmail.com>2022-06-20 12:09:46 -0400
commitce03a8868f90aca0d31dff3f17f49ef13ce923b9 (patch)
tree2f0456d92bac998ea0d3cfc7196ff27b0f04bad0 /recipes-containers/skopeo/skopeo_git.bb
parent8f15a73bcfa7a104ba2965bbdecd7a546fa45aa5 (diff)
downloadmeta-virtualization-ce03a8868f90aca0d31dff3f17f49ef13ce923b9.tar.gz
skopeo: clean up depends and fix CGO settings
According to https://github.com/containers/skopeo/blob/main/install.md#building-from-source, the ostree dependency is not needed. Also, adjust the CGO_CFLAGS and CGO_LDFALGS to use target flags instead of the SDK ones. Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-containers/skopeo/skopeo_git.bb')
-rw-r--r--recipes-containers/skopeo/skopeo_git.bb5
1 files changed, 2 insertions, 3 deletions
diff --git a/recipes-containers/skopeo/skopeo_git.bb b/recipes-containers/skopeo/skopeo_git.bb
index f3217dbf..35377a8d 100644
--- a/recipes-containers/skopeo/skopeo_git.bb
+++ b/recipes-containers/skopeo/skopeo_git.bb
@@ -9,7 +9,6 @@ DEPENDS = " \
9 lvm2 \ 9 lvm2 \
10 btrfs-tools \ 10 btrfs-tools \
11 glib-2.0 \ 11 glib-2.0 \
12 ostree \
13" 12"
14 13
15inherit go 14inherit go
@@ -61,8 +60,8 @@ do_compile() {
61 export CGO_ENABLED="1" 60 export CGO_ENABLED="1"
62 export CFLAGS="" 61 export CFLAGS=""
63 export LDFLAGS="" 62 export LDFLAGS=""
64 export CGO_CFLAGS="${BUILDSDK_CFLAGS} --sysroot=${STAGING_DIR_TARGET}" 63 export CGO_CFLAGS="${TARGET_CFLAGS}"
65 export CGO_LDFLAGS="${BUILDSDK_LDFLAGS} --sysroot=${STAGING_DIR_TARGET}" 64 export CGO_LDFLAGS="${TARGET_LDFLAGS}"
66 cd ${S}/src/import 65 cd ${S}/src/import
67 66
68 export GO111MODULE=off 67 export GO111MODULE=off