diff options
author | Bruce Ashfield <bruce.ashfield@gmail.com> | 2023-07-07 21:01:01 +0000 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@gmail.com> | 2023-07-25 14:54:20 -0400 |
commit | 5dda7078ba8582ae4bb38699787f4e8c61f0b9ab (patch) | |
tree | 50311eb1e06ab69a776aa99cc270cfc0c4753681 /recipes-containers/runc | |
parent | 248be027d61195fc24eced3d474e1ad6a6e730f0 (diff) | |
download | meta-virtualization-5dda7078ba8582ae4bb38699787f4e8c61f0b9ab.tar.gz |
runc-opencontainers: update to 1.1.7-tip
Bumping runc to version v1.1.7-37-gca73c9fd, which comprises the following commits:
0d93d7d1 release: add riscv64 binary
9164fe17 libct/seccomp: add riscv64
ed47e31a Makefile: set CGO_ENABLED=1 when needed
923ae4da Makefile: add support for static PIE
2abca872 Makefile: fix GO_BUILDMODE setting
120ec5bd Makefile: add LDFLAGS_COMMON and LDFLAGS_STATIC
b9940113 Dockerfile: don't use crossbuild-essential-*
028fc57a Dockerfile: rm dpkg --add-architecture lines
4449ce84 Dockerfile: nit
d375351b ci/cirrus: enable rootless tests on cs9
e1a8b52f tests/int/cgroups: filter out rdma
02e065ef docs/systemd: fix a broken link
9af462e4 Fix tmpfs mode opts when dir already exists
7d1bdc7d .codespellrc: update for 2.2.5
8397943e man/runc: fixes
f9da684d tests/int: increase num retries for oom tests
7fa912ed ci/cirrus: limit numcpu
e9c1ca08 Fix Vagrant caching
e2265a92 ci: bump bats 1.8.2 -> 1.9.0
bbddb6bd Vagrantfile.fedora: bump to 38
27b86b4c ci/cirrus: use vagrant from hashicorp repo
98a1b76c tests/int: fix some checks
1eadcede ci: bump bats 1.3.0 -> 1.8.2
63af8b00 init: do not print environment variable value
404ea7ab libct: fix a race with systemd removal
f0ecf30b VERSION: back to development
860f061b VERSION: release 1.1.7
We refresh one patch for context changes.
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-containers/runc')
-rw-r--r-- | recipes-containers/runc/files/0001-Makefile-respect-GOBUILDFLAGS-for-runc-and-remove-re.patch | 14 | ||||
-rw-r--r-- | recipes-containers/runc/runc-opencontainers_git.bb | 2 |
2 files changed, 8 insertions, 8 deletions
diff --git a/recipes-containers/runc/files/0001-Makefile-respect-GOBUILDFLAGS-for-runc-and-remove-re.patch b/recipes-containers/runc/files/0001-Makefile-respect-GOBUILDFLAGS-for-runc-and-remove-re.patch index bb4af36b..9e5a8313 100644 --- a/recipes-containers/runc/files/0001-Makefile-respect-GOBUILDFLAGS-for-runc-and-remove-re.patch +++ b/recipes-containers/runc/files/0001-Makefile-respect-GOBUILDFLAGS-for-runc-and-remove-re.patch | |||
@@ -17,12 +17,12 @@ Index: git/src/import/Makefile | |||
17 | =================================================================== | 17 | =================================================================== |
18 | --- git.orig/src/import/Makefile | 18 | --- git.orig/src/import/Makefile |
19 | +++ git/src/import/Makefile | 19 | +++ git/src/import/Makefile |
20 | @@ -20,7 +20,7 @@ | 20 | @@ -24,7 +24,7 @@ |
21 | endif | 21 | GO_BUILDMODE := "-buildmode=pie" |
22 | endif | 22 | endif |
23 | endif | 23 | endif |
24 | -GO_BUILD := $(GO) build -trimpath $(GO_BUILDMODE) $(EXTRA_FLAGS) -tags "$(BUILDTAGS)" \ | 24 | -GO_BUILD := $(GO) build -trimpath $(GO_BUILDMODE) \ |
25 | +GO_BUILD := $(GO) build $(GOBUILDFLAGS) -trimpath $(GO_BUILDMODE) $(EXTRA_FLAGS) -tags "$(BUILDTAGS)" \ | 25 | +GO_BUILD := $(GO) build $(GOBUILDFLAGS) -trimpath $(GO_BUILDMODE) \ |
26 | -ldflags "-X main.gitCommit=$(COMMIT) -X main.version=$(VERSION) $(EXTRA_LDFLAGS)" | 26 | $(EXTRA_FLAGS) -tags "$(BUILDTAGS)" \ |
27 | GO_BUILD_STATIC := CGO_ENABLED=1 $(GO) build -trimpath $(EXTRA_FLAGS) -tags "$(BUILDTAGS) netgo osusergo" \ | 27 | -ldflags "$(LDFLAGS_COMMON) $(EXTRA_LDFLAGS)" |
28 | -ldflags "-extldflags -static -X main.gitCommit=$(COMMIT) -X main.version=$(VERSION) $(EXTRA_LDFLAGS)" | 28 | |
diff --git a/recipes-containers/runc/runc-opencontainers_git.bb b/recipes-containers/runc/runc-opencontainers_git.bb index 77c567ef..7757baa0 100644 --- a/recipes-containers/runc/runc-opencontainers_git.bb +++ b/recipes-containers/runc/runc-opencontainers_git.bb | |||
@@ -1,6 +1,6 @@ | |||
1 | include runc.inc | 1 | include runc.inc |
2 | 2 | ||
3 | SRCREV = "b6109acd4d81e8a33dd07d94e6a7f9c706d8356c" | 3 | SRCREV = "ca73c9fd4b684a7ddec8b3bd892b5f76d6f21710" |
4 | SRC_URI = " \ | 4 | SRC_URI = " \ |
5 | git://github.com/opencontainers/runc;branch=release-1.1;protocol=https \ | 5 | git://github.com/opencontainers/runc;branch=release-1.1;protocol=https \ |
6 | file://0001-Makefile-respect-GOBUILDFLAGS-for-runc-and-remove-re.patch \ | 6 | file://0001-Makefile-respect-GOBUILDFLAGS-for-runc-and-remove-re.patch \ |