summaryrefslogtreecommitdiffstats
path: root/recipes-containers/runc/runc-docker_git.bb
diff options
context:
space:
mode:
authorPaul Barker <pbarker@toganlabs.com>2017-10-05 13:38:18 +0000
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-10-05 10:44:04 -0400
commita1085de5319d1ad5a5227c7f1cb44cef2a6bb085 (patch)
treefa90a8f8790ce4f959f8c57e66408c67e8397c3d /recipes-containers/runc/runc-docker_git.bb
parent9a24b3eb635ef745f5ea5b567d900c8659c02097 (diff)
downloadmeta-virtualization-a1085de5319d1ad5a5227c7f1cb44cef2a6bb085.tar.gz
runc: Use correct go cross-compiler
The makefiles for both providers of runc need to be patched in similar ways to ensure that we use the binaries from go-cross and not go-native. Signed-off-by: Paul Barker <pbarker@toganlabs.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-containers/runc/runc-docker_git.bb')
-rw-r--r--recipes-containers/runc/runc-docker_git.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/recipes-containers/runc/runc-docker_git.bb b/recipes-containers/runc/runc-docker_git.bb
index 97353254..01986528 100644
--- a/recipes-containers/runc/runc-docker_git.bb
+++ b/recipes-containers/runc/runc-docker_git.bb
@@ -8,10 +8,13 @@ SRC_URI = "git://github.com/docker/runc.git;nobranch=1;name=runc-docker \
8 file://0002-Remove-Platform-as-no-longer-in-OCI-spec.patch \ 8 file://0002-Remove-Platform-as-no-longer-in-OCI-spec.patch \
9 file://0003-Update-memory-specs-to-use-int64-not-uint64.patch \ 9 file://0003-Update-memory-specs-to-use-int64-not-uint64.patch \
10 file://0001-runc-Add-console-socket-dev-null.patch \ 10 file://0001-runc-Add-console-socket-dev-null.patch \
11 file://0001-Use-correct-go-cross-compiler.patch \
11 " 12 "
12 13
13GO_IMPORT = "import" 14GO_IMPORT = "import"
14 15
16EXTRA_FLAGS = "-v -x -work"
17
15RUNC_VERSION = "1.0.0-rc3" 18RUNC_VERSION = "1.0.0-rc3"
16PROVIDES += "virtual/runc" 19PROVIDES += "virtual/runc"
17RPROVIDES_${PN} = "virtual/runc" 20RPROVIDES_${PN} = "virtual/runc"