summaryrefslogtreecommitdiffstats
path: root/recipes-containers/runc/runc-docker_git.bb
diff options
context:
space:
mode:
authorJason Wessel <jason.wessel@windriver.com>2017-09-13 12:39:46 -0700
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-09-14 09:49:00 -0400
commit01a8d4537012ad93dc8510e9b762acdc8c4536c7 (patch)
tree8b22ba0333f7a8c83193bee31b33a3b307f1164a /recipes-containers/runc/runc-docker_git.bb
parent718592922bd64da4d609c96e831f6aba05e44a8d (diff)
downloadmeta-virtualization-01a8d4537012ad93dc8510e9b762acdc8c4536c7.tar.gz
nets, docker, runc, oci-*tools: go.bbclass compile fixes
Recently in the oe-core the go.bbclass changed and requires the defition of the GO_IMPORT variable. This was intended to simplify how the compilation works with go packages and it is still a work in progress. This patch set makes the recipes compatible to generate the same end result as before using the new go.bbclass from oe-core. Any patches that were included in the recipes had to have the paths adjusted because the new go.bbclass manipulates the notion of S to be S + "src" + "$GO_IMPORT" internally for the purpose of unpack, patch and compile. Signed-off-by: Jason Wessel <jason.wessel@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-containers/runc/runc-docker_git.bb')
-rw-r--r--recipes-containers/runc/runc-docker_git.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/recipes-containers/runc/runc-docker_git.bb b/recipes-containers/runc/runc-docker_git.bb
index f412c84b..97353254 100644
--- a/recipes-containers/runc/runc-docker_git.bb
+++ b/recipes-containers/runc/runc-docker_git.bb
@@ -10,6 +10,8 @@ SRC_URI = "git://github.com/docker/runc.git;nobranch=1;name=runc-docker \
10 file://0001-runc-Add-console-socket-dev-null.patch \ 10 file://0001-runc-Add-console-socket-dev-null.patch \
11 " 11 "
12 12
13GO_IMPORT = "import"
14
13RUNC_VERSION = "1.0.0-rc3" 15RUNC_VERSION = "1.0.0-rc3"
14PROVIDES += "virtual/runc" 16PROVIDES += "virtual/runc"
15RPROVIDES_${PN} = "virtual/runc" 17RPROVIDES_${PN} = "virtual/runc"