summaryrefslogtreecommitdiffstats
path: root/recipes-containers/podman
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2022-07-17 14:34:38 -0400
committerBruce Ashfield <bruce.ashfield@gmail.com>2022-07-17 14:37:43 -0400
commit7ec4b4746d9d76062a868ea77818a150ddd53c54 (patch)
tree3a76fd72f79ace0a41d85b171949262252815026 /recipes-containers/podman
parentfb14913e224ba97786bc9b192a8b6d4a8d1592b9 (diff)
downloadmeta-virtualization-7ec4b4746d9d76062a868ea77818a150ddd53c54.tar.gz
podman; fix patch fuzz/failure
patch a33188f [podman: Fix host contamination] appears to have introduced fuzz/failures. Which strangely wasn't picked up on merge testing. We refresh the patch to fix the issues. Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-containers/podman')
-rw-r--r--recipes-containers/podman/podman/0001-Rename-BUILDFLAGS-to-GOBUILDFLAGS.patch36
1 files changed, 17 insertions, 19 deletions
diff --git a/recipes-containers/podman/podman/0001-Rename-BUILDFLAGS-to-GOBUILDFLAGS.patch b/recipes-containers/podman/podman/0001-Rename-BUILDFLAGS-to-GOBUILDFLAGS.patch
index 13a736e4..e27e1fa8 100644
--- a/recipes-containers/podman/podman/0001-Rename-BUILDFLAGS-to-GOBUILDFLAGS.patch
+++ b/recipes-containers/podman/podman/0001-Rename-BUILDFLAGS-to-GOBUILDFLAGS.patch
@@ -14,11 +14,11 @@ Signed-off-by: Andrei Gherzan <andrei.gherzan@huawei.com>
14 Makefile | 24 ++++++++++++------------ 14 Makefile | 24 ++++++++++++------------
15 1 file changed, 12 insertions(+), 12 deletions(-) 15 1 file changed, 12 insertions(+), 12 deletions(-)
16 16
17diff --git a/Makefile b/Makefile 17Index: import/Makefile
18index cb230d8e9..538b28d41 100644 18===================================================================
19--- a/Makefile 19--- import.orig/Makefile
20+++ b/Makefile 20+++ import/Makefile
21@@ -69,7 +69,7 @@ PRE_COMMIT = $(shell command -v bin/venv/bin/pre-commit ~/.local/bin/pre-commit 21@@ -69,7 +69,7 @@
22 # triggered. 22 # triggered.
23 SOURCES = $(shell find . -path './.*' -prune -o \( \( -name '*.go' -o -name '*.c' \) -a ! -name '*_test.go' \) -print) 23 SOURCES = $(shell find . -path './.*' -prune -o \( \( -name '*.go' -o -name '*.c' \) -a ! -name '*_test.go' \) -print)
24 24
@@ -27,7 +27,7 @@ index cb230d8e9..538b28d41 100644
27 27
28 BUILDTAGS_CROSS ?= containers_image_openpgp exclude_graphdriver_btrfs exclude_graphdriver_devicemapper exclude_graphdriver_overlay 28 BUILDTAGS_CROSS ?= containers_image_openpgp exclude_graphdriver_btrfs exclude_graphdriver_devicemapper exclude_graphdriver_overlay
29 CONTAINER_RUNTIME := $(shell command -v podman 2> /dev/null || echo docker) 29 CONTAINER_RUNTIME := $(shell command -v podman 2> /dev/null || echo docker)
30@@ -264,11 +264,11 @@ gofmt: ## Verify the source code gofmt 30@@ -264,11 +264,11 @@
31 31
32 .PHONY: test/checkseccomp/checkseccomp 32 .PHONY: test/checkseccomp/checkseccomp
33 test/checkseccomp/checkseccomp: .gopathok $(wildcard test/checkseccomp/*.go) 33 test/checkseccomp/checkseccomp: .gopathok $(wildcard test/checkseccomp/*.go)
@@ -41,7 +41,7 @@ index cb230d8e9..538b28d41 100644
41 41
42 .PHONY: volume-plugin-test-image 42 .PHONY: volume-plugin-test-image
43 volume-plugin-test-img: 43 volume-plugin-test-img:
44@@ -276,7 +276,7 @@ volume-plugin-test-img: 44@@ -276,7 +276,7 @@
45 45
46 .PHONY: test/goecho/goecho 46 .PHONY: test/goecho/goecho
47 test/goecho/goecho: .gopathok $(wildcard test/goecho/*.go) 47 test/goecho/goecho: .gopathok $(wildcard test/goecho/*.go)
@@ -50,7 +50,7 @@ index cb230d8e9..538b28d41 100644
50 50
51 test/version/version: .gopathok version/version.go 51 test/version/version: .gopathok version/version.go
52 $(GO) build -o $@ ./test/version/ 52 $(GO) build -o $@ ./test/version/
53@@ -318,7 +318,7 @@ ifeq (,$(findstring systemd,$(BUILDTAGS))) 53@@ -318,7 +318,7 @@
54 distro for journald support." 54 distro for journald support."
55 endif 55 endif
56 $(GOCMD) build \ 56 $(GOCMD) build \
@@ -59,7 +59,7 @@ index cb230d8e9..538b28d41 100644
59 $(GO_LDFLAGS) '$(LDFLAGS_PODMAN)' \ 59 $(GO_LDFLAGS) '$(LDFLAGS_PODMAN)' \
60 -tags "$(BUILDTAGS)" \ 60 -tags "$(BUILDTAGS)" \
61 -o $@ ./cmd/podman 61 -o $@ ./cmd/podman
62@@ -329,14 +329,14 @@ $(SRCBINDIR): 62@@ -329,7 +329,7 @@
63 63
64 $(SRCBINDIR)/podman$(BINSFX): $(SRCBINDIR) .gopathok $(SOURCES) go.mod go.sum 64 $(SRCBINDIR)/podman$(BINSFX): $(SRCBINDIR) .gopathok $(SOURCES) go.mod go.sum
65 $(GOCMD) build \ 65 $(GOCMD) build \
@@ -68,15 +68,16 @@ index cb230d8e9..538b28d41 100644
68 $(GO_LDFLAGS) '$(LDFLAGS_PODMAN)' \ 68 $(GO_LDFLAGS) '$(LDFLAGS_PODMAN)' \
69 -tags "${REMOTETAGS}" \ 69 -tags "${REMOTETAGS}" \
70 -o $@ ./cmd/podman 70 -o $@ ./cmd/podman
71 71@@ -339,7 +339,7 @@
72 $(SRCBINDIR)/podman-remote-static: $(SRCBINDIR) .gopathok $(SOURCES) go.mod go.sum 72 GOOS=$(GOOS) \
73 $(GOCMD) build \ 73 GOARCH=$(GOARCH) \
74 $(GO) build \
74- $(BUILDFLAGS) \ 75- $(BUILDFLAGS) \
75+ $(GOBUILDFLAGS) \ 76+ $(GOBUILDFLAGS) \
76 $(GO_LDFLAGS) '$(LDFLAGS_PODMAN_STATIC)' \ 77 $(GO_LDFLAGS) '$(LDFLAGS_PODMAN_STATIC)' \
77 -tags "${REMOTETAGS}" \ 78 -tags "${REMOTETAGS}" \
78 -o $@ ./cmd/podman 79 -o $@ ./cmd/podman
79@@ -371,7 +371,7 @@ podman-winpath: .gopathok $(SOURCES) go.mod go.sum 80@@ -374,7 +374,7 @@
80 CGO_ENABLED=0 \ 81 CGO_ENABLED=0 \
81 GOOS=windows \ 82 GOOS=windows \
82 $(GO) build \ 83 $(GO) build \
@@ -85,7 +86,7 @@ index cb230d8e9..538b28d41 100644
85 -ldflags -H=windowsgui \ 86 -ldflags -H=windowsgui \
86 -o bin/windows/winpath.exe \ 87 -o bin/windows/winpath.exe \
87 ./cmd/winpath 88 ./cmd/winpath
88@@ -390,14 +390,14 @@ podman-mac-helper: ## Build podman-mac-helper for macOS 89@@ -393,14 +393,14 @@
89 GOOS=darwin \ 90 GOOS=darwin \
90 GOARCH=$(GOARCH) \ 91 GOARCH=$(GOARCH) \
91 $(GO) build \ 92 $(GO) build \
@@ -102,7 +103,7 @@ index cb230d8e9..538b28d41 100644
102 -o $@ ./cmd/rootlessport 103 -o $@ ./cmd/rootlessport
103 104
104 .PHONY: rootlessport 105 .PHONY: rootlessport
105@@ -420,7 +420,7 @@ bin/podman.cross.%: .gopathok 106@@ -423,7 +423,7 @@
106 GOARCH="$${TARGET##*.}"; \ 107 GOARCH="$${TARGET##*.}"; \
107 CGO_ENABLED=0 \ 108 CGO_ENABLED=0 \
108 $(GO) build \ 109 $(GO) build \
@@ -111,7 +112,7 @@ index cb230d8e9..538b28d41 100644
111 $(GO_LDFLAGS) '$(LDFLAGS_PODMAN)' \ 112 $(GO_LDFLAGS) '$(LDFLAGS_PODMAN)' \
112 -tags '$(BUILDTAGS_CROSS)' \ 113 -tags '$(BUILDTAGS_CROSS)' \
113 -o "$@" ./cmd/podman 114 -o "$@" ./cmd/podman
114@@ -864,7 +864,7 @@ install.tools: .install.goimports .install.gitvalidation .install.md2man .instal 115@@ -871,7 +871,7 @@
115 .PHONY: .install.ginkgo 116 .PHONY: .install.ginkgo
116 .install.ginkgo: .gopathok 117 .install.ginkgo: .gopathok
117 if [ ! -x "$(GOBIN)/ginkgo" ]; then \ 118 if [ ! -x "$(GOBIN)/ginkgo" ]; then \
@@ -120,6 +121,3 @@ index cb230d8e9..538b28d41 100644
120 fi 121 fi
121 122
122 .PHONY: .install.gitvalidation 123 .PHONY: .install.gitvalidation
123--
1242.25.1
125