summaryrefslogtreecommitdiffstats
path: root/recipes-containers/podman-tui
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2023-04-05 16:23:31 -0400
committerBruce Ashfield <bruce.ashfield@gmail.com>2023-04-05 22:59:52 -0400
commit486c9bdb00fd7137c56b98b4a4dd160cc2273e32 (patch)
tree0500f7c0b8a3a9957e4454fbe9e0dc4275b08027 /recipes-containers/podman-tui
parent6912464b107c34c7e9eb68793a4e4799c9d25234 (diff)
downloadmeta-virtualization-486c9bdb00fd7137c56b98b4a4dd160cc2273e32.tar.gz
podman-tui: update to v0.9.0
We drop our btrfs patch, as it is now part of the upstream. Bumping podman-tui to version v0.9.0-37-g24bdb2a, which comprises the following commits: 449d8f4 golangci-lint system package b0d20b2 Bump actions/stale from 7 to 8 613d18f ui/styles - applying golint 7839523 ui/infobar - applying golint 745a331 ui/help - applying golint 4c27c3d ui/volumes code improvement and golint 02740c1 adding container attach command to container page/view 6b5beb4 fix container create error without health options 705bc34 Bump actions/setup-go from 3 to 4 cf4509e Add container health options to the container create dialog d79883e Add packit configurtion to build RPM as part of PR tests ba02fb5 Update unit tests and github workflow for running the tests 4e3889f fix container create error when volume is selected 0af3e47 update github workflow golang version to 1.18.8 f572f48 Golangci-lint update to v1.51.1 c2932fc fix vendor + codepsell 1e35d9a Bump golang.org/x/crypto from 0.6.0 to 0.7.0 bb17bbc unit tests fix 1328668 Bump to v0.10.0-dev 8ad97a1 Bump to v0.9.0 28f800c Bump github.com/onsi/ginkgo/v2 from 2.8.4 to 2.9.0 f18b55b Bump to podman v4.2.2 064a53b Bump github.com/onsi/gomega from 1.27.1 to 1.27.2 c3c1cb3 Bump github.com/containers/common 28ca42e Bump github.com/containers/podman/v4 from 4.4.0-rc1 to 4.4.2 88e898f Bump github.com/onsi/ginkgo/v2 from 2.8.3 to 2.8.4 df84886 Bump github.com/containers/storage from 1.45.3 to 1.45.4 370a785 New feature - container healthcheck 3d18e6a Bump to v0.9.0-dev 073a500 Bump to v0.8.0 fe2fafb Bump github.com/onsi/gomega from 1.24.1 to 1.27.1 4a78fc7 Bump github.com/onsi/ginkgo/v2 from 2.6.0 to 2.8.3 6d03623 Bump podman/v4 to 4.4.2 fa3ea79 Bump github.com/gdamore/tcell/v2 a6d175a Bump golang.org/x/net from 0.6.0 to 0.7.0 0d6726c Bump github.com/containerd/containerd from 1.6.12 to 1.6.18 5cf21f8 Bump github.com/docker/docker 80431f0 Bump golang.org/x/crypto from 0.5.0 to 0.6.0 Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-containers/podman-tui')
-rw-r--r--recipes-containers/podman-tui/podman-tui/0001-fix-workaround-field-rename-in-btrfs-progs-6.1.patch40
-rw-r--r--recipes-containers/podman-tui/podman-tui_git.bb6
2 files changed, 2 insertions, 44 deletions
diff --git a/recipes-containers/podman-tui/podman-tui/0001-fix-workaround-field-rename-in-btrfs-progs-6.1.patch b/recipes-containers/podman-tui/podman-tui/0001-fix-workaround-field-rename-in-btrfs-progs-6.1.patch
deleted file mode 100644
index 9b895c53..00000000
--- a/recipes-containers/podman-tui/podman-tui/0001-fix-workaround-field-rename-in-btrfs-progs-6.1.patch
+++ /dev/null
@@ -1,40 +0,0 @@
1From 246ba3062e8b551026aef2708eee747014ce5c52 Mon Sep 17 00:00:00 2001
2From: Rui Chen <rui@chenrui.dev>
3Date: Wed, 28 Dec 2022 18:26:39 -0500
4Subject: [PATCH] fix: workaround field rename in btrfs-progs 6.1
5
6same as kdave/btrfs-progs@0345143
7
8Upstream-Status: Inappropriate [embedded specific]
9
10Signed-off-by: Rui Chen <rui@chenrui.dev>
11---
12 drivers/btrfs/btrfs.go | 5 ++++-
13 1 file changed, 4 insertions(+), 1 deletion(-)
14
15diff --git a/drivers/btrfs/btrfs.go b/drivers/btrfs/btrfs.go
16index e8b16b858..3d9053297 100644
17--- a/drivers/btrfs/btrfs.go
18+++ b/drivers/btrfs/btrfs.go
19@@ -6,6 +6,9 @@ package btrfs
20 /*
21 #include <stdlib.h>
22 #include <dirent.h>
23+
24+// keep struct field name compatible with btrfs-progs < 6.1.
25+#define max_referenced max_rfer
26 #include <btrfs/ioctl.h>
27 #include <btrfs/ctree.h>
28
29@@ -382,7 +385,7 @@ func subvolLimitQgroup(path string, size uint64) error {
30 defer closeDir(dir)
31
32 var args C.struct_btrfs_ioctl_qgroup_limit_args
33- args.lim.max_referenced = C.__u64(size)
34+ args.lim.max_rfer = C.__u64(size)
35 args.lim.flags = C.BTRFS_QGROUP_LIMIT_MAX_RFER
36 _, _, errno := unix.Syscall(unix.SYS_IOCTL, getDirFd(dir), C.BTRFS_IOC_QGROUP_LIMIT,
37 uintptr(unsafe.Pointer(&args)))
38--
392.34.1
40
diff --git a/recipes-containers/podman-tui/podman-tui_git.bb b/recipes-containers/podman-tui/podman-tui_git.bb
index bfdd84fc..bbd1393b 100644
--- a/recipes-containers/podman-tui/podman-tui_git.bb
+++ b/recipes-containers/podman-tui/podman-tui_git.bb
@@ -18,7 +18,7 @@ DEPENDS = " \
18" 18"
19 19
20SRCREV_FORMAT = "podmantui_storage" 20SRCREV_FORMAT = "podmantui_storage"
21SRCREV_podmantui = "907b4d64ad9e1013597e234be79aae3eaf0f4f5b" 21SRCREV_podmantui = "24bdb2a9317a7061a40ea58be312a0133cae28ba"
22SRCREV_storage = "246ba3062e8b551026aef2708eee747014ce5c52" 22SRCREV_storage = "246ba3062e8b551026aef2708eee747014ce5c52"
23SRC_URI = " \ 23SRC_URI = " \
24 git://github.com/containers/podman-tui;protocol=https;name=podmantui;branch=main \ 24 git://github.com/containers/podman-tui;protocol=https;name=podmantui;branch=main \
@@ -27,8 +27,6 @@ SRC_URI = " \
27# the right commit, so we instead extract a patch and apply it to the tree 27# the right commit, so we instead extract a patch and apply it to the tree
28#SRC_URI += "git://github.com/containers/storage;protocol=https;name=storage;branch=main;destsuffix=git/src/import/vendor/github.com/containers/storage" 28#SRC_URI += "git://github.com/containers/storage;protocol=https;name=storage;branch=main;destsuffix=git/src/import/vendor/github.com/containers/storage"
29 29
30SRC_URI += "file://0001-fix-workaround-field-rename-in-btrfs-progs-6.1.patch;patchdir=src/import/vendor/github.com/containers/storage"
31
32LICENSE = "Apache-2.0" 30LICENSE = "Apache-2.0"
33LIC_FILES_CHKSUM = "file://src/import/LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" 31LIC_FILES_CHKSUM = "file://src/import/LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
34 32
@@ -36,7 +34,7 @@ GO_IMPORT = "import"
36 34
37S = "${WORKDIR}/git" 35S = "${WORKDIR}/git"
38 36
39PV = "v0.7.0+git${SRCPV}" 37PV = "v0.9.0+git${SRCPV}"
40 38
41PODMAN_PKG = "github.com/containers/podman-tui" 39PODMAN_PKG = "github.com/containers/podman-tui"
42 40