summaryrefslogtreecommitdiffstats
path: root/recipes-containers/oci-runtime-tools
diff options
context:
space:
mode:
authorJason Wessel <jason.wessel@windriver.com>2017-07-13 10:09:06 -0700
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-07-13 13:53:58 -0400
commita31f735bda504fd951b4b284a41fc4d6d154fa5e (patch)
tree925f079afddd42cd503c87f6e60cbb25fc596c28 /recipes-containers/oci-runtime-tools
parentcc3d8b9268e8eca1128a7f5d6349d818211c2097 (diff)
downloadmeta-virtualization-a31f735bda504fd951b4b284a41fc4d6d154fa5e.tar.gz
oci-runtime-tools, oci-runtime-spec: Uprev to runc 1.0-rc3 versions
The config.json has elements which have changed in the latest runc. These changes are not backward compatible with older versions of runc. Signed-off-by: Jason Wessel <jason.wessel@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-containers/oci-runtime-tools')
-rw-r--r--recipes-containers/oci-runtime-tools/oci-runtime-tools_git.bb12
1 files changed, 10 insertions, 2 deletions
diff --git a/recipes-containers/oci-runtime-tools/oci-runtime-tools_git.bb b/recipes-containers/oci-runtime-tools/oci-runtime-tools_git.bb
index 4f77dced..a3f8e665 100644
--- a/recipes-containers/oci-runtime-tools/oci-runtime-tools_git.bb
+++ b/recipes-containers/oci-runtime-tools/oci-runtime-tools_git.bb
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=b355a61a394a504dacde901c958f662c"
5 5
6SRC_URI = "git://github.com/opencontainers/runtime-tools.git" 6SRC_URI = "git://github.com/opencontainers/runtime-tools.git"
7 7
8SRCREV = "038b0c99b82f3c08de31f6b09e693eb24644affd" 8SRCREV = "15ec1df3f6607f4223ab3915547c184cf60a30dd"
9PV = "0.0.1+git${SRCPV}" 9PV = "0.0.1+git${SRCPV}"
10 10
11S = "${WORKDIR}/git" 11S = "${WORKDIR}/git"
@@ -16,7 +16,7 @@ inherit go
16do_compile() { 16do_compile() {
17 export GOARCH="${TARGET_GOARCH}" 17 export GOARCH="${TARGET_GOARCH}"
18 export GOROOT="${STAGING_LIBDIR_NATIVE}/${TARGET_SYS}/go" 18 export GOROOT="${STAGING_LIBDIR_NATIVE}/${TARGET_SYS}/go"
19 export GOPATH="${S}" 19 export GOPATH="${S}:${S}/vendor"
20 20
21 # Pass the needed cflags/ldflags so that cgo 21 # Pass the needed cflags/ldflags so that cgo
22 # can find the needed headers files and libraries 22 # can find the needed headers files and libraries
@@ -26,6 +26,14 @@ do_compile() {
26 export CGO_CFLAGS="${BUILDSDK_CFLAGS} --sysroot=${STAGING_DIR_TARGET}" 26 export CGO_CFLAGS="${BUILDSDK_CFLAGS} --sysroot=${STAGING_DIR_TARGET}"
27 export CGO_LDFLAGS="${BUILDSDK_LDFLAGS} --sysroot=${STAGING_DIR_TARGET}" 27 export CGO_LDFLAGS="${BUILDSDK_LDFLAGS} --sysroot=${STAGING_DIR_TARGET}"
28 28
29 # link fixups for compilation
30 rm -f ${S}/vendor/src
31 ln -sf ./ ${S}/vendor/src
32 mkdir -p ${S}/vendor/github.com/opencontainers/runtime-tools
33 ln -sf ../../../../generate ${S}/vendor/github.com/opencontainers/runtime-tools/generate
34 ln -sf ../../../../validate ${S}/vendor/github.com/opencontainers/runtime-tools/validate
35 ln -sf ../../../../cmd ${S}/vendor/github.com/opencontainers/runtime-tools/cmd
36
29 oe_runmake 37 oe_runmake
30} 38}
31 39