summaryrefslogtreecommitdiffstats
path: root/recipes-containers/oci-runtime-tools
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2017-03-20 21:59:10 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-03-20 23:15:01 -0400
commit7d66b0cc41110ef81fb94dc3bc6411b9570e5f12 (patch)
tree93f07dc0a676f5389c41ded50875792e20f5f6dc /recipes-containers/oci-runtime-tools
parenta050e7a61dac3d8fc2f8f68e763002b4a4664d71 (diff)
downloadmeta-virtualization-7d66b0cc41110ef81fb94dc3bc6411b9570e5f12.tar.gz
go: replace explicit go-cross* with inherit go bbclass
Rather than expliciting depending on go-cross-${TARGET_ARCH}, we can now simply inherit the oe-core go bbclass. This gets us the correct go dependencies and other variables properly set. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-containers/oci-runtime-tools')
-rw-r--r--recipes-containers/oci-runtime-tools/oci-runtime-tools_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-containers/oci-runtime-tools/oci-runtime-tools_git.bb b/recipes-containers/oci-runtime-tools/oci-runtime-tools_git.bb
index 7e5af380..a4c544d5 100644
--- a/recipes-containers/oci-runtime-tools/oci-runtime-tools_git.bb
+++ b/recipes-containers/oci-runtime-tools/oci-runtime-tools_git.bb
@@ -2,7 +2,6 @@ HOMEPAGE = "https://github.com/opencontainers/runtime-tools"
2SUMMARY = "oci-runtime-tool is a collection of tools for working with the OCI runtime specification" 2SUMMARY = "oci-runtime-tool is a collection of tools for working with the OCI runtime specification"
3LICENSE = "GPLv2" 3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=b355a61a394a504dacde901c958f662c" 4LIC_FILES_CHKSUM = "file://LICENSE;md5=b355a61a394a504dacde901c958f662c"
5DEPENDS = "go-cross-${TARGET_ARCH}"
6 5
7SRC_URI = "git://github.com/opencontainers/runtime-tools.git" 6SRC_URI = "git://github.com/opencontainers/runtime-tools.git"
8 7
@@ -12,6 +11,7 @@ PV = "0.0.1+git${SRCPV}"
12S = "${WORKDIR}/git" 11S = "${WORKDIR}/git"
13 12
14inherit go-osarchmap 13inherit go-osarchmap
14inherit go
15 15
16do_compile() { 16do_compile() {
17 export GOARCH="${TARGET_GOARCH}" 17 export GOARCH="${TARGET_GOARCH}"