summaryrefslogtreecommitdiffstats
path: root/recipes-containers/oci-runtime-spec
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2017-02-14 22:47:03 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-02-15 14:57:35 -0500
commitb18acd8bc403dc8781e3a25bb534e14ba0c38fda (patch)
tree64bbd8a342a0c58c18f1e82b0fcec0a87f491b48 /recipes-containers/oci-runtime-spec
parent88a28bbbebd8ea134d088d42bfe6c0044b40ecb1 (diff)
downloadmeta-virtualization-b18acd8bc403dc8781e3a25bb534e14ba0c38fda.tar.gz
oci: introduce oci-image-tools (and dependencies)
The oci image tools allow the easy manipulation of containers and bundles. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-containers/oci-runtime-spec')
-rw-r--r--recipes-containers/oci-runtime-spec/oci-runtime-spec_git.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/recipes-containers/oci-runtime-spec/oci-runtime-spec_git.bb b/recipes-containers/oci-runtime-spec/oci-runtime-spec_git.bb
new file mode 100644
index 00000000..82f852f9
--- /dev/null
+++ b/recipes-containers/oci-runtime-spec/oci-runtime-spec_git.bb
@@ -0,0 +1,41 @@
1DESCRIPTION = "The Open Container Initiative develops specifications for standards on Operating System process and application containers"
2HOMEPAGE = "https://github.com/opencontainers/runtime-spec"
3SECTION = "devel/go"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://src/${PKG_NAME}/LICENSE;md5=b355a61a394a504dacde901c958f662c"
6
7SRCNAME = "runtime-spec"
8
9PKG_NAME = "github.com/opencontainers/${SRCNAME}"
10SRC_URI = "git://${PKG_NAME}.git;destsuffix=git/src/${PKG_NAME}"
11
12SRCREV = "4af0c72f92aacf1b43618d7986197d8209fadf0b"
13PV = "v1.0.0-rc4+git${SRCPV}"
14
15S = "${WORKDIR}/git"
16
17# NO-OP the do compile rule because this recipe is source only.
18do_compile() {
19}
20
21do_install() {
22 install -d ${D}${prefix}/local/go/src/${PKG_NAME}
23 for j in $(cd ${S} && find src/${PKG_NAME} -name "*.go" -not -path "*/.tool/*"); do
24 if [ ! -d ${D}${prefix}/local/go/$(dirname $j) ]; then
25 mkdir -p ${D}${prefix}/local/go/$(dirname $j)
26 fi
27 cp $j ${D}${prefix}/local/go/$j
28 done
29 cp -r ${S}/src/${PKG_NAME}/LICENSE ${D}${prefix}/local/go/src/${PKG_NAME}/
30}
31
32SYSROOT_PREPROCESS_FUNCS += "runtime_spec_file_sysroot_preprocess"
33
34runtime_spec_file_sysroot_preprocess () {
35 install -d ${SYSROOT_DESTDIR}${prefix}/local/go/src/${PKG_NAME}
36 cp -r ${D}${prefix}/local/go/src/${PKG_NAME} ${SYSROOT_DESTDIR}${prefix}/local/go/src/$(dirname ${PKG_NAME})
37}
38
39FILES_${PN} += "${prefix}/local/go/src/${PKG_NAME}/*"
40
41CLEANBROKEN = "1" \ No newline at end of file