summaryrefslogtreecommitdiffstats
path: root/recipes-containers/oci-image-spec
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2019-06-27 03:54:50 +0000
committerBruce Ashfield <bruce.ashfield@gmail.com>2019-07-12 14:50:34 +0000
commitdf0abf029381587291621d28dd9716288d87c964 (patch)
treeb9f0545cd8118b3f9b7bfb324ae5c2095d85cce1 /recipes-containers/oci-image-spec
parentc8338c5568afcb033205c65ab232c8e94dcf98df (diff)
downloadmeta-virtualization-df0abf029381587291621d28dd9716288d87c964.tar.gz
oci-image-spec: uprev to v1.0.1
Updating the reference/source package of the oci-image-spec to v1.0.1. We also cleanup the install rule to be a bit simpler (by using --parents), and remove the .tool directory (which is new to this version), since it won't be package by default (and hence throws a QA error) and we don't need the .tool/* files. Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-containers/oci-image-spec')
-rw-r--r--recipes-containers/oci-image-spec/oci-image-spec_git.bb14
1 files changed, 7 insertions, 7 deletions
diff --git a/recipes-containers/oci-image-spec/oci-image-spec_git.bb b/recipes-containers/oci-image-spec/oci-image-spec_git.bb
index 92a83998..58057408 100644
--- a/recipes-containers/oci-image-spec/oci-image-spec_git.bb
+++ b/recipes-containers/oci-image-spec/oci-image-spec_git.bb
@@ -9,8 +9,8 @@ SRCNAME = "image-spec"
9PKG_NAME = "github.com/opencontainers/${SRCNAME}" 9PKG_NAME = "github.com/opencontainers/${SRCNAME}"
10SRC_URI = "git://${PKG_NAME}.git;destsuffix=git/src/${PKG_NAME}" 10SRC_URI = "git://${PKG_NAME}.git;destsuffix=git/src/${PKG_NAME}"
11 11
12SRCREV = "91d3eaabebcdc329edd9b4ff0f28f8f90022201f" 12SRCREV = "bd4f8fcb0979a663d8b97a1d4d9b030b3d2ca1fa"
13PV = "v1.0.0-rc4+git${SRCPV}" 13PV = "v1.0.1+git${SRCPV}"
14 14
15S = "${WORKDIR}/git" 15S = "${WORKDIR}/git"
16 16
@@ -21,11 +21,11 @@ do_compile() {
21do_install() { 21do_install() {
22 install -d ${D}${prefix}/local/go/src/${PKG_NAME} 22 install -d ${D}${prefix}/local/go/src/${PKG_NAME}
23 for j in $(cd ${S} && find src/${PKG_NAME} -name "*.go"); do 23 for j in $(cd ${S} && find src/${PKG_NAME} -name "*.go"); do
24 if [ ! -d ${D}${prefix}/local/go/$(dirname $j) ]; then 24 cp --parents $j ${D}${prefix}/local/go/
25 mkdir -p ${D}${prefix}/local/go/$(dirname $j)
26 fi
27 cp $j ${D}${prefix}/local/go/$j
28 done 25 done
26 # .tool isn't useful, so remote it.
27 rm -rf ${D}${prefix}/local/go/src/${PKG_NAME}/.tool/
28
29 cp -r ${S}/src/${PKG_NAME}/LICENSE ${D}${prefix}/local/go/src/${PKG_NAME}/ 29 cp -r ${S}/src/${PKG_NAME}/LICENSE ${D}${prefix}/local/go/src/${PKG_NAME}/
30} 30}
31 31
@@ -38,4 +38,4 @@ image_spec_file_sysroot_preprocess () {
38 38
39FILES_${PN} += "${prefix}/local/go/src/${PKG_NAME}/*" 39FILES_${PN} += "${prefix}/local/go/src/${PKG_NAME}/*"
40 40
41CLEANBROKEN = "1" \ No newline at end of file 41CLEANBROKEN = "1"