summaryrefslogtreecommitdiffstats
path: root/recipes-containers/lxc
diff options
context:
space:
mode:
authorfli <fupan.li@windriver.com>2016-07-15 03:05:03 -0700
committerBruce Ashfield <bruce.ashfield@windriver.com>2016-07-15 11:01:16 -0400
commitb657b65354d3146e7a2165a6818c8724ea4f28b9 (patch)
tree95090bed20af264141cfedbe4e694071ec69c5d6 /recipes-containers/lxc
parentcb16321ca63461f699a251d60f2d889617af76a8 (diff)
downloadmeta-virtualization-b657b65354d3146e7a2165a6818c8724ea4f28b9.tar.gz
lxc: fixes lxc segment fault issue on arm if it is compiled with GCC 5.2
If the lxc is compiled with gcc 5.2 -O2 optimization on arm, lxc-console/lxc-stop command always produce segment fault. The same issue also occurred on systemd: [YOCTO #8291] For lxc, after several testing, it only needs to disable schedule-insns2 to fix the segment fault issue. Signed-off-by: fli <fupan.li@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-containers/lxc')
-rw-r--r--recipes-containers/lxc/lxc_2.0.0.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/recipes-containers/lxc/lxc_2.0.0.bb b/recipes-containers/lxc/lxc_2.0.0.bb
index 5004b9e9..e4360573 100644
--- a/recipes-containers/lxc/lxc_2.0.0.bb
+++ b/recipes-containers/lxc/lxc_2.0.0.bb
@@ -49,6 +49,9 @@ EXTRA_OECONF += "--enable-log-src-basename"
49 49
50CFLAGS_append = " -Wno-error=deprecated-declarations" 50CFLAGS_append = " -Wno-error=deprecated-declarations"
51 51
52# disable problematic GCC 5.2 optimizations [YOCTO #8291]
53FULL_OPTIMIZATION_append_arm = " -fno-schedule-insns2"
54
52PACKAGECONFIG ??= "templates \ 55PACKAGECONFIG ??= "templates \
53 ${@bb.utils.contains('DISTRO_FEATURES', 'selinux', 'selinux', '', d)} \ 56 ${@bb.utils.contains('DISTRO_FEATURES', 'selinux', 'selinux', '', d)} \
54" 57"