summaryrefslogtreecommitdiffstats
path: root/recipes-containers/lxc
diff options
context:
space:
mode:
authorMaxin B. John <maxin.john@enea.com>2014-07-29 14:46:02 +0200
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-07-29 10:05:12 -0400
commit7605c820e49b4312f593095c17c5466845b7d9f4 (patch)
treef13c9bb2909a64732e4bf09959ee31baeea5aa0c /recipes-containers/lxc
parent81061497fd63be7d4c1d6b54f421164564f4ad89 (diff)
downloadmeta-virtualization-7605c820e49b4312f593095c17c5466845b7d9f4.tar.gz
lxc: Uprev to 1.0.5
Update lxc to latest available version: 1.0.5 Remove already upstreamed patches. Signed-off-by: Maxin B. John <maxin.john@enea.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-containers/lxc')
-rw-r--r--recipes-containers/lxc/files/config_network_type-set-macvlan-default-mode-to-priv.patch43
-rw-r--r--recipes-containers/lxc/files/lxc-busybox-follow-symlinks-when-inspecting-busybox-.patch27
-rw-r--r--recipes-containers/lxc/files/network.c-Add-missing-LXC_NET_NONE-option-refactor.patch38
-rw-r--r--recipes-containers/lxc/lxc_1.0.5.bb (renamed from recipes-containers/lxc/lxc_1.0.1.bb)9
4 files changed, 2 insertions, 115 deletions
diff --git a/recipes-containers/lxc/files/config_network_type-set-macvlan-default-mode-to-priv.patch b/recipes-containers/lxc/files/config_network_type-set-macvlan-default-mode-to-priv.patch
deleted file mode 100644
index 8cb321bb..00000000
--- a/recipes-containers/lxc/files/config_network_type-set-macvlan-default-mode-to-priv.patch
+++ /dev/null
@@ -1,43 +0,0 @@
1From 261658e80014c031852a024f8794dd7f2a2351ad Mon Sep 17 00:00:00 2001
2From: Bogdan Purcareata <bogdan.purcareata@freescale.com>
3Date: Fri, 28 Mar 2014 10:31:41 -0400
4Subject: [PATCH] config_network_type: set macvlan default mode to private
5
6If a default mode is not set, the container requires an explicit
7mode specified in the config file, otherwise creating the
8container fails.
9
10Signed-off-by: Bogdan Purcareata <bogdan.purcareata@freescale.com>
11Signed-off-by: Serge Hallyn <serge.hallyn@ubuntu.com>
12---
13 src/lxc/confile.c | 6 +++++-
14 1 file changed, 5 insertions(+), 1 deletion(-)
15
16diff --git a/src/lxc/confile.c b/src/lxc/confile.c
17index d6cf151..90fb344 100644
18--- a/src/lxc/confile.c
19+++ b/src/lxc/confile.c
20@@ -303,6 +303,8 @@ out:
21 return ret;
22 }
23
24+static int macvlan_mode(int *valuep, const char *value);
25+
26 static int config_network_type(const char *key, const char *value,
27 struct lxc_conf *lxc_conf)
28 {
29@@ -337,8 +339,10 @@ static int config_network_type(const char *key, const char *value,
30
31 if (!strcmp(value, "veth"))
32 netdev->type = LXC_NET_VETH;
33- else if (!strcmp(value, "macvlan"))
34+ else if (!strcmp(value, "macvlan")) {
35 netdev->type = LXC_NET_MACVLAN;
36+ macvlan_mode(&netdev->priv.macvlan_attr.mode, "private");
37+ }
38 else if (!strcmp(value, "vlan"))
39 netdev->type = LXC_NET_VLAN;
40 else if (!strcmp(value, "phys"))
41--
421.9.rc1
43
diff --git a/recipes-containers/lxc/files/lxc-busybox-follow-symlinks-when-inspecting-busybox-.patch b/recipes-containers/lxc/files/lxc-busybox-follow-symlinks-when-inspecting-busybox-.patch
deleted file mode 100644
index 6882c16e..00000000
--- a/recipes-containers/lxc/files/lxc-busybox-follow-symlinks-when-inspecting-busybox-.patch
+++ /dev/null
@@ -1,27 +0,0 @@
1From 50dbb8209bf65e4d24ccd06d3ca05004d0ddc63c Mon Sep 17 00:00:00 2001
2From: Bogdan Purcareata <bogdan.purcareata@freescale.com>
3Date: Mon, 24 Mar 2014 12:43:03 -0400
4Subject: [PATCH] lxc-busybox: follow symlinks when inspecting busybox binary
5
6Signed-off-by: Bogdan Purcareata <bogdan.purcareata@freescale.com>
7Signed-off-by: Serge Hallyn <serge.hallyn@ubuntu.com>
8---
9 templates/lxc-busybox.in | 2 +-
10 1 file changed, 1 insertion(+), 1 deletion(-)
11
12diff --git a/templates/lxc-busybox.in b/templates/lxc-busybox.in
13index e5a512a..246e743 100644
14--- a/templates/lxc-busybox.in
15+++ b/templates/lxc-busybox.in
16@@ -187,7 +187,7 @@ configure_busybox()
17 return 1
18 fi
19
20- file $(which busybox) | grep -q "statically linked"
21+ file -L $(which busybox) | grep -q "statically linked"
22 if [ $? -ne 0 ]; then
23 echo "warning : busybox is not statically linked."
24 echo "warning : The template script may not correctly"
25--
261.9.rc1
27
diff --git a/recipes-containers/lxc/files/network.c-Add-missing-LXC_NET_NONE-option-refactor.patch b/recipes-containers/lxc/files/network.c-Add-missing-LXC_NET_NONE-option-refactor.patch
deleted file mode 100644
index 81fde835..00000000
--- a/recipes-containers/lxc/files/network.c-Add-missing-LXC_NET_NONE-option-refactor.patch
+++ /dev/null
@@ -1,38 +0,0 @@
1From b343592b45c91db8c18e863fac5ab8eeb94445d6 Mon Sep 17 00:00:00 2001
2From: Bogdan Purcareata <bogdan.purcareata@freescale.com>
3Date: Wed, 26 Mar 2014 11:35:09 -0400
4Subject: [PATCH] network.c: Add missing LXC_NET_NONE option + refactor
5
6Add LXC_NET_NONE to known lxc_network_types, so parsing a config
7file with lxc.network.type = none does not result in failure
8(e.g. doc/examples/lxc-no-netns.conf). Options have also been
9reordered to match the enum in conf.h.
10
11Signed-off-by: Bogdan Purcareata <bogdan.purcareata@freescale.com>
12Signed-off-by: Serge Hallyn <serge.hallyn@ubuntu.com>
13---
14 src/lxc/network.c | 5 +++--
15 1 file changed, 3 insertions(+), 2 deletions(-)
16
17diff --git a/src/lxc/network.c b/src/lxc/network.c
18index 090b9bd..a9900de 100644
19--- a/src/lxc/network.c
20+++ b/src/lxc/network.c
21@@ -1202,11 +1202,12 @@ int lxc_bridge_attach(const char *bridge, const char *ifname)
22 }
23
24 static const char* const lxc_network_types[LXC_NET_MAXCONFTYPE + 1] = {
25+ [LXC_NET_EMPTY] = "empty",
26 [LXC_NET_VETH] = "veth",
27 [LXC_NET_MACVLAN] = "macvlan",
28- [LXC_NET_VLAN] = "vlan",
29 [LXC_NET_PHYS] = "phys",
30- [LXC_NET_EMPTY] = "empty",
31+ [LXC_NET_VLAN] = "vlan",
32+ [LXC_NET_NONE] = "none",
33 };
34
35 const char *lxc_net_type_to_str(int type)
36--
371.9.rc1
38
diff --git a/recipes-containers/lxc/lxc_1.0.1.bb b/recipes-containers/lxc/lxc_1.0.5.bb
index 4ef80d66..bea1ad08 100644
--- a/recipes-containers/lxc/lxc_1.0.1.bb
+++ b/recipes-containers/lxc/lxc_1.0.5.bb
@@ -3,7 +3,6 @@ SECTION = "console/utils"
3LICENSE = "GPLv2" 3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c" 4LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
5PRIORITY = "optional" 5PRIORITY = "optional"
6PR = "r4"
7DEPENDS = "libxml2 libcap" 6DEPENDS = "libxml2 libcap"
8RDEPENDS_${PN} = " \ 7RDEPENDS_${PN} = " \
9 rsync \ 8 rsync \
@@ -24,15 +23,12 @@ RDEPENDS_${PN}-ptest += "file make"
24 23
25SRC_URI = "http://linuxcontainers.org/downloads/${BPN}-${PV}.tar.gz \ 24SRC_URI = "http://linuxcontainers.org/downloads/${BPN}-${PV}.tar.gz \
26 file://lxc-1.0.0-disable-udhcp-from-busybox-template.patch \ 25 file://lxc-1.0.0-disable-udhcp-from-busybox-template.patch \
27 file://config_network_type-set-macvlan-default-mode-to-priv.patch \
28 file://lxc-busybox-follow-symlinks-when-inspecting-busybox-.patch \
29 file://network.c-Add-missing-LXC_NET_NONE-option-refactor.patch \
30 file://runtest.patch \ 26 file://runtest.patch \
31 file://run-ptest \ 27 file://run-ptest \
32 file://automake-ensure-VPATH-builds-work-correctly.patch \ 28 file://automake-ensure-VPATH-builds-work-correctly.patch \
33 " 29 "
34SRC_URI[md5sum] = "3c7379891e45713817ec873a167070b0" 30SRC_URI[md5sum] = "9d9af9e9e69a831cd50b58d91c786013"
35SRC_URI[sha256sum] = "17d8e5b575207b4fb57da0b8ba2d13f3e5ee20ce8ccd1259d6eae4bd5ca575b1" 31SRC_URI[sha256sum] = "02ac82e69a76d424e5443b9c577e84a8eaafcebf17cfd865eedee147e8ef8844"
36 32
37S = "${WORKDIR}/${BPN}-${PV}" 33S = "${WORKDIR}/${BPN}-${PV}"
38 34
@@ -76,4 +72,3 @@ pkg_postinst_${PN}() {
76 /etc/init.d/populate-volatile.sh update 72 /etc/init.d/populate-volatile.sh update
77 fi 73 fi
78} 74}
79