summaryrefslogtreecommitdiffstats
path: root/recipes-containers/kubernetes
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2019-09-02 16:36:48 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2019-09-03 16:01:06 -0400
commitf8568abe01de28e91adaeb636ee0ed89c1d1c8b8 (patch)
tree5f26b2d8a39ae579e8a02c99a448282c228e6b82 /recipes-containers/kubernetes
parentac0b214d5f41ef74559f528969f5597d4165ee92 (diff)
downloadmeta-virtualization-f8568abe01de28e91adaeb636ee0ed89c1d1c8b8.tar.gz
kubernetes: building unstripped binaries
Specify GOLDFLAGS as an empty string for building unstripped binaries, which allows you to use code debugging tools like delve. When GOLDFLAGS is unspecified, it defaults to "-s -w" which strips debug information. Other flags that can be used for GOLDFLAGS are documented at https://golang.org/cmd/link/ [1] [1] https://github.com/kubernetes/kubernetes/blob/master/build/root/Makefile#L82 Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-containers/kubernetes')
-rw-r--r--recipes-containers/kubernetes/kubernetes_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-containers/kubernetes/kubernetes_git.bb b/recipes-containers/kubernetes/kubernetes_git.bb
index 0aa7c009..cc377961 100644
--- a/recipes-containers/kubernetes/kubernetes_git.bb
+++ b/recipes-containers/kubernetes/kubernetes_git.bb
@@ -53,7 +53,7 @@ do_compile() {
53 export CGO_CFLAGS="${CFLAGS} --sysroot=${STAGING_DIR_TARGET}" 53 export CGO_CFLAGS="${CFLAGS} --sysroot=${STAGING_DIR_TARGET}"
54 export CGO_LDFLAGS="${LDFLAGS} --sysroot=${STAGING_DIR_TARGET}" 54 export CGO_LDFLAGS="${LDFLAGS} --sysroot=${STAGING_DIR_TARGET}"
55 # to limit what is built, use 'WHAT', i.e. make WHAT=cmd/kubelet 55 # to limit what is built, use 'WHAT', i.e. make WHAT=cmd/kubelet
56 make cross KUBE_BUILD_PLATFORMS=${GOOS}/${GOARCH} 56 make cross KUBE_BUILD_PLATFORMS=${GOOS}/${GOARCH} GOLDFLAGS=""
57} 57}
58 58
59do_install() { 59do_install() {