diff options
author | Bruce Ashfield <bruce.ashfield@gmail.com> | 2023-03-27 20:28:24 -0400 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@gmail.com> | 2023-03-27 22:13:43 -0400 |
commit | 8fcd81741740bd4702db999923160155f26e1f25 (patch) | |
tree | 78ff1db6297e6b9256548f35106a09e1265e72b3 /recipes-containers/kubernetes | |
parent | c5f7a698bc4b3c251f23b958d5037a66088e4a51 (diff) | |
download | meta-virtualization-8fcd81741740bd4702db999923160155f26e1f25.tar.gz |
kubernetes: update to v1.27.x-rc
Bumping kubernetes to the next release candidate (april 2023).
We refresh our $GO patch, drop the need to do release artifacts
preparation and add a new INSANE_SKIP for kubelet.
But otherwise, the build and content the same or similar.
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-containers/kubernetes')
-rw-r--r-- | recipes-containers/kubernetes/kubernetes/0001-build-golang.sh-convert-remaining-go-calls-to-use.patch | 20 | ||||
-rw-r--r-- | recipes-containers/kubernetes/kubernetes_git.bb | 14 |
2 files changed, 19 insertions, 15 deletions
diff --git a/recipes-containers/kubernetes/kubernetes/0001-build-golang.sh-convert-remaining-go-calls-to-use.patch b/recipes-containers/kubernetes/kubernetes/0001-build-golang.sh-convert-remaining-go-calls-to-use.patch index fed777b9..ae956794 100644 --- a/recipes-containers/kubernetes/kubernetes/0001-build-golang.sh-convert-remaining-go-calls-to-use.patch +++ b/recipes-containers/kubernetes/kubernetes/0001-build-golang.sh-convert-remaining-go-calls-to-use.patch | |||
@@ -10,11 +10,11 @@ Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> | |||
10 | hack/lib/golang.sh | 8 ++++---- | 10 | hack/lib/golang.sh | 8 ++++---- |
11 | 1 file changed, 4 insertions(+), 4 deletions(-) | 11 | 1 file changed, 4 insertions(+), 4 deletions(-) |
12 | 12 | ||
13 | Index: kubernetes-v1.24.0+git8b1b4db3834ddf7cf1b97137180f413cb9e2186f/hack/lib/golang.sh | 13 | Index: kubernetes/hack/lib/golang.sh |
14 | =================================================================== | 14 | =================================================================== |
15 | --- kubernetes-v1.24.0+git8b1b4db3834ddf7cf1b97137180f413cb9e2186f.orig/hack/lib/golang.sh | 15 | --- kubernetes.orig/hack/lib/golang.sh |
16 | +++ kubernetes-v1.24.0+git8b1b4db3834ddf7cf1b97137180f413cb9e2186f/hack/lib/golang.sh | 16 | +++ kubernetes/hack/lib/golang.sh |
17 | @@ -652,7 +652,7 @@ | 17 | @@ -689,7 +689,7 @@ |
18 | kube::golang::create_coverage_dummy_test "${package}" | 18 | kube::golang::create_coverage_dummy_test "${package}" |
19 | kube::util::trap_add "kube::golang::delete_coverage_dummy_test \"${package}\"" EXIT | 19 | kube::util::trap_add "kube::golang::delete_coverage_dummy_test \"${package}\"" EXIT |
20 | 20 | ||
@@ -23,23 +23,23 @@ Index: kubernetes-v1.24.0+git8b1b4db3834ddf7cf1b97137180f413cb9e2186f/hack/lib/g | |||
23 | -covermode count \ | 23 | -covermode count \ |
24 | -coverpkg k8s.io/...,k8s.io/kubernetes/vendor/k8s.io/... \ | 24 | -coverpkg k8s.io/...,k8s.io/kubernetes/vendor/k8s.io/... \ |
25 | "${build_args[@]}" \ | 25 | "${build_args[@]}" \ |
26 | @@ -664,13 +664,13 @@ | 26 | @@ -701,13 +701,13 @@ |
27 | done | 27 | done |
28 | if [[ "${#uncovered[@]}" != 0 ]]; then | 28 | if [[ "${#uncovered[@]}" != 0 ]]; then |
29 | V=2 kube::log::info "Building ${uncovered[*]} without coverage..." | 29 | V=2 kube::log::info "Building ${uncovered[*]} without coverage..." |
30 | - go install "${build_args[@]}" "${uncovered[@]}" | 30 | - GO111MODULE=on GOPROXY=off go install "${build_args[@]}" "${uncovered[@]}" |
31 | + $GO install "${build_args[@]}" "${uncovered[@]}" | 31 | + GO111MODULE=on GOPROXY=off $GO install "${build_args[@]}" "${uncovered[@]}" |
32 | else | 32 | else |
33 | V=2 kube::log::info "Nothing to build without coverage." | 33 | V=2 kube::log::info "Nothing to build without coverage." |
34 | fi | 34 | fi |
35 | else | 35 | else |
36 | V=2 kube::log::info "Coverage is disabled." | 36 | V=2 kube::log::info "Coverage is disabled." |
37 | - go install "${build_args[@]}" "$@" | 37 | - GO111MODULE=on GOPROXY=off go install "${build_args[@]}" "$@" |
38 | + $GO install "${build_args[@]}" "$@" | 38 | + GO111MODULE=on GOPROXY=off $GO install "${build_args[@]}" "$@" |
39 | fi | 39 | fi |
40 | } | 40 | } |
41 | 41 | ||
42 | @@ -729,7 +729,7 @@ | 42 | @@ -769,7 +769,7 @@ |
43 | testpkg=$(dirname "${test}") | 43 | testpkg=$(dirname "${test}") |
44 | 44 | ||
45 | mkdir -p "$(dirname "${outfile}")" | 45 | mkdir -p "$(dirname "${outfile}")" |
diff --git a/recipes-containers/kubernetes/kubernetes_git.bb b/recipes-containers/kubernetes/kubernetes_git.bb index 31ef1351..b00964d2 100644 --- a/recipes-containers/kubernetes/kubernetes_git.bb +++ b/recipes-containers/kubernetes/kubernetes_git.bb | |||
@@ -5,9 +5,9 @@ applications across multiple hosts, providing basic mechanisms for deployment, \ | |||
5 | maintenance, and scaling of applications. \ | 5 | maintenance, and scaling of applications. \ |
6 | " | 6 | " |
7 | 7 | ||
8 | PV = "v1.24.0+git${SRCREV_kubernetes}" | 8 | PV = "v1.27.0-rc+git${SRCREV_kubernetes}" |
9 | SRCREV_kubernetes = "8b1b4db3834ddf7cf1b97137180f413cb9e2186f" | 9 | SRCREV_kubernetes = "bcd6658c10cdf42a9eea1748b8742e8995b55ca7" |
10 | SRCREV_kubernetes-release = "7c1aa83dac555de6f05500911467b70aca4949f0" | 10 | SRCREV_kubernetes-release = "21382abdbfa8e6a43fd417306fa649cb651cc06e" |
11 | PE = "1" | 11 | PE = "1" |
12 | 12 | ||
13 | BBCLASSEXTEND = "devupstream:target" | 13 | BBCLASSEXTEND = "devupstream:target" |
@@ -22,7 +22,7 @@ PV:class-devupstream = "v1.23-alpha+git${SRCPV}" | |||
22 | 22 | ||
23 | SRCREV_FORMAT ?= "kubernetes_release" | 23 | SRCREV_FORMAT ?= "kubernetes_release" |
24 | 24 | ||
25 | SRC_URI = "git://github.com/kubernetes/kubernetes.git;branch=release-1.24;name=kubernetes;protocol=https;destsuffix=git/src/github.com/kubernetes/kubernetes \ | 25 | SRC_URI = "git://github.com/kubernetes/kubernetes.git;branch=release-1.27;name=kubernetes;protocol=https;destsuffix=git/src/github.com/kubernetes/kubernetes \ |
26 | git://github.com/kubernetes/release;branch=master;name=kubernetes-release;destsuffix=git/release;protocol=https" | 26 | git://github.com/kubernetes/release;branch=master;name=kubernetes-release;destsuffix=git/release;protocol=https" |
27 | 27 | ||
28 | SRC_URI:append = " \ | 28 | SRC_URI:append = " \ |
@@ -69,7 +69,10 @@ do_compile() { | |||
69 | export CC="${BUILD_CC}" | 69 | export CC="${BUILD_CC}" |
70 | export LD="${BUILD_LD}" | 70 | export LD="${BUILD_LD}" |
71 | 71 | ||
72 | make generated_files GO="go" KUBE_BUILD_PLATFORMS="${HOST_GOOS}/${BUILD_GOARCH}" | 72 | # make generated_files GO="go" KUBE_BUILD_PLATFORMS="${HOST_GOOS}/${BUILD_GOARCH}" |
73 | # is replaced by: | ||
74 | # ./hack/update-codegen.sh | ||
75 | # but we don't appear to need either anymore, but we leave them as a placeholder/reminder | ||
73 | 76 | ||
74 | # Build the target binaries | 77 | # Build the target binaries |
75 | export GOARCH="${TARGET_GOARCH}" | 78 | export GOARCH="${TARGET_GOARCH}" |
@@ -115,6 +118,7 @@ PACKAGES =+ "kubeadm kubectl kubelet kube-proxy ${PN}-misc ${PN}-host" | |||
115 | ALLOW_EMPTY:${PN} = "1" | 118 | ALLOW_EMPTY:${PN} = "1" |
116 | INSANE_SKIP:${PN} += "ldflags already-stripped" | 119 | INSANE_SKIP:${PN} += "ldflags already-stripped" |
117 | INSANE_SKIP:${PN}-misc += "ldflags already-stripped textrel" | 120 | INSANE_SKIP:${PN}-misc += "ldflags already-stripped textrel" |
121 | INSANE_SKIP:kubelet += "ldflags already-stripped" | ||
118 | 122 | ||
119 | # Note: we are explicitly *not* adding docker to the rdepends, since we allow | 123 | # Note: we are explicitly *not* adding docker to the rdepends, since we allow |
120 | # backends like cri-o to be used. | 124 | # backends like cri-o to be used. |