summaryrefslogtreecommitdiffstats
path: root/recipes-containers/kubernetes/kubernetes_git.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2020-08-12 17:01:38 +0000
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-08-12 13:03:46 -0400
commit535a3e82791322b0484ac4a6a05600afe3cf0647 (patch)
treec30d8b26b1f82930873169ce88b4b709bbe22951 /recipes-containers/kubernetes/kubernetes_git.bb
parentdc08df210c16bc7d2a06065a3c43ef9078f986c9 (diff)
downloadmeta-virtualization-535a3e82791322b0484ac4a6a05600afe3cf0647.tar.gz
k8s: fix 32bit ARM build
Remove the remaining 'go' calls, and replace them with $GO. We also must explicitly pass "GO='go'" on the host side build call. This avoids the gnu-stubs header file issues, since the 'go' binary cannot use the sysroot. Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-containers/kubernetes/kubernetes_git.bb')
-rw-r--r--recipes-containers/kubernetes/kubernetes_git.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/recipes-containers/kubernetes/kubernetes_git.bb b/recipes-containers/kubernetes/kubernetes_git.bb
index 2cc2bcdf..76c82026 100644
--- a/recipes-containers/kubernetes/kubernetes_git.bb
+++ b/recipes-containers/kubernetes/kubernetes_git.bb
@@ -14,6 +14,7 @@ SRC_URI = "git://github.com/kubernetes/kubernetes.git;branch=release-1.19;name=k
14 file://0001-hack-lib-golang.sh-use-CC-from-environment.patch \ 14 file://0001-hack-lib-golang.sh-use-CC-from-environment.patch \
15 file://0001-cross-don-t-build-tests-by-default.patch \ 15 file://0001-cross-don-t-build-tests-by-default.patch \
16 file://0001-generate-bindata-unset-GOBIN.patch \ 16 file://0001-generate-bindata-unset-GOBIN.patch \
17 file://0001-build-golang.sh-convert-remaining-go-calls-to-use.patch \
17 " 18 "
18 19
19DEPENDS += "rsync-native \ 20DEPENDS += "rsync-native \
@@ -50,7 +51,7 @@ do_compile() {
50 export CC="${BUILD_CC}" 51 export CC="${BUILD_CC}"
51 export LD="${BUILD_LD}" 52 export LD="${BUILD_LD}"
52 53
53 make generated_files KUBE_BUILD_PLATFORMS="${HOST_GOOS}/${BUILD_GOARCH}" 54 make generated_files GO="go" KUBE_BUILD_PLATFORMS="${HOST_GOOS}/${BUILD_GOARCH}"
54 55
55 # Build the target binaries 56 # Build the target binaries
56 export GOARCH="${TARGET_GOARCH}" 57 export GOARCH="${TARGET_GOARCH}"
@@ -65,7 +66,7 @@ do_compile() {
65 export GOBIN="" 66 export GOBIN=""
66 67
67 # to limit what is built, use 'WHAT', i.e. make WHAT=cmd/kubelet 68 # to limit what is built, use 'WHAT', i.e. make WHAT=cmd/kubelet
68 make cross GO=${GO} KUBE_BUILD_PLATFORMS=${GOOS}/${GOARCH} GOLDFLAGS="" 69 make cross CGO_FLAGS=${CGO_FLAGS} GO=${GO} KUBE_BUILD_PLATFORMS=${GOOS}/${GOARCH} GOLDFLAGS=""
69} 70}
70 71
71do_install() { 72do_install() {