summaryrefslogtreecommitdiffstats
path: root/recipes-containers/k3s
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2020-11-10 14:21:14 -0500
committerBruce Ashfield <bruce.ashfield@gmail.com>2021-03-15 23:15:42 -0400
commita0c94280cf4eb35ef05f8d91c66c75746d9e25b0 (patch)
tree7c912e5fb948d346e68c3f24d9cc83257738c40a /recipes-containers/k3s
parentaf1690d85199505786b88340cc78f9754fd2b31c (diff)
downloadmeta-virtualization-a0c94280cf4eb35ef05f8d91c66c75746d9e25b0.tar.gz
k3s: add kernel module rrecommends (and PV fix)
Fixing up the PV to use SRCPV for tracking future version bumps, if the tree is dirty or not, git will tell us. We also add some additional kernel module rrecommends, so that the tools called by k3s can find the support they need (mainly iptools) Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-containers/k3s')
-rw-r--r--recipes-containers/k3s/k3s_git.bb7
1 files changed, 5 insertions, 2 deletions
diff --git a/recipes-containers/k3s/k3s_git.bb b/recipes-containers/k3s/k3s_git.bb
index dca187e0..ea5ed75d 100644
--- a/recipes-containers/k3s/k3s_git.bb
+++ b/recipes-containers/k3s/k3s_git.bb
@@ -3,7 +3,6 @@ DESCRIPTION = "Lightweight Kubernetes, intended to be a fully compliant Kubernet
3HOMEPAGE = "https://k3s.io/" 3HOMEPAGE = "https://k3s.io/"
4LICENSE = "Apache-2.0" 4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://${S}/src/import/LICENSE;md5=2ee41112a44fe7014dce33e26468ba93" 5LIC_FILES_CHKSUM = "file://${S}/src/import/LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
6PV = "v1.18.9+k3s1-dirty"
7 6
8SRC_URI = "git://github.com/rancher/k3s.git;branch=release-1.18;name=k3s \ 7SRC_URI = "git://github.com/rancher/k3s.git;branch=release-1.18;name=k3s \
9 file://k3s.service \ 8 file://k3s.service \
@@ -16,6 +15,8 @@ SRC_URI = "git://github.com/rancher/k3s.git;branch=release-1.18;name=k3s \
16SRC_URI[k3s.md5sum] = "363d3a08dc0b72ba6e6577964f6e94a5" 15SRC_URI[k3s.md5sum] = "363d3a08dc0b72ba6e6577964f6e94a5"
17SRCREV_k3s = "630bebf94b9dce6b8cd3d402644ed023b3af8f90" 16SRCREV_k3s = "630bebf94b9dce6b8cd3d402644ed023b3af8f90"
18 17
18PV = "v1.18.9+git${SRCPV}"
19
19CNI_NETWORKING_FILES ?= "${WORKDIR}/cni-containerd-net.conf" 20CNI_NETWORKING_FILES ?= "${WORKDIR}/cni-containerd-net.conf"
20 21
21inherit go 22inherit go
@@ -68,10 +69,12 @@ SYSTEMD_AUTO_ENABLE_${PN}-agent = "disable"
68FILES_${PN}-agent = "${BIN_PREFIX}/bin/k3s-agent" 69FILES_${PN}-agent = "${BIN_PREFIX}/bin/k3s-agent"
69FILES_${PN} += "${BIN_PREFIX}/bin/*" 70FILES_${PN} += "${BIN_PREFIX}/bin/*"
70 71
71RDEPENDS_${PN} = "cni conntrack-tools coreutils findutils iproute2 ipset virtual/containerd" 72RDEPENDS_${PN} = "k3s-cni conntrack-tools coreutils findutils iptables iproute2 ipset virtual/containerd"
72RDEPENDS_${PN}-server = "${PN}" 73RDEPENDS_${PN}-server = "${PN}"
73RDEPENDS_${PN}-agent = "${PN}" 74RDEPENDS_${PN}-agent = "${PN}"
74 75
76RRECOMMENDS_${PN} = "kernel-module-xt-comment kernel-module-xt-mark kernel-module-xt-connmark kernel-module-vxlan"
77
75RCONFLICTS_${PN} = "kubectl" 78RCONFLICTS_${PN} = "kubectl"
76 79
77INHIBIT_PACKAGE_STRIP = "1" 80INHIBIT_PACKAGE_STRIP = "1"