summaryrefslogtreecommitdiffstats
path: root/recipes-containers/docker
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2023-09-06 02:53:59 +0000
committerBruce Ashfield <bruce.ashfield@gmail.com>2023-09-15 17:30:40 +0000
commit103695c7b9578f3380b5b4ab851548c3d9aaef4a (patch)
treee26dc00df3404f317d7369c1b6dc22ba2a117b36 /recipes-containers/docker
parent81fb35712574d2f1caf21803cbc4a2b71e143263 (diff)
downloadmeta-virtualization-103695c7b9578f3380b5b4ab851548c3d9aaef4a.tar.gz
docker-moby: update to 24.0.6
Bumping moby to version v24.0.6, which comprises the following commits: c35376c455 volume/local: Don't unmount, restore mounted status 5d4cc0b5b5 integration/liveRestore: Check volume content 1d983e2e8a update golangci-lint to v1.54.2 d2e9a19358 CONTRIBUTING.md: update links to golang docs and blog 73f6053bb3 api: swagger: update link to Go documentation de13951b9d docs/api: update links to Go documentation 377af4c9b4 Dockerfile: Windows: update Golang download domains to cut down redirects 088cec8f0f hack: update link to GOPATH documentation ed2f5d1d85 c8d/builder: Don't drop fields from created image 1d10e8633d daemon: Handle NotFound when deleting container lease 63422515ba c8d/run: Allow running container without image 49671250f6 c8d/commit: Don't produce an empty layer b83f5a89f4 Don't return an error if the lease is not found 4ac2355d62 hack: use long SHA for DOCKER_GITCOMMIT ac2a80fcc3 ci(bin-image): clean up metadata 5eef5a7f59 ci(bin-image): clean up env var handling aaf84dd4cf remove Dockerfile.e2e a99e62fa3d distribution: show image schema deprecation on all registries e239799583 distribution: update warning for deprecated image formats bb22b8a418 ci(bin-image): check repo origin fb6784bdf0 gha: set 10-minute timeout on "report" actions 74bf46aea6 c8d/diff: Reuse mount, mount parent as read-only b76a0c7d00 c8d/export: Use ref counted mounter 54953f2f5a integration: Add test for not breaking overlayfs 3897724f4a volume/local: Fix debug log typo 0c131f58ba ci(bin-image): populate DOCKER_GITCOMMIT, take 2 448ae33f87 ci(bin-image): populate DOCKER_GITCOMMIT 3ce0dc7e35 bakefile: Remove default value of DOCKER_GITCOMMIT 600aa7b7a5 c8d/inspect: Ignore manifest with missing config 5d2c383d72 remove s390x and ppc64ls pipelines 15bd07b4fd update runc binary to v1.1.9 cc39fb9f6b Integration test for capabilities bf2b8a05a0 Do not drop effective&permitted set e67f9dadc6 hack/make/.binary: use with-go-mod.sh 314b84b023 hack: enable Go modules when building dockerd and docker-proxy 72947f5022 hack: use Git-free ROOTDIR convention 7e7bc0f1bc vendor: github.com/containerd/containerd v1.6.22 5f0df8c534 vendor github.com/containerd/ttrpc v1.1.2 25b709df48 windows: fix --register-service when executed from within binary directory b7d1e98ae7 libnet/d/bridge: Allow IPv6 ICC from any IP address 749e687e1b integration/windows: Unskip some kill tests 128838227e hack/test: Don't fail-fast before integration-cli b7c5385b81 update to go1.20.7 4cd50eb1ed TestDaemonProxy: use new scanners to check logs a49bca97df Fix daemon proxy test for "reload sanitized" d6536d44e9 TestDaemonProxy: check proxy settings early a6f8e97342 Improve test daemon logging Bumping docker-cli to version v24.0.6, which comprises the following commits: fab55e13c cli/command/system: fix "docker events" not supporting --format=json d3485b9e9 cli/registry: client.iterateEndpoints: remove check for APIVersion1 613380299 cli/registry: fix client.pullManifestList not de-referencing manifest b83959e00 force TestNewHistoryCommandSuccess to use UTC timezone 28a08a22b un-skip history test and fix golden mismatches 8e0393932 update cli-docs-tool to v0.6.0 efd052eb8 docs/reference: run.md: remove stray whitespace d9770a962 adding -c option for docker run/build in manpages 6efe73abe cli/command/manifest: update link to Go documentation d97753101 man: update links to Go documentation e9f843bf0 docs/reference: update links to Go documentation cfbaee468 CONTRIBUTING.md: update links daeee4697 update flag-description for --cgroup-parent 08ad72160 Update docs/command output for volume pruning 3c4fe7b3e docs: add missing docs for "DOCKER_TLS" env-var dc45bcc99 Stop slowing bash init by caching plugins path slowly 710dd00e9 replace dockerfile/dockerignore with patternmatcher/ignorefile bf632329d vendor: github.com/moby/patternmatcher v0.6.0 3c6c0bce1 cli/registry/client: set actions when authn with token 65655cc26 cmd/docker: areFlagsSupported: don't Ping if not needed 11606268f login: Add message about using PATs a8987063b docs: document special host-gateway value for add-host c0e376854 update to go1.20.7 We refresh one patch to adapt to the new build script structure. Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-containers/docker')
-rw-r--r--recipes-containers/docker/docker-moby_git.bb6
-rw-r--r--recipes-containers/docker/files/0001-dynbinary-use-go-cross-compiler.patch20
2 files changed, 13 insertions, 13 deletions
diff --git a/recipes-containers/docker/docker-moby_git.bb b/recipes-containers/docker/docker-moby_git.bb
index aacfe6a0..b619a780 100644
--- a/recipes-containers/docker/docker-moby_git.bb
+++ b/recipes-containers/docker/docker-moby_git.bb
@@ -44,9 +44,9 @@ DESCRIPTION = "Linux container runtime \
44# so we get that tag, and make it our SRCREVS: 44# so we get that tag, and make it our SRCREVS:
45# 45#
46 46
47SRCREV_moby = "00e46f85f6e46bb4b02c33da253f901c473794e9" 47SRCREV_moby = "1a7969545d73537545645f5cd2c79b7a77e7d39f"
48SRCREV_libnetwork = "67e0588f1ddfaf2faf4c8cae8b7ea2876434d91c" 48SRCREV_libnetwork = "67e0588f1ddfaf2faf4c8cae8b7ea2876434d91c"
49SRCREV_cli = "b74562d917779426ae5010dd8d8bd9140075a741" 49SRCREV_cli = "ed223bc820ee9bb7005a333013b86203a9e1bc23"
50SRCREV_FORMAT = "moby_libnetwork" 50SRCREV_FORMAT = "moby_libnetwork"
51SRC_URI = "\ 51SRC_URI = "\
52 git://github.com/moby/moby.git;branch=24.0;name=moby;protocol=https \ 52 git://github.com/moby/moby.git;branch=24.0;name=moby;protocol=https \
@@ -66,7 +66,7 @@ require docker.inc
66LICENSE = "Apache-2.0" 66LICENSE = "Apache-2.0"
67LIC_FILES_CHKSUM = "file://src/import/LICENSE;md5=4859e97a9c7780e77972d989f0823f28" 67LIC_FILES_CHKSUM = "file://src/import/LICENSE;md5=4859e97a9c7780e77972d989f0823f28"
68 68
69DOCKER_VERSION = "24.0.5" 69DOCKER_VERSION = "24.0.6"
70PV = "${DOCKER_VERSION}+git${SRCREV_moby}" 70PV = "${DOCKER_VERSION}+git${SRCREV_moby}"
71 71
72CVE_PRODUCT = "docker mobyproject:moby" 72CVE_PRODUCT = "docker mobyproject:moby"
diff --git a/recipes-containers/docker/files/0001-dynbinary-use-go-cross-compiler.patch b/recipes-containers/docker/files/0001-dynbinary-use-go-cross-compiler.patch
index ea8f4c5e..696eeaa7 100644
--- a/recipes-containers/docker/files/0001-dynbinary-use-go-cross-compiler.patch
+++ b/recipes-containers/docker/files/0001-dynbinary-use-go-cross-compiler.patch
@@ -35,11 +35,11 @@ Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
35 hack/make/.binary | 37 ++++++++----------------------------- 35 hack/make/.binary | 37 ++++++++-----------------------------
36 1 file changed, 8 insertions(+), 29 deletions(-) 36 1 file changed, 8 insertions(+), 29 deletions(-)
37 37
38diff --git a/hack/make/.binary b/hack/make/.binary 38Index: import/hack/make/.binary
39index 39c00cd50c..de32ad1cc7 100644 39===================================================================
40--- a/hack/make/.binary 40--- import.orig/hack/make/.binary
41+++ b/hack/make/.binary 41+++ import/hack/make/.binary
42@@ -3,7 +3,7 @@ set -e 42@@ -3,7 +3,7 @@
43 43
44 # a helper to provide ".exe" when it's appropriate 44 # a helper to provide ".exe" when it's appropriate
45 binary_extension() { 45 binary_extension() {
@@ -48,7 +48,7 @@ index 39c00cd50c..de32ad1cc7 100644
48 echo -n '.exe' 48 echo -n '.exe'
49 fi 49 fi
50 } 50 }
51@@ -16,33 +16,12 @@ source "${MAKEDIR}/.go-autogen" 51@@ -16,33 +16,12 @@
52 ( 52 (
53 export GOGC=${DOCKER_BUILD_GOGC:-1000} 53 export GOGC=${DOCKER_BUILD_GOGC:-1000}
54 54
@@ -83,7 +83,7 @@ index 39c00cd50c..de32ad1cc7 100644
83 windows/arm64 | linux/mips* | linux/ppc64) ;; 83 windows/arm64 | linux/mips* | linux/ppc64) ;;
84 *) 84 *)
85 BUILDFLAGS+=("-buildmode=pie") 85 BUILDFLAGS+=("-buildmode=pie")
86@@ -54,11 +33,11 @@ source "${MAKEDIR}/.go-autogen" 86@@ -66,11 +45,11 @@
87 # only necessary for non-sandboxed invocation where TARGETPLATFORM is empty 87 # only necessary for non-sandboxed invocation where TARGETPLATFORM is empty
88 PLATFORM_NAME=$TARGETPLATFORM 88 PLATFORM_NAME=$TARGETPLATFORM
89 if [ -z "$PLATFORM_NAME" ]; then 89 if [ -z "$PLATFORM_NAME" ]; then
@@ -100,12 +100,12 @@ index 39c00cd50c..de32ad1cc7 100644
100 fi 100 fi
101 fi 101 fi
102 102
103@@ -66,7 +45,7 @@ source "${MAKEDIR}/.go-autogen" 103@@ -78,7 +57,7 @@
104 if [ -n "$DOCKER_DEBUG" ]; then 104 if [ -n "$DOCKER_DEBUG" ]; then
105 set -x 105 set -x
106 fi 106 fi
107- go build -o "$DEST/$BINARY_FULLNAME" "${BUILDFLAGS[@]}" -ldflags "$LDFLAGS $LDFLAGS_STATIC $DOCKER_LDFLAGS" ${GO_PACKAGE} 107- ./hack/with-go-mod.sh go build -mod=vendor -modfile=vendor.mod -o "$DEST/$BINARY_FULLNAME" "${BUILDFLAGS[@]}" -ldflags "$LDFLAGS $LDFLAGS_STATIC $DOCKER_LDFLAGS" "$GO_PACKAGE"
108+ ${GO} build -trimpath -o "$DEST/$BINARY_FULLNAME" "${BUILDFLAGS[@]}" -ldflags "$LDFLAGS $LDFLAGS_STATIC $DOCKER_LDFLAGS" ${GO_PACKAGE} 108+ ./hack/with-go-mod.sh ${GO} build -trimpath -mod=vendor -modfile=vendor.mod -o "$DEST/$BINARY_FULLNAME" "${BUILDFLAGS[@]}" -ldflags "$LDFLAGS $LDFLAGS_STATIC $DOCKER_LDFLAGS" "$GO_PACKAGE"
109 ) 109 )
110 110
111 echo "Created binary: $DEST/$BINARY_FULLNAME" 111 echo "Created binary: $DEST/$BINARY_FULLNAME"