diff options
author | Bruce Ashfield <bruce.ashfield@windriver.com> | 2017-03-20 21:59:10 -0400 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@windriver.com> | 2017-03-20 23:15:01 -0400 |
commit | 7d66b0cc41110ef81fb94dc3bc6411b9570e5f12 (patch) | |
tree | 93f07dc0a676f5389c41ded50875792e20f5f6dc /recipes-containers/docker-distribution/docker-distribution_git.bb | |
parent | a050e7a61dac3d8fc2f8f68e763002b4a4664d71 (diff) | |
download | meta-virtualization-7d66b0cc41110ef81fb94dc3bc6411b9570e5f12.tar.gz |
go: replace explicit go-cross* with inherit go bbclass
Rather than expliciting depending on go-cross-${TARGET_ARCH}, we
can now simply inherit the oe-core go bbclass. This gets us the
correct go dependencies and other variables properly set.
Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-containers/docker-distribution/docker-distribution_git.bb')
-rw-r--r-- | recipes-containers/docker-distribution/docker-distribution_git.bb | 5 |
1 files changed, 2 insertions, 3 deletions
diff --git a/recipes-containers/docker-distribution/docker-distribution_git.bb b/recipes-containers/docker-distribution/docker-distribution_git.bb index e86d4ff9..b8181c7a 100644 --- a/recipes-containers/docker-distribution/docker-distribution_git.bb +++ b/recipes-containers/docker-distribution/docker-distribution_git.bb | |||
@@ -3,9 +3,6 @@ SUMMARY = "The Docker toolset to pack, ship, store, and deliver content" | |||
3 | LICENSE = "Apache-2.0" | 3 | LICENSE = "Apache-2.0" |
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=d2794c0df5b907fdace235a619d80314" | 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=d2794c0df5b907fdace235a619d80314" |
5 | 5 | ||
6 | DEPENDS = "go-cross-${TARGET_ARCH} \ | ||
7 | " | ||
8 | |||
9 | SRCREV_distribution="0810eba2adf048b77621472991211924d9ec31c5" | 6 | SRCREV_distribution="0810eba2adf048b77621472991211924d9ec31c5" |
10 | SRC_URI = "git://github.com/docker/distribution.git;branch=master;name=distribution;destsuffix=git/src/github.com/docker/distribution \ | 7 | SRC_URI = "git://github.com/docker/distribution.git;branch=master;name=distribution;destsuffix=git/src/github.com/docker/distribution \ |
11 | file://docker-registry.service \ | 8 | file://docker-registry.service \ |
@@ -17,6 +14,7 @@ PV = "v2.6.0-rc+git${SRCPV}" | |||
17 | S = "${WORKDIR}/git/src/github.com/docker/distribution" | 14 | S = "${WORKDIR}/git/src/github.com/docker/distribution" |
18 | 15 | ||
19 | inherit go-osarchmap | 16 | inherit go-osarchmap |
17 | inherit go | ||
20 | 18 | ||
21 | # This disables seccomp and apparmor, which are on by default in the | 19 | # This disables seccomp and apparmor, which are on by default in the |
22 | # go package. | 20 | # go package. |
@@ -32,6 +30,7 @@ do_compile() { | |||
32 | export CFLAGS="" | 30 | export CFLAGS="" |
33 | export LDFLAGS="" | 31 | export LDFLAGS="" |
34 | export CGO_CFLAGS="${BUILDSDK_CFLAGS} --sysroot=${STAGING_DIR_TARGET}" | 32 | export CGO_CFLAGS="${BUILDSDK_CFLAGS} --sysroot=${STAGING_DIR_TARGET}" |
33 | export GO_GCFLAGS="" | ||
35 | export CGO_LDFLAGS="${BUILDSDK_LDFLAGS} --sysroot=${STAGING_DIR_TARGET}" | 34 | export CGO_LDFLAGS="${BUILDSDK_LDFLAGS} --sysroot=${STAGING_DIR_TARGET}" |
36 | 35 | ||
37 | oe_runmake binaries | 36 | oe_runmake binaries |